Jump to content

Why do I sink through chairs? It's embarrassing


Recommended Posts

Posted (edited)

Apologies in advance if this should be in the 'Your Avatar' forum?  Happy to move it there?

But anyone know why this happens, or how to avoid it happening - it's getting embarrassing?

So - Whenver I sit or lie on anything (chairs, beds, beach towels, cars and boats, etc) I start out being sat totally normal - in the right position - looking normal and everthing fine.  But then after about 15 - 30 secods, I suddenly 'sink' into the chair.  The only way to then get back to sitting normal, is to EITHER use the adjust setting in the sitter control box (which takes forever).  OR if I turn my (VISTA) AO off, I then also return to a normal sitting position.

It's a real pain to have to remember to do this every single time I want to sit / lie on anything.  Or is it just the way it is?  Or is there a setting I can change to avoid this happening.  And is it just me, or does this happen to eveyone?

Example Video GIF below shows me sitting normally, and then suddenly sinking,  (Which happneed about 30 seconds after sitting).  I then return to normal if I turn my AO off (as I did  shown right at the end of video GIF)

https://gyazo.com/11777c9b2d4f70bc9dfdec172bb9e214

11777c9b2d4f70bc9dfdec172bb9e214.gif

Edited by JordonBanks
typo
Link to comment
Share on other sites

13 minutes ago, JordonBanks said:

Apologies in advance if this should be in the 'Your Avatar' forum?  Happy to move it there?

But anyone know why this happens, or how to avoid it happening - it's getting embarrassing?

So - Whenver I sit or lie on anything (chairs, beds, beach towels, cars and boats, etc) I start out being sat totally normal - in the right position - looking normal and everthing fine.  But then after about 15 - 30 secods, I suddenly 'sink' into the chair.  The only way to then get back to sitting normal, is to EITHER use the adjust setting in the sitter control box (which takes forever).  OR if I turn my (VISTA) AO off, I then also return to a normal sitting position.

It's a real pain to have to remember to do this every single time I want to sit / lie on anything.  Or is it just the way it is?  Or is there a setting I can change to avoid this happening.  And is it just me, or does this happen to eveyone?

Example Video GIF below shows me sitting normally, and then suddenly sinking,  (Which happneed about 30 seconds after sitting).  I then return to normal if I turn my AO off (as I did  shown right at the end of video GIF)

https://gyazo.com/11777c9b2d4f70bc9dfdec172bb9e214

11777c9b2d4f70bc9dfdec172bb9e214.gif

You’ve already answered your question yourself.   You must turn off your AO when using something else that animates your avatar that doesn’t have a high enough priority assigned to it.  This happens at upload by the animation creator and as far as I know, there’s no way to change that.  I have minimal experience 1st hand with this from creating static poses & basic poses to hold & dance with tinies ten years ago.  Maybe things have changed?

  • Like 4
Link to comment
Share on other sites

7 minutes ago, Pixie Kobichenko said:

You’ve already answered your question yourself.   You must turn off your AO when using something else that animates your avatar that doesn’t have a high enough priority assigned to it.  This happens at upload by the animation creator and as far as I know, there’s no way to change that.  I have minimal experience 1st hand with this from creating static poses & basic poses to hold & dance with tinies ten years ago.  Maybe things have changed?

Thanks.  So everytime I want to sit/sail a boat, lie down. etc (and that object has an animation built in - like most chairs do) - I have to turn my own AO off?  Okay will do.  But sounds a right pain to have to do everytime.  You'd think there could be some kind of 'automatic switcer' to save you having to do it each time..  But thanks for quick response 🙂

Link to comment
Share on other sites

33 minutes ago, JordonBanks said:

Thanks.  So everytime I want to sit/sail a boat, lie down. etc (and that object has an animation built in - like most chairs do) - I have to turn my own AO off?  Okay will do.  But sounds a right pain to have to do everytime.  You'd think there could be some kind of 'automatic switcer' to save you having to do it each time..  But thanks for quick response 🙂

I am not very familiar with it since I use the Firestorm AO. But I seem to remember that the sit in AO's can be turned to not override built in animations? Is it a notecard with the AO?

I can't help but wonder why you need to turn on the sit animation. Do you sit on other than objects that's scripted? I can not remember that I have done this. I always sit on chairs, chaises, beds, scripted landscaping items like floating islands. So I don't use the "sit" I have placed in the Firestorm AO. I use the "sit on ground" a few times.

  • Like 1
Link to comment
Share on other sites

Posted (edited)
13 minutes ago, Marianne Little said:

I am not very familiar with it since I use the Firestorm AO. But I seem to remember that the sit in AO's can be turned to not override built in animations? Is it a notecard with the AO?

I can't help but wonder why you need to turn on the sit animation. Do you sit on other than objects that's scripted? I can not remember that I have done this. I always sit on chairs, chaises, beds, scripted landscaping items like floating islands. So I don't use the "sit" I have placed in the Firestorm AO. I use the "sit on ground" a few times.

Oh - need to check that out.  its a VISTA animation, and having a setting which gave priority to the object animation would make a lot of sense to me, if that is what is needed to not turn into Casper the Ghost.  perhaps it does.  I will investigate further 🙂

Yep - I only usually sit on actual 'sittable objects' and so I don't turn on any sit animation specifically.  I just right click on a sittakle object and choose sit. (from the little Firestorm circle menu thing).  But My VISTA AO is on by default.  And so is on when I sit on anything.  and thats what must be causing the conflict.  I am not manually turning on anything.  But only way to no longer sink into an object is to turn my VISTA AO off, when sitting on that object.  and then manually turn it back on again, when I stand up again..  which is the pain bit to remember.

 

Edited by JordonBanks
typo
Link to comment
Share on other sites

Posted (edited)

I never knew one could turn sits OFF either if that is what Marianne is saying but then I never encountered this problem in my all of SL which spans off and on for over 15 years.  The animations have priorities as Pixie was speaking about in her post above, so your AO has higher priorities than most sits in SL which are probably older sits.  I make stuff for Dinkies with older animations and my Dinkie customers must use a level 3 priority AO or turn AO off to use the products.  It's all in the priorities and it cannot be helped.  You could get a lower level AO which is what I do for my Dinkies so I can use all the animations for stuffs I make without turning AO on/off.  A level 3 priority AO is an older AO but for a Dinkie, it's best because Dinkies use a lot of the older, non-bento animations as Dinkies are NOT bento except tail.  Your AO must have a very high priority. 

Edited by FairreLilette
  • Like 3
Link to comment
Share on other sites

26 minutes ago, JordonBanks said:

Oh - need to check that out.  its a VISTA animation, and having a setting which gave priority to the object animation would make a lot of sense to me, if that is what is needed to not turn into Casper the Ghost.  perhaps it does.  I will investigate further 🙂

Yep - I only usually sit on actual 'sittable objects' and so I don't turn on any sit animation specifically.  I just right click on a sittakle object and choose sit. (from the little Firestorm circle menu thing).  But My VISTA AO is on by default.  And so is on when I sit on anything.  and thats what must be causing the conflict.  I am not manually turning on anything.  But only way to no longer sink into an object is to turn my VISTA AO off, when sitting on that object.  and then manually turn it back on again, when I stand up again..  which is the pain bit to remember.

 

Most of the AO huds have a specific button that turns on and off the sit override. Some will always be switched on whenever you log in (part of the loading process) and others will remember your last setting. I always turn the sit override off whenever I log in. I then don't have to think about it anymore until I log in again, or decide to switch it on in order to use it. It was particularly handy when a lot of furniture didn't have animations already installed.

If you're going to sail your boat or fly or drive in vehicles I would always suggest that you detach your AO hud if you are going to be crossing a lot of regions. Very rarely your AO can get broken by crossings... but I emphasise that it IS rarely. In the 15 years  that I have been in SL, and the tremendous amount of travelling that I have done, I think this has only happened to me no more than 5 or 6 times. As a precaution (because I don't always detach the hud) I make a copy of my HUD and use the copy. I can then copy the original to use again in the event of the last being broken.

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

25 minutes ago, FairreLilette said:

I never knew one could turn sits OFF either if that is what Marianne is saying but then I never encountered this problem in my all of SL which spans off and on for over 15 years.  The animations have priorities as Pixie was speaking about in her post above, so your AO has higher priorities than most sits in SL which are probably older sits.  I make stuff for Dinkies with older animations and my Dinkie customers must use a level 3 priority AO or turn AO off to use the products.  It's all in the priorities and it cannot be helped.  You could get a lower level AO which is what I do for my Dinkies so I can use all the animations for stuffs I make without turning AO on/off.  A level 3 priority AO is an older AO but for a Dinkie, it's best because Dinkies use a lot of the older, non-bento animations as Dinkies are NOT bento except tail.  Your AO must have a very high priority. 

Yes, the AO's I used before could turn off only the sit. I should have explained it clearer. My head is a bit fuzzy today. Click on the AO on your screen, it expands with symbols for sit, stands, walks, sit on ground, and turn off the sit. Click the AO again and it closes so it does not take up so much room on the screen.

The high priority animations can be annoying. It is like all uploads has to be highest priority. But it is necessary when it is a purse with "hold" animation. I do not want to swing the purse in my face when my AO want to move my arm up.

  • Like 1
Link to comment
Share on other sites

Posted (edited)
1 hour ago, Sister Nova said:

Most of the AO huds have a specific button that turns on and off the sit override. Some will always be switched on whenever you log in (part of the loading process) and others will remember your last setting. I always turn the sit override off whenever I log in. I then don't have to think about it anymore until I log in again, or decide to switch it on in order to use it. It was particularly handy when a lot of furniture didn't have animations already installed.

If you're going to sail your boat or fly or drive in vehicles I would always suggest that you detach your AO hud if you are going to be crossing a lot of regions. Very rarely your AO can get broken by crossings... but I emphasise that it IS rarely. In the 15 years  that I have been in SL, and the tremendous amount of travelling that I have done, I think this has only happened to me no more than 5 or 6 times. As a precaution (because I don't always detach the hud) I make a copy of my HUD and use the copy. I can then copy the original to use again in the event of the last being broken.

I think that's helped find the answer.  In my AO hud there is a little option (shown at top of my screen grab) called FORCE SIT.  I've turned that off, and I think (fingers crossed) that has solved it.  (I guess the FORCE SIT option 'forced' the sitting animation to use the AO animation rather than the objects buikt in, and that caused the conflict).  And as most objects I  sit on seem to have  built in sitting animations, then I can just turn FORCE SIT on again for ones that don't have animations built in.  It may be in those instances, the animation of the AO will kick in anyway, if none exists within the object - I'll have to see)

Anyway - so for for anyone using VISTA animations - it appears that it is FORCE SIT you need to toggle off.

I can now enjoy the sunsetting in Bellissaria, without getting that 'sinking feeling'

Thanks all

fea94ee6f33e4d95175b0bf9a095bd59.png

Edited by JordonBanks
Typo
  • Like 4
Link to comment
Share on other sites

48 minutes ago, JordonBanks said:

I think that's helped find the answer.  In my AO hud there is a little option (shown at top of my screen grab) called FORCE SIT.  I've turned that off, and I think (fingers crossed) that has solved it.  (I guess the FORCE SIT option 'forced' the sitting animation to use the AO animation rather than the objects buikt in, and that caused the conflict).  And as most objects I  sit on seem to have  built in sitting animations, then I can just turn FORCE SIT on again for ones that don't have animations built in.  It may be in those instances, the animation of the AO will kick in anyway, if none exists within the object - I'll have to see)

Anyway - so for for anyone using VISTA animations - it appears that it is FORCE SIT you need to toggle off.

I can now enjoy the sunsetting in Bellissaria, without getting that 'sinking feeling'

Thanks all

fea94ee6f33e4d95175b0bf9a095bd59.png

That's great and I didn't know there was on/off for sits either all these years.  I do need my customers to use a Level 3 priority AO because the animations I'm talking about aren't sits but rather are drinking and eating.  The Dinkie animations I have in my tea, milkshakes, etc will only work with an AO if it's a level 3 priority.  Some things you may need to turn AO off 'but' I think that's mostly for "girlie stuff"; i.e. a parasol or a purse for some examples.  

  • Like 1
Link to comment
Share on other sites

Posted (edited)
3 hours ago, JordonBanks said:

Thanks.  So everytime I want to sit/sail a boat, lie down. etc (and that object has an animation built in - like most chairs do) - I have to turn my own AO off?  Okay will do.  But sounds a right pain to have to do everytime.  You'd think there could be some kind of 'automatic switcer' to save you having to do it each time..  But thanks for quick response 🙂

It depends on the animation. Some are created in such a way that they will override the animations in the AO (higher priority setting). Turning the AO off should be nothing more than a simple click on the on/off button on the hud.

Edited by Silent Mistwalker
  • Thanks 1
Link to comment
Share on other sites

Sometimes you will see yourself sitting OK, but others will see you sitting on the floor. So just flip your AO off when you sit. 

Annoying but that's SL!

  • Thanks 1
Link to comment
Share on other sites

I never switch off my AO when sitting. But I kicked out all sit animations (don't need that) and for the one time per year that I sit on something I have a low priority sit in which is overriden by all furniture animations.

So everybody that sit's IN the furniture does NOT master their AO - it's the other way around. 😁
Btw. that fires my prejudice that most creators have no clue of SL. (keyword AO in this case)

  • Like 2
Link to comment
Share on other sites

On 6/6/2021 at 1:15 PM, JordonBanks said:

Thanks.  So everytime I want to sit/sail a boat, lie down. etc (and that object has an animation built in - like most chairs do) - I have to turn my own AO off?  Okay will do.  But sounds a right pain to have to do everytime.  You'd think there could be some kind of 'automatic switcer' to save you having to do it each time..  But thanks for quick response 🙂

The problem is likely that your AO is full of Priority 4 (maximum) animations.

As @Nova Convair suggested, the easiest solution is to remove the sits from your AO altogether. You don't need them. Ground sits are handy but the sits for sitting on chairs etc are almost never needed these days. 

 

  • Like 1
  • Thanks 2
Link to comment
Share on other sites

On 6/6/2021 at 6:05 AM, JordonBanks said:

Oh - need to check that out.  its a VISTA animation, and having a setting which gave priority to the object animation would make a lot of sense to me,

An animation's priority is a property of the animation itself, and once the animation is in SL it can't be changed. Scripts can't play animations at different priorities or make them override each other on demand. (When people talk about "a priority 3 AO" what they really mean is an AO full of priority 3 animations. It's not the AO making them pri 3.)

A chair object could, in theory, stop your AO's sitting animation -- but it has no way of knowing its name or UUID, so this can't work in practice. (And if your AO cycles through different sits, the chair would have to kill each one within a fraction of a second. That's even less feasible.)

So the solutions you're looking at are:

  1. don't define any chair-sits in your AO (ground-sits are fine)
  2. only use chair-sit animations with lower priorities than the ones in the chairs you want to sit in
  3. turn your AO's sit-override option off (if it has one)
  4. turn your AO off
Link to comment
Share on other sites

  • 2 months later...
34 minutes ago, dxzvr said:

How do I turn off AO??

Every AO has a toggle to turn it on or off, but they are all different.  It all depends on how the creator designed yours.  Read the instructions that came with it.

Link to comment
Share on other sites

Furniture has animations and programming to set the avatar in the right place. But, that doesn't work well. So, you'll see the ADJUST option in most furniture controls built to position your avatar.

AOs depend on only the animation to position the avatar. The only adjustment for position is the avatar's Hover Height.

All AOs that I have seen have a master ON/OFF and Sit-Override ON/OFF. The Firestorm viewer has an additional Be Smart option for sit-override. I think it makes things a little unpredictable. But, it can help.

The problem is furniture moves the sit-point, the place where the avatar is positioned. These positions are for a specific size avatar, animation, and the furniture. An animation can't be designed to work will all the furniture in SL. So, an AO's animation are unlikely to work with most furniture. However, animation usually work ok with prims without sit-position modification.

The work around for home furiture and photos in various places is to use one of the sits in the furniture for your AO's sits. When you get one of the AO's sits adjusted to the right place on the furniture, the rest of the AO sits will be close to correct for that single funiture sit.

Edited by Nalates Urriah
Link to comment
Share on other sites

All animations have a 'priority'. A Priority 4 animation file will overide a priority 3 animation file. So , you wont have to always turn it off, but its good practice to get in the habit.

Link to comment
Share on other sites

1 hour ago, rasterscan said:

All animations have a 'priority'. A Priority 4 animation file will overide a priority 3 animation file. So , you wont have to always turn it off, but its good practice to get in the habit.

I was wondering what those numbers were for when I turn on/off my AO.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...