Jump to content

Making it difficult to shop are we?


Recommended Posts

Posted (edited)

I have a link in my browser to the Marketplace.  I "now" get this error (for a couple of days anyway)

image.thumb.png.06074483592cd8edf66e4c188d432e1b.png

 

SO I went to the main Secondlife.com page directly from Google. From the main entry page which I could get to -- wooooot -- I clicked on the Marketplace link at the top of the page.  

 

I STILL GET THIS SAME PAGE.  

I do not WANT to clear my cookies. I like my cookies very much (peanut butter in real life).  This is not good.  I can get to the marketplace in Edge I suspect, but this is not helping merchants.  

Perhaps testing should be on the agenda. 

 

skipping off to Edge to see if I can get there to BUY SOMETHING SPECIFIC.   

:SwingingFriends:

Edited by Chic Aeon
had "in" instead of "on" :D
  • Like 1
  • Thanks 2
Link to comment
Share on other sites

Posted (edited)

This is an old hiccup I remember happening a few months ago in little spates, though none of them on SecondLife. I recall that nothing I could do from my end cured the problem. I think it went away on it's own.

 

ETA

found a diary entry that switching from Firefox to Vivaldi got round it.

Edited by Profaitchikenz Haiku
Link to comment
Share on other sites

Well I tried a LOT of things including running some utilities.  Nothing helped.  I gave up on Firefox long ago as SO MANY things didn't work :D. Sadly.  I did send in a "doesn't work" page to Brave.   I CAN get there in Chrome but it takes literally fifteen seconds when most (non-cached) pages load instantly for me.   Things were VERY bad for me on Flickr and they did eventually get fixed. So hopefully it will.

MEANWHILE when I went to the Marketplace in Edge I could see the page. BUT when I tried to log in it told me my information was incorrect (EVEN THOUGH IT LOGGED ME IN) === and, it redirected to my Marketplace account page where you have your email address etc.  Now THAT has nothing to do with BRAVE LOL. 

 

Hopefully that will get fixed too :D.  Or maybe they don't want us to save our logins on the Marketplace for some reason.  Hard to say.

 

 

Link to comment
Share on other sites

  • 1 month later...

I've been having this issue with Chrome for some time now, and I decided to put some work into finding the answer.  I could load the market fine in Firefox, but Chrome kept presenting the same white screen error :  Too Many Redirects.  It was being caused by Ad Block.  To fix it, follow these steps for a SPECIFIC SITE:

  1. Go to the market and when the white screen error appears (with too many redirects)
  2. Click on the 3 dots in the upper right corner (where all of your Chrome settings are), click Settings
  3. Click Privacy and security on the left, and go to Site Settings on the right and click it
  4. In the very first section, find "View permissions and data stored across sites" and click that.
  5. At the very top of that next page there is a search box.  In there, type market.  This will bring up results showing secondlife.com (click this one).  Any site on this domain will be listed below now and you can click on the marketplace.secondlife.com link to expand it.
  6. Look for Pop-ups and redirects (about 8 down from the top of the list) and change that setting to Allow.
  7. Now go back to your market page with the error and refresh the page.  You should now be able to load the market.

Please note the steps above are for a specific site - not all sites.  There is a setting that allows Pop-ups and redirects for ALL sites, but I do not recommend you do that since AdBlock will then become mostly pointless.

This same process can be done for ANY page that is doing this to you suddenly.  I was able to pinpoint it to happening when I did a Chrome update.  That setting had been switched after I refreshed the browser.  I hope this helps.

  • Thanks 1
Link to comment
Share on other sites

Slightly off Topic maybe but concerning Marketplace...as of today it has started  logging me out after EVERY use.  I cannot stay logged in now and it's a right royal PITA.  Is there a way around this?

 

Link to comment
Share on other sites

1 hour ago, Aishagain said:

Slightly off Topic maybe but concerning Marketplace...as of today it has started  logging me out after EVERY use.  I cannot stay logged in now and it's a right royal PITA.  Is there a way around this?

 

Burn all the cookies for all of SL's domains and relog into everything from scratch.

  • Thanks 1
Link to comment
Share on other sites

Posted (edited)
19 hours ago, IttyBittyKitty Littlepaws said:

Look for Pop-ups and redirects (about 8 down from the top of the list) and change that setting to Allow.

Thanks, @IttyBittyKitty Littlepaws, but unfortunaltely that did not work for me. Following a similar route, I got rid of all rhe cookies assciated with marketplace.secondlife.com.

That solved the problem but my cookies are gone now and there's no telling what will happen on subsequent logins. Presumably, the cookies will build up again. We'll see!

Update:

I've now logged out and back in again, no problems. This is on a Windows 10 laptop that is refusing (or someone is) to update to the new Windows 10 20H2 (stuck at 61%). Maybe that's infuential?

Edited by Odaks
Added PS
Link to comment
Share on other sites

6 hours ago, Coffee Pancake said:

Oh no, don't use that. 

It's not kept up to date like a regular desktop browser, and depending on your viewer can be very out of date and missing critical security patches.

Hmm, that is not what I was told and since I only use it for SL MP, I will take the info under advisement.  Nevertheless thankyou Coffee.

Link to comment
Share on other sites

  • Moderators

Greetings, All!

While I can provide no information on why this happens, I can provide an easy way to clear it in Chrome.

Right click on the page and choose Inspect from the Menu Options.

Click on the Application tab

It should default to the Cookies portion, if not, click on Cookies 

If you have more than one Cookie showing, click on the one for the Marketplace

Right click on the Cookie and choose "Clear" - this should be the only option. 

Close the Inspect window by clicking on the X at the far right. 

Reload the Marketplace web page. 

 

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

  • Moderators

Greetings, So Whimsy!

The "fix" for Chrome isn't a fix.  It is a shortcut to clear the browser cookie. 

Unfortunately, I do not use Firefox so I am not sure if that browser has a similar shortcut to clearing Cache/Cookies, but clearing the browser cache and any Second Life or Second Life Marketplace cookies that are stored should resolve the Too Many Redirects message. 

Link to comment
Share on other sites

37 minutes ago, So Whimsy said:

@Dakota Linden Now please provide a fix for Firefox. Been having this issue for two weeks now and it's driving me bonkers having to open another browser only for the marketplace....

Here is an article I have bookmarked for clearing individual cookies in Firefox:

https://trustiko.com/delete-cookies-for-a-specific-website-in-firefox/

 

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...