Jump to content
  • 0

Why am I seeing the floor through my cup?


Question

This might be an odd question. It might just be some normal feature to Second life. I find I can make literally anything I want in Blender. Anything at all. It always renders out fine. Preview for upload, always looks fine. Upload and rez the object, and there is always some area that is invisible. I understand there is an issue with physics where it often makes invisible walls, etc, but my issue is opposite. I found sort of a work around. I'll try to guess where the invisible area will be, and try to make that area as small as possible. But why is it doing that? Why can I see a textured object on one side (usually the outside), and not see it on the other side? They are solid objects (all vertices of mesh connect to faces so there is a face on all sides), but that doesn't appear to make a difference anyway. Best luck so far has been to add a detached cap on top of objects so you just can't see inside whatever object it is. Any ideas as to why it's even doing that, and why it's only visible (invisible, rather) after uploading to Second Life? This is starting to get expensive.

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 1

Blender, by default, displays two-sided faces. So when you create a new plane, it looks solid on both sides.

Second Life on the other hand, like most games, use single-sided faces. That plane is going to have "normal" direction, which is the solid side.

You can enable "face orientation" so the two sides are given different colors (blue and red by default) or you can enable Backface Culling which will make the wrong side similarly invisible.

62aa091087.png 335792b808.png

Then all you need to do is make sure that the "outside" surface stays on the outside, otherwise you'll find flipped normals or those "holes" in your mesh. If you tried looking at the hole from the other side, you'd find the surface.

Edited by Wulfie Reanimator
  • Like 1
Link to post
Share on other sites
  • 0

Adding to Wulfie's answer...

I didn't know Blender defaults to two surface polygons! My 3D modeling program, Lightwave 3D, defaults to single surfaced ones. This means that viewed from one side, the polygon looks solid. From the other side, it's invisible. SL does the same...you can move your camera inside an object, or underground, and see this for yourself.

When modeling something like a cup, you must be careful to give it...well, 3D-ness. The walls and bottom of a cup have thickness. To model this, you'd have two skins, the inner and outer surfaces of the mug, joined by more polygons around the rim. The polys outside the cup would have their surface normals facing out, and those inside the cup would have their normals facing in. (Surface normal: a little arrow pointing away from the "visible" side of the polygon)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...