Jump to content
  • 0
Sign in to follow this  
Former

Dell XPS 17, has a 3gb NVIDIA GeForce GT 555M card, 8gb ram

Question

  • 0

Well for starters, update your graphics drivers.  Go to nvidia.com and get the latest directly from them.  Guaranteed that Dell didn't provide you with the latest drivers.

Start there and see if that helps.

--Cinn

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

Well for starters, update your graphics drivers.  Go to nvidia.com and get the latest directly from them.  Guaranteed that Dell didn't provide you with the latest drivers.

Start there and see if that helps.

--Cinn

Share this post


Link to post
Share on other sites
  • 0

Hello Former. The specs of your Dell are quite enough to play SL without any problem and maybe better than what required. Don't worry about that. In the beginning for your 4-5 logins be patience. You have to download everything you see arround (textures) and especially at new places. This creates lag if you are in hurry to run arround when you arrive in a new region. Of course, as Cinn suggested, the last updates for your nvidia required. Maybe it is a good idea to set your graphics to medium temporarily. Finally are you sure that the cause for the problem isn't your internet connection or your router? If it is new also, in deed that you have to get the last drivers for it also.

Share this post


Link to post
Share on other sites
  • 0

Yes it should run Second Life very well at high and ultra.I have a older Dell XPS 17 with a Core 2 Duo, 4GB RAM and an 256MB Nvidia 8600GT graphics card and although I usually use my gaming desktop for SL, the Dell will run SL well at Mid and sometimes ok on High too. Your spec is so much better so definitely something else is affecting performance.

Are you using a wi-fi connection? If so, try on a wired connection and see if any better.

Share this post


Link to post
Share on other sites
  • 0

Just had a thought. Is there a switch on this new Dell XPS 17 to change from onboard graphics to discrete graphics (Nvidia card) and you are only using the onboard graphics? The Alienware M17X had this arrangement. Have a look at the manual.

 

Share this post


Link to post
Share on other sites
  • 0

Actually I'm having the same issue with a Alienware m14x. Its got the same card. I spent hours online with Dell technical support to no avail. Despite running viewer 2 with that card it still does about 2 FPS. I think it might have to do with second life using the onboard graphics card instead of the GPU desipte all settings... Has anyone found a solution to this yet by chance?





Share this post


Link to post
Share on other sites
  • 0

@entangledwolf:

Second Life does not decide what graphics mode you are in. Going by what my gf says (she has an Alienware M17X), you have to change the graphics mode by pressing fn + F7. Check your manual to see if your M14X is the same or has different keys to change mode but I doubt Alienware changed this across models. Just press those keys once and the screen should flicker but no other indication that you've switched modes.

She discovered another way to ensure discrete graphics are being used is to remove the battery and start the laptop using mains power only.

Share this post


Link to post
Share on other sites
  • 0

@Nyll

 

Thanks for replying. FN F7 actually mutes the computer on the M14X. They changed the design on this one significantly with the new video card. We actually set the entire laptop to use the Nvidia card all the time for every application and still nothing. We we're on with Dell technical support for quiet some time and they had control of the laptop so if it was easy as activating the card they would have gotten that figured out I would think.

 

Would it be possible for you to tell me what video card your GF has in the M17x? I'm thinking SL just doesn't like the 555m and I may need to return this laptop and get a diffrent card.

Share this post


Link to post
Share on other sites
  • 0

@ entangledwolf

They've changed the key activators then. Hers is over a year old. I'm not sure what card is in it. I'll ask when I see her, probably tonight. She did have problems with the switchable graphics so resorted to removing the battery when playing SL with it.

I don't know why Alienware/Dell make it so difficult to switch from onboard to discrete graphics. People buy Alienware laptops because they are gaming machines. I have a Dell XPS 17 (bought S/H) as well as my desktop but thankfully it only uses the discrete Nvidia card, could be because the battery is dead and only works on mains power or it was made prior to switchable graphics.

Share this post


Link to post
Share on other sites
  • 0

Hey guys!

I am experiencing exactöy the same problem with the same computer (same model even). Has anyone found a solution to this problem? since there have been no answers i assume that either returned the product (which would be a shame because its a pretty notebook) or you resolved it yourself. I would be curious to know how.

wehn checking my sytem info through sl the viewer indentifies a different grahics card than i should actually have. this must be my onboard graphic card. but how do i switch to my discrete graphic card? all this is really bizarre....maybe some linden guy could help us here?

waiting anxiously for your replies and suggestions ;)

Share this post


Link to post
Share on other sites
  • 0

I am glad to announce that I have found a solution to this problem myself with sirprising results.

 

You were all right. One has to find a way to switch from integrated graphics card to discrete graphic card (in this case the nvidia GT 555M).

 

for all who have a DELL XPS 17...right click on your desktop...select Nvidia control panel...and go to 3d settings. there you will find a window that allows you to choose between three different options: auto, nvidia and integrated card...selecct the second option and here yoou go.

 

the graphics card is that good that you can even use shadows...it looks dazzling...i wa sreally impressed...and its not even laggy if you use shadows...i did not expect that given that it was horribly laggy before when the system was using the integrated graphic card..

 

hope that explanation will help you. and dont return the notebook...its stunning and the graphics card is great for sl.

Share this post


Link to post
Share on other sites
  • 0

Cinn is right on - my partner just got a new Dell XPS 17 with the 555 1MB and it kept running FIrestorm in the intel chipset. She spent hours on the phone with Dell-India  - they were very nice but the control panel still would not switch Firestorm to nvidia. She got a techy friend to help her install the newest nvidia driver from their website (not Dell's) and it worked!! She is running Firestorm in high graphics and is loving it! Was ready to send the machine back. Thank goodness for geeks, it is hard for mere mortals to figure out how to update drivers!

Share this post


Link to post
Share on other sites
  • 0

I have this problem too. I have been talking with Dell support about it and do not have a resolution yet. The latest drivers from nvidia 280.26 make it worse btw. It will run great (FPS about 60) the first time you start SL then not run at all after that. The most recent from Dell is 268.30. That one runs but with FPS about 6 I really hope this gets fixed soon.

Share this post


Link to post
Share on other sites
  • 0

Owning a Dell XPS with a nVidia GT555m w/3GB RAM + HD 3k Intel graphics paired with Optimus, I have discovered a work around that seems to work well with current 3.0.3 beta releases and previous 2.x clients to include Kirsten's. (R.I.P. and come back soon Kirsten!)

Something seems to stuff the Optimus switching process when SL is in the downloading clothing stage and has caused numerous nVidia error code 7 and 8 messages to include "nVidia drivers XXX.XX have stopped working and have recovered..." Windows Vista and 7 messages. Perhaps it's in the hand off from the switch from the Core i7 HD 3k graphics to the DGPU nVidia card while under heavy load that causes the TRD timeout. *shrug* I am just guessing here from what I do understand from the archetecture and how it works.

To get my L702X to run and launch SL clients at the moment is twofold:

1) Make that nVidia 3-D Application profile for the Secondlife.exe/Secondlifebeta.exe files and permanently override the default "Integrated Graphics (Intel)" to "Use High Performance Video (nVidia)". For poops and giggles, turn on the system tray notification for nVidia graphics, just to make sure that your DGPU is running, rather than integrated graphics. Click apply, then exit, do not "X" out the control panel.

2) Launch Secondlife from the desktop by right clicking and selecting "Run With Grpahic Processor -> High-Performance  NVIDIA Processor." (Should be redundant if you set the profile for the application in the nVidia control panel, but it does not hurt either) When the client starts, you should see a rainbow colored nVidia GPU Activity systray notification "1 program" that looks like  a grid/chip. Double check it is running before login by hitting Help -> About second life and seeing which GPU is currently active. If it says anything but "nVidia GT 555m" you did something wrong, check steps above!

 

Now comes the silly part - because it still seems that the GPU starts in this "low power standby state", until the clock domains ramp up on the DGPU, you'll get it stuffed quickly - it takes a few moments for the Optimus to forget the Intel HD 3k and grab, then load and speed up the 555 cores. So what you do is open SL's  (CNTRL-P) preferences and set graphics slider all the way left to "Low".

Login as usual.

Wait for your immediate area to load and at least your avatar shape and you see the beginnings of the skin bake. Once settled?

Open preferences -> Graphics tab again and set the slider wherever you want. I jump right onto Ultra or High after my skin and clothes load and it goes just fine after that. GPU loaded and just humming away at 50 FPS or so. (Anisotropic and Full Scene Anti-aliasing set to 8x in this case - no shadows) Nothing will make the machine stop. It's been ultra stable for me this way - and I stay logged in until I get bored, honestly.

 

This is tested to work with all *DELL* webiste drivers for my machine completely up to date, running nVidia Verde 285.27 beta drivers from www.nvidia.com. Hit the Microsoft website too, grab the web installer for the latest Direct-X end user runtime updates. *Knocks on Aluminum Hood of that 17" Dell* Works a treat!

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Good luck!

I had the same problem.  This worked for me.  I researched the Nvidia site and this was the answer.  Download this driver from the Nvidia site:

http://www.nvidia.com/object/notebook-win7-winvista-64bit-275.50-beta-driver.html

Then go into your Control panel.. display settings... nvidia icon... and set your global settings to the 555m that will make it default.

To be extra sure you start with the 555m, when you start your viewr.. right click and choose the 555m.

worked like a dream for me

Share this post


Link to post
Share on other sites
  • 0

I researched this through Nvidia... and I have the same card.  This is the driver they sent to use.  After you dl the driver.. then go into your nvidia prog and set it to default in the global settings.  To be doubly sure that you are using the 555m, right click on your viewer shortcut and choose it from "run with graphics processor".  Worked like a dream for me.  Hope it helps.

 

http://www.nvidia.com/object/notebook-win7-winvista-64bit-275.50-beta-driver.html

Share this post


Link to post
Share on other sites
  • 0

I also had this problem.. Nvidia sent this driver to use... after installing it, go into the Nvidia program and set it to default under the global settings. To be doubly sure that it is the card you're using... right click on the shortcut and choose it from the "run with graphics processor" Worked the first time for me. Good luck!

 

http://www.nvidia.com/object/notebook-win7-winvista-64bit-275.50-beta-driver.html

Share this post


Link to post
Share on other sites
  • 0

http://www.nvidia.com/object/notebook-win7-winvista-64bit-275.50-beta-driver.html

I also had this problem.. Nvidia sent this driver to use... after installing it, go into the Nvidia program and set it to default under the global settings. To be doubly sure that it is the card you're using... right click on the shortcut and choose it from the "run with graphics processor" Worked the first time for me. Good luck!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...