Jump to content
Sign in to follow this  
Oskar Linden

Deploys for the week of 2011-05-30

Recommended Posts

Monday is a holiday this week and most Lindens are out enjoying their day off. We do have code ready for deploy tomorrow morning and will be shipping it at the regularly scheduled hour.


Second Life Server (main channel)
The main channel will be getting Kelly's "maint-server" project. This is mostly bug fixes and some logging changes to help us investigate some issues.
Bug Fixes
  • SCR-61: "llOwnersay Truncates multibyte characters at the end of it's range"
  • SVC-6573: Block execution of ungrouped scripts on ungrouped land that blocks scripts.
  • SVC-2810: IM to Email sending out messages that can't be replied to.
  • SVC-4632: Getting past estate land bans
  • SCR-66: "llRegionSayTo() Fails to send messages to attachments on sitting avatars"
  • Added logging to help in investigating a "'TIMEWARP" issue that is causing some residents to be kicked off simulators
  • A simulator crash mode.
  • A dataserver crash in SMTP connection sending mail
  • Fix to allow services to start properly after deployment of new code.
 
2011-05-31, 5:00am: Rolling Restart - Release Notes: https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_Server/11
 

Second Life RC BlueSteel
This branch has the same changes to the People API as were here last week. This API was updated to handle friendship additions and removals as well as some infrastructural changes.

2011-06-01, 8:00am: Rolling Restart - Release Notes: https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_BlueSteel/11
 

Second Life RC LeTigre
This channel will get Kelly's "mono2-performance' branch.

2011-06-01, 9:00am: Rolling Restart - Release Notes: https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_LeTigre/11
 

Second Life RC Magnum
This project is keeping the "mesh-prep" branch after getting some bug fixes. This contains infrastructure and framework updates to get the grid ready for mesh. It does not include any mesh features or functionality. The physics engine has been updated and the 10cm gap between colliding objects has been removed for some objects. 
The llCastRay() function has been included, but it is disabled..

2011-06-01, 10:00am: Rolling Restart - Release Notes: https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_Magnum/11
 

Snack Release Channel
Snack will be closed until it is needed again.
 

We will be monitoring this thread during the next week so please feel free to post issues that you feel have been introduced by the new code. Please file a JIRA for issues you find and post the JIRA link into this thread. It really helps us out. When determining if issues are relevant or not research is key. Tracking down exactly the right situation where an issue is occurring greatly speeds up the development process to get fixes in place.
I appreciate your help. Have a good week!
 
__Oskar
 
p.s. If you are interested in helping test SecondLife in beta please join the group "Second Life Beta" in-world. We also have an email list where we communicate upcoming projects and how you can help. ( https://lists.secondlife.com/cgi-bin/mailman/listinfo/server-beta ) Once a week we meet on ADITI to discuss new features, new bugs, new fixes, and other fun stuff. You are more than welcome. Information is here: https://wiki.secondlife.com/wiki/Server_Beta_User_Group

 

Share this post


Link to post
Share on other sites

Any chance you will fix vehicle movement within and between sims?  It has reached impossibility of moving vehicles between sims, and often crashes occur with sims. 

If you are giving up on vehicles, please tell us so we don't waste your time.

Share this post


Link to post
Share on other sites

I've tested vehicles on all the current server versions and experienced no crashes.... the only thing I've noticed is a half second rubberband for all physics objects.

Share this post


Link to post
Share on other sites

I have also been experiencing increased problems in vehicle sim crossings in the past few weeks - several 5-10 second rubber-bands and after 15 to 20 crossings I usually get sent to an impossible grid location and enter an alternative reality (this seems a new 'feature' that appeared a few months back)

Share this post


Link to post
Share on other sites


Hitomi Tiponi wrote:

I have also been experiencing increased problems in vehicle sim crossings in the past few weeks - several 5-10 second rubber-bands and after 15 to 20 crossings I usually get sent to an impossible grid location and enter an alternative reality (this seems a new 'feature' that appeared a few months back)

Oh, I think I recognize the "impossible location" thing. When this happens, do you notice that the terrain for the region you are moving to has not shown on the screen yet?

I do not see that one happen much any more, but -- about December or January, when a few projects like compression and threaded rez first came to RCs, I noticed that this sequence could happen --

 

  1. I am in Region A, flying into Region B. I know that Region B is present and up, but no Region B objects yet show in the mini map, and I cannot yet see Region B on the screen.
  2. I cross over to Region B, but still only see empty water on the screen. In the menu bar it still shows Region A, with out of range coordinates. This is not like the olsd usual connection drop, I can still start and stop and change direction.
  3. If I stay in the "bad" coordinate space, Region B will never appear.
  4. If I reverse direction and move back to the proper 0-255 coordinates for Region A, then Region B will appear and I can cross over with no more trouble.

This is easier to make happen with a short draw distance, it is also easier to make happen if the network or viewer is running slowly. I do not know if any one of those is directly related.

Is that the same trouble you are seeing now?

Share this post


Link to post
Share on other sites


Oskar Linden wrote:

Are these random vehicle crossings or do you notice a pattern between certain regions or RC's?

 

__Oskar

Take a 256 prim train and ride on the SLRR from Tuliptree to Calleta. On sim crossing between Sweetbay and Calleta I'm always thrown off the train and end on negative coordinates beside Oculea region.

Share this post


Link to post
Share on other sites

Maddy Gynoid wrote:


Take a 256 prim train and ride on the SLRR from Tuliptree to Calleta. On sim crossing between Sweetbay and Calleta I'm always thrown off the train and end on negative coordinates beside Oculea region.


I too have been "un-seated" from my train and the scripted train auto reset. And that is on trains with less then 50 prims.

On the Sweetbay / Calleta crossing, as well as on some spots on the other side of the SLRR track.

We will hold a Rail Community meeting Firday the 3rd. of June at 1:30PM. Maybe we can identify the trouble spots and give the information to Oz.

Heck, Oz Linden your welcome to join us at Tuliptree / 125 / 25 / 25

SLURL: Rail Community Meeting

Share this post


Link to post
Share on other sites

Oz works on the viewer side and doesn't have much control over region crossing code. Post your findings here and I'll have the server devs take a look at it.

 

__Oskar

Share this post


Link to post
Share on other sites

@Chaos: We are certainly not giving up on vehicles. The Engineering team has been investigating these issues and has found some weirdness that we are looking into.

 

__Oskar

Share this post


Link to post
Share on other sites

Thanks Oskar - so far I have not noticed it to be related to different server versions. In a few days time I will do a road-trip on one of those excellently maintained and quiet highways in sl and will notice where the problems seem to be.

Share this post


Link to post
Share on other sites

Hi

I own a car racing sim and since the deployment the last two races we've had to do a sim restart mid race due to the sim starting to crash. Things like estate functions fail, sim fps drops to near zero and ping times are near 500msec for everyone. It's all we can do to get off the sim to the next one for a restart. As race cars press the servers to the limits it may be something to look into

Share this post


Link to post
Share on other sites

What I have noticed relating to the super long rubberband issue that throws you off the vehicle is that it very rarely happens with full prim regions. It is at its worst when trying to cross into an openspace region that has sat unused for a long time.

It is almost like the simulator has swapped something out to disk, causing a delay long enough to knock you off your vehicle (even a 1 prim vehicle) when you try to enter the "asleep" region.

Share this post


Link to post
Share on other sites

Hi since deployment my magnum server sim has crashed 4 times(once per day). First things to do with the asset server such as rezzing or card saving/opening stop functioning then there are major lag spikes until nobody can move. Our normal script time from the estate menu of 4.3 triples

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...