Jump to content

Black screen, but only in one place


You are about to reply to a thread that has been inactive for 234 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hiya,

Having a very strange issue that I have absolutely no idea the cause of.

The viewer works absolutely fine, but there's one specific place where if I go there, the screen turns black. I can still see hovering text, names etc, it's just like there's no light. If I teleport there it will usually render okay for a second or so, then drop to black. It's not the gamma setting; I've checked that, and it's nothing to do with an RLV relay or the RLV API, having turned them both off. Also interesting is that it only affects one part of the area. If I disable restrictions and take the camera to an area above, it works just fine, but the moment it goes below the floor there everything immediately goes black again. I've just managed to get my camera to go very very close to something, and I can just about see it, but there's some form of incredibly dense black fog, and I have no idea what's causing it.

If I use a different account, everything is absolutely fine, and nobody else in the same location is having the issue. I have no idea why it would be inconsistent unless it's either a setting thing or something specifically for my main account.


Any tips would be greatly appreciated.


EDIT: I have a feeling it could be something to do with this, but I'm not sure:
I tried something in the location with a second account, and my relay was apparently sent "setenv_densitymultiplier:.18=force", and "@setenv_distancemultiplier:.0.9=force", which to me would indicate it's forcing very close, very dense distance fog -- much like I'd discovered. Is there a way to force it back?

EDIT 2: Having found the "Disable Fog" setting in Advanced > Rendering Features, if I disable it then the problem is "fixed", though obviously I don't want to just leave fog off forever and I'd rather just force that fog value back down if I can.

Edited by BlameGLaDOS
Additional info
Link to comment
Share on other sites

Try and set your particle count to like 1,024 or lower. Fog in SL is normally made with scripts, where some scripters use the partice emitter values wrong, which can have high impact on even expensive high-end graphic cards.

If you run SL in say ultra graphic settings things like fog puts on extra load on your computer.

It is a good idea to inform about your hardware, GPU and settings, this can be easy obtained with with Help->About and copy paste the information.

  • Like 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 234 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...