Jump to content

Firestorm 6.4.12 Texture Cashing Issue - Please Help


You are about to reply to a thread that has been inactive for 213 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Texture Trashing Every Few Seconds and I have worked through the https://wiki.firestormviewer.org/http_fetching_issues but it is still happening

In the first picture of Firestorm it can be seen in the hair and the 2nd picture of Firestorm its not trashing

1st picture - https://imgur.com/a/rDoj3lZ

2nd - https://imgur.com/a/RFpym4i

My Computer - Microsoft Windows 10 Pro 64-bit
Motherboard: Micro Star B450M Pro-M2 (MS-7B84)
Power Supply: Cooler Master Extreme2 525
CPU: AMD Ryzen 5 1400 Quad-Core Processor          
Drive: Intel 660p NVMe PCIe M.2 512GB
Memory: G.SKILL Ripjaws V DDR4 2400 C15 2x8GB
Graphics Card Vendor: ATI Technologies Inc.
Graphics Card: Radeon AMD SAPPHIRE NITRO+ RX 580 Series 8GB

3.png

2021-02-24 (8).png

Edited by PatricaC
Link to comment
Share on other sites

9 minutes ago, Coffee Pancake said:

The amount of VRAM the GPU has and how much SL has allocated shouldn't ever be the same.

Windows needs VRAM, Chrome needs VRAM, SL taking it all would be very bad.

Okay but texture trashing shouldn't happen as often as it is either 

Link to comment
Share on other sites

There are no limits on what people can place in SL, VRAM is used by both textures and meshes.

The viewer is attempting to make room in VRAM for more stuff. Textures are loaded at progressively increasing resolutions, the idea being that the viewer only loads the highest resolution it needs rather than the full resolution. Kicking out a full resolution texture will force it to be reloaded.

It's really bad at selecting which texture should be kicked out to try and save space. This entire system was designed before mesh objects.

 

Lack of VRAM shows as a texture thrashing issue, but it's unlikely to be caused by textures alone (or even related to textures).

Try reducing the object detail slider. There could easily be a large / complex mesh being loaded that's easting a lot of VRAM.

Failing that reduce your draw distance (even by a couple of meters can make a huge difference). Remove minimized HUDS. Move to another location.

  • Like 2
Link to comment
Share on other sites

2 hours ago, Coffee Pancake said:

There are no limits on what people can place in SL, VRAM is used by both textures and meshes.

That's interesting, is there any prioritisation (distance, size, mesh-first...) or is it just all thrown in as the region throws information at the client?

Link to comment
Share on other sites

2 hours ago, Coffee Pancake said:

Lack of VRAM shows as a texture thrashing issue, but it's unlikely to be caused by textures alone (or even related to textures).

Try reducing the object detail slider. There could easily be a large / complex mesh being loaded that's easting a lot of VRAM.

Failing that reduce your draw distance (even by a couple of meters can make a huge difference). Remove minimized HUDS. Move to another location.

First picture is my Object detail slider is at

2nd picture is my own land and the most i see on the entire sim is about 6 people maybe 8 at the max ...... it also happens there with no huds or anything on

3rd picture is the objects on land

2021-02-25.png

2021-02-25 (2).png

2021-02-25 (6).png

Edited by PatricaC
Link to comment
Share on other sites

4 hours ago, Rachel1206 said:

That looks like a bug in the viewer, where you graphic card and its VRAM memory not detected correct.

That's actually normal. As per linked Wiki, "This setting is hard limited based on the VRAM available with your graphics card. (...) GPU 4GB+ = up to 2048MB"

3 hours ago, PatricaC said:

Okay but texture trashing shouldn't happen as often as it is either 

As Coffee said...

2 hours ago, Coffee Pancake said:

Try reducing the object detail slider. There could easily be a large / complex mesh being loaded that's easting a lot of VRAM.

If may I ask, what body do you use? What is your avatar complexity?

  • Like 2
Link to comment
Share on other sites

6 minutes ago, panterapolnocy said:

That's actually normal. As per linked Wiki, "This setting is hard limited based on the VRAM available with your graphics card. (...) GPU 4GB+ = up to 2048MB"

As Coffee said...

If may I ask, what body do you use? What is your avatar complexity?

 

I use Maitreya Body, Catwa Bento head here's my complexity and texture cashing you can see it in my hair and I'm the only one on entire sim

 

2021-02-25 (8).png

Edited by PatricaC
Link to comment
Share on other sites

47 minutes ago, panterapolnocy said:

That's actually normal. As per linked Wiki, "This setting is hard limited based on the VRAM available with your graphics card. (...) GPU 4GB+ = up to 2048MB"

As Coffee said...

 

It is a bug, she does not have the option for enabling dynamic texture memory. Her graphic card has 8 GB VRAM.

Her graphic card should handle max out Ultra settings without problems, even if she had several Chrome windows open and same time doing a real time video encoding!

Edited by Rachel1206
Answer hidden?
Link to comment
Share on other sites

49 minutes ago, panterapolnocy said:

That's actually normal. As per linked Wiki, "This setting is hard limited based on the VRAM available with your graphics card. (...) GPU 4GB+ = up to 2048MB"

As Coffee said...

If may I ask, what body do you use? What is your avatar complexity?

It is a bug, she does not have the option for enabling dynamic texture memory. Her graphic card has 8 GB VRAM.

Her graphic card should handle max out Ultra settings without problems, even if she had several Chrome windows open and same time doing a real time video encoding!

Link to comment
Share on other sites

I may be missing something here but as I see it the GPU has 8GB VRAM and should permit at least 4GB to be used by the viewer.  There would (or at least "should") be no texture thrashing if the VRAM was being correctly allocated.

@PatricaCIn the top bar help tab "About Firestorm" is the GPU being detected correctly by the viewer? A Sapphire Nitro RX580 8GB card should run SL at high/Ultra settings with no issues.

If the viewer is only seeing less than 4GB VRAM and the thrashing suggests it is seeing a lot less, something is not right, either with the viewer or the GPU.

Further, I've looked at those two Imgur photos and I cannot see the texture thrashing that you refer to.

 

Edited by Aishagain
omitted words and typos
  • Like 1
Link to comment
Share on other sites

3 hours ago, Aishagain said:

@PatricaCIn the top bar help tab "About Firestorm" is the GPU being detected correctly by the viewer? A Sapphire Nitro RX580 8GB card should run SL at high/Ultra settings with no issues.

Here's what's under that so you can see it yourself , I know i can run it at High but I keep it at Med cause sometimes I dual log bring in an alt or work on dance routines/do dance shows so i keep it at that so I don't have to keep playing with my graphics settings every time i want to dual log or work on a dance routine or do a dance show that has 40 av's at

491770315_2021-02-25(9).thumb.png.23dd7322135ebff174228454367b0a39.png

Edited by PatricaC
Link to comment
Share on other sites

@PatricaC Well there is nothing in that to my eye that looks wrong.  It seems that for some reason your viewer is not seeing the VRAM of the Radeon card.  Now I tried to see your FS JIRA but it says either it has been deleted or I do not have permission to see it...no idea why that should be but I cannot assist in this issue further, sorry.

There have been so many issues with AMD/Ati GPU cards over the years that I simply avoid AMD GPUs completely for SL.  Now I realise that is no help to you but might explain the roots of the issue. ☹️

  • Like 1
Link to comment
Share on other sites

1 minute ago, Aishagain said:

@PatricaC Well there is nothing in that to my eye that looks wrong.  It seems that for some reason your viewer is not seeing the VRAM of the Radeon card.  Now I tried to see your FS JIRA but it says either it has been deleted or I do not have permission to see it...no idea why that should be but I cannot assist in this issue further, sorry.

There have been so many issues with AMD/Ati GPU cards over the years that I simply avoid AMD GPUs completely for SL.  Now I realise that is no help to you but might explain the roots of the issue. ☹️

You might have login to the JIRA cause I just logged in and I still see it

2021-02-25 (10).png

  • Thanks 1
Link to comment
Share on other sites

Hmm weird it won't let me see it when I log in. Perhaps since it is a SUP number only support personnel and the originator are permitted to see it.

 

Edited by Aishagain
  • Like 1
Link to comment
Share on other sites

6 minutes ago, Aishagain said:

Hmm weird it won't let me seeing when I log in.

 

That's weird cause I know only 1 was watching it before maybe you can get it through this way -https://jira.firestormviewer.org/secure/ViewProfile.jspa?selectedTab=jira.user.profile.panels:user-profile-summary-panel not sure if that will work

Nvidia cards I have had issues with but this was like 10 years ago though my ex husband had no issues with his Nvidia card maybe they just don't like me idk 

Thats why I told my builder to go with Sapphire AMD hoping it be better then AMD themselves 

Edited by PatricaC
Link to comment
Share on other sites

1 minute ago, Aishagain said:

@PatricaCnope that simply logs me into my Support requests and Bug reports.  No matter I think FS support will be far more use to you than I!

I have only created 1 other JIRA then the one I have up, I don't remember if I created more under my alt though atm.

Link to comment
Share on other sites

I run Firestorm on Ubuntu Linux with a Sapphire Nitro+ RX 580 8 GB video card, and I never notice texture thrashing. Sometimes a texture on an object may take longer to load. I use other viewers as well. Only the official viewer (a version compiled to run on Linux) tends to have texture thrashing due to the texture memory limit that the official viewer has by default. Restrained Love and Kokua viewers are a bit odd in that setting the 2GB maximum seems to cause issues. Marine Kelley recommends a setting of 1552 MB for texture memory, which seems to be sufficient most of the time. On Singularity I have it set to 3072 MB.

Link to comment
Share on other sites

7 minutes ago, KjartanEno said:

I run Firestorm on Ubuntu Linux with a Sapphire Nitro+ RX 580 8 GB video card, and I never notice texture thrashing. Sometimes a texture on an object may take longer to load. I use other viewers as well. Only the official viewer (a version compiled to run on Linux) tends to have texture thrashing due to the texture memory limit that the official viewer has by default. Restrained Love and Kokua viewers are a bit odd in that setting the 2GB maximum seems to cause issues. Marine Kelley recommends a setting of 1552 MB for texture memory, which seems to be sufficient most of the time. On Singularity I have it set to 3072 MB.

If you look in this picture I'm unable to do that

It doesn't seem to do it as much with the latest RX 580 optional drivers installed listed below

Revision Number
Adrenalin 2020 Edition 21.2.3 Optional
 
Release Date
2/22/2021

 

1.png

Edited by PatricaC
Link to comment
Share on other sites

Yes, because Firestorm has that 2048 MB maximum, unlike Singularity. You could enable advanced lighting and turn off shadows. I also think you should be able to check Enable Streamed VBOs (The tooltip has outdated information, likely applicable to 10 year old AMD/ATI graphics cards.)

  • Haha 1
  • Confused 1
Link to comment
Share on other sites

2 minutes ago, KjartanEno said:

Yes, because Firestorm has that 2048 MB maximum, unlike Singularity. You could enable advanced lighting and turn off shadows. I also think you should be able to check Enable Streamed VBOs (The tooltip has outdated information, likely applicable to 10 year old AMD/ATI graphics cards.)

RX 580 isn't a 10 year old card though

RX 580 Release date - April 2017

Edited by PatricaC
Link to comment
Share on other sites

I think Firestorm has some bug(s) regarding the texture memory. I visited Kiyori sim last month with Firestorm and Singularity. Firestorm eventually crashed, but not before taking up all 16 GB of system memory and going into HD swap space. Singularity ran for a couple of hours without issue.

The tooltip on Enable Streamed VBOs says that AMD cards might have poor performance when enabled, but in my experience this is not true. What I meant is that the tooltip was written long before the RX 4xx/5xx series of cards was made. Turn on VBOs and see how it goes. 

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 213 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...