Jump to content

Modify permissions when boxed [insanity - please help]


Taiga Cloud
 Share

You are about to reply to a thread that has been inactive for 248 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I am having a hard time keeping the modify permission when I send a boxed item to an alt. The object has a script that is no mod. - Fun thing, on a previous mesh with the same script it has worked.

But now its not working on the next project. The object itself is supposed to be editable. It works on my account I uploaded the mesh on. But when I pack it into a box with full perms and send this package to an alt or a friend, they get the object inside with no mod status after unpacking

I have bitten and hissed at two keyboards literally trying to solve this issue, and its so frustrating.

 

I have done the following:

1. Object A (with no mod script) has mod rights and is rezzed inworld.

2. I take a copy to my inventory - And here I already see that it also unchecked the copy setting. SO I manually edit that back to copy. As I want it to be mod/copy/no transfer for the customer.

3. I put Object Ainto full perm Box.

4. I send the box to my alt.

5. I unpack on the alt.

6. I see that the object cannot be modified.

 

I did the same with another product and even checked the permissions, there is no difference, but this issue happens.

 

What can I do? WHat am I overseeing?

 

 

Link to comment
Share on other sites

Did you actually try and have the alt RESIZE or TINT or somehow modify the object?  All objects with no mod scripts (the norm) will SHOW as no modify in the inventory when transferred but are still modify by the receiving person. The only thing that I know if that you have to check is to be sure that after you take up an item with a no mod script in it --- you need to make sure that the MODIFY box is STILL checked in your inventory before sending it out. Sometimes it disappears and you have to put that check mark back in again.  

 

That's my only idea. It has worked like this for -- well ever as far as I know :D. Good luck. 

Edited by Chic Aeon
adding info
Link to comment
Share on other sites

40 minutes ago, Chic Aeon said:

Did you actually try and have the alt RESIZE or TINT or somehow modify the object?  All objects with no mod scripts (the norm) will SHOW as no modify in the inventory when transferred but are still modify by the receiving person. The only thing that I know if that you have to check is to be sure that after you take up an item with a no mod script in it --- you need to make sure that the MODIFY box is STILL checked in your inventory before sending it out. Sometimes it disappears and you have to put that check mark back in again.  

 

That's my only idea. It has worked like this for -- well ever as far as I know :D. Good luck. 

Yup, did exactly that. All greyed out on my alt. :( The modify box is like greyed out in the inventory of the creator account.

  • Sad 1
Link to comment
Share on other sites

1 hour ago, Taiga Cloud said:

2. I take a copy to my inventory - And here I already see that it also unchecked the copy setting. SO I manually edit that back to copy. As I want it to be mod/copy/no transfer for the customer.

I don't know what's going on with the Mod permission, but changing any permission while in Inventory is fraught with a peril known as the "Slam Bit" -- see this wiki entry for details and a way to maybe better track what's happening to all the object permissions.

  • Thanks 1
Link to comment
Share on other sites

10 hours ago, Qie Niangao said:

I don't know what's going on with the Mod permission, but changing any permission while in Inventory is fraught with a peril known as the "Slam Bit" -- see this wiki entry for details and a way to maybe better track what's happening to all the object permissions.

Thank you,

got it fixed with reading through this. 

Ill explain it for others who face similar issues: I hope this helps anybody in the future. What I did wrong was this:

After upload I rezzed the object right away without setting the permissions in the inventory before. The item permissions have to be set before rezzing inworld. Then you have the "inventory" permissions. Those apply then when you rezz it, just make sure and check again. Now you can insert scripts etc. Take the copy and the next owner will be able to modify it.

I fixed it by removing all scripts and having the mesh inside my inventory, then the * shows under next owner permissions and then I rezzed it inworld, put the scripts back in, sent it to alt, bam it works.

 

Thank you a lot!

  • Like 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 248 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...