Jump to content

Trouble Texturing Avatars


Rusalka Writer
 Share

You are about to reply to a thread that has been inactive for 4084 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I've been doing fine with Blender (2.49) UV texturing an entire house, no problems. Then today I tried a couple of avatars. They load fine, I can wear them fine, but their UV mapped textures don't come along. The avatars are white, and the textures are not in inventory. I have tried:

1. The latest successful Darwin build (230926).

2. Reimporting the Collada file into Blender. The textures loaded fine.

3. Dug through the jiras. Nothing there.

If it helps, the scale panel on the importer doesn't seem to work on avatars, either, although it does on buildings.

Link to comment
Share on other sites

I may misunderstand what you say, but I thought we had to upload textures separately from the mesh?

Also, does it not make sense that you can't scale a rigged mesh on upload? If you did, the deformations an weight paintinhg would not fit the avatar armature anymore, so the mesh would bend at the wrong places?

- Luc -

Link to comment
Share on other sites

Well, when you load a building, for example, that you've UV mapped in Blender it loads textured and the textures are loaded with the model. The avatars don't seem to be working the same way. I did upload the textures separately for one, and dragging them onto the parts of the avatar did correctly texture them into their assigned materials areas, and the mapping held up. I'm just wondering why they work differently.

So hard to distinguish bugs from unintended features.

Link to comment
Share on other sites

Heh. I didn't know that. The few times I have uploaded things, I've uploaded the textures separately without thinking about it.  It is strange that textures are handled differently for rigged meshes than for static meshes. Does not seem right, I think.

- Luc -

Link to comment
Share on other sites

At least it is possible to get some textures uploaded, so you don't have to stare at a bright white avatar all the time. I'm sure it will prevent some headaches and a lot of frustration down the road if this worked the same for both types of mesh. Maybe the Lindens in charge of this should be poked gently with a glowing iron and told this needs fixing. :)

- Luc -

Link to comment
Share on other sites

  • Lindens

We're re-working the upload pipeline. The desired behavior is that textures referenced in the collada file will be uploaded with the geometry and included in the upload fee calculation.

This work is not released yet however. Please retest once we've deployed the viewer & server combination for the new asset format (coming soon!). If it still reproduces after that release, please let us know ASAP as it is a bug we will want to fix. If you'd like to send in a sample collada file in advance, I can make sure our devs have acces to it to test the new pipeline.

 

 -Nyx

Link to comment
Share on other sites

  • 1 month later...
You are about to reply to a thread that has been inactive for 4084 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...