Jump to content

New User about to Give Up on SL - Firestorm Viewer has started Freezing/Glitching Constantly


You are about to reply to a thread that has been inactive for 193 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I just joined SL about 3 weeks ago. It seems like a world chock full of potential adventure, but I am having such severe issues that I may delete my account. It's a shame because I have bought Lindens and invested some in my avatar. 😔

A friend told me to use the Firestorm Viewer as it is more user friendly. I downloaded it about 3 weeks ago and other than the occasional lag, it seemed fine. I loaded in busy stores and rendered everyone almost without fail.

Then, about four days ago, it began to malfunction badly. I was in a shop when it froze and I got the spinning wheel of doom. I tried again and got the same thing within a minute of logging in. Then, I started getting it right away. I would have to force close every time as it froze and said "Not responding."

I tried loading in a different region. Same thing. I gave up that night and tried again in the morning. The freezing happened almost instantly. I finally uninstalled Firestorm and reviewed how to do a clean install. I followed the instructions, redownloaded Firestorm, and got the same result.

I did searches, read forums, and took a day off. Today, I restarted/recycled my modem via my Internet provider. I downloaded Firestorm and it worked for a little while. I managed to buy a head at Lelutka (which was not letting me in AT ALL at one point) and was working on updating my avatar when the screen started blacking out. It would flash black - on - black - on - black - on. Like it was having a seizure. I logged out, logged back in. This time, I froze. Each log in produced the freezing issue or the black out/screen on issue again.

That's a summary. Let me tell you everything else I have done to try and get SL to work and some info about my computer.

  • I have Windows 10 and have downloaded the latest viewer for Windows.
  • My computer is a Dell Inspiron 15 5501 Laptop purchased last year. I have 12 GB of ram. I was on IMVU before SL - and while IMVU does not require the same graphics rendering, I have always been able to use it and run multiple apps at once with little issue. I THINK my video card is dedicated. I am not a tech genius so I am not 100% sure.
  • I just checked my download speed on my wifi and it's 381.10 mbps.
  • Other things I have done to try and resolve: I have whitelisted Firestorm on my Avast firewall/security, done a clean install three times, cleaned my computer, checked for viruses, looked for and completed driver updates, rebooted/shutdown my laptop, loaded in quieter regions (which sometime allow me to hang on a few minutes but eventually, same result), and checked my processes to see if any unknown background application was dragging me down.

I am completely lost. While I wanted to have a "Second Life," I have no desire to take days from my ACTUAL life to get the platform to work. Any suggestions aside from what I have already done would be so appreciated. If not, I will just call my small investment a loss and move on. Thank you so much in advance! -Clara 🦊

 

Link to comment
Share on other sites

I am actually having the EXACT SAME ISSUE and I was told the same thing by the person who invited me here. I am coming from IMVU as well, i know that my computer isn't having issues because it's only sl that's doing this to me.. I find that to be very odd... I was also having this weird farting thing going on with my avatar until I left the room and reloaded.. Then started the screen thing that you mentioned.. Along with the screen thing, I kept getting a message saying that my computer was blocking the graphics... I have no idea what this means because the message only pops up when I have second life opened up... I am typing this on the webpage and it is not happening and it also doesn't happen when i'm on imvu. I was having very odd things happen in the first few days that I created my account.. It was the glitching, the lag, and i also had my avatar running on it's own.. I wasn't able to control it much, that seems to have stopped but it's weird.. Please let me know if you find out what was the cause or if you're able to fix it.. 

  • Like 1
Link to comment
Share on other sites

36 minutes ago, Alwin Alcott said:

please post your specs .. to find in the help/about menu of the viewer. Preferably when logged in.

 

I am having the same exact issue as this user, it's very strange.

Link to comment
Share on other sites

39 minutes ago, Alwin Alcott said:

please post your specs .. to find in the help/about menu of the viewer. Preferably when logged in.

 

I froze on my first few attempts to log but finally nabbed this before freezing again:

 

Firestorm 6.4.12 (62831) Dec  3 2020 22:34:49 (64bit / SSE2) (Firestorm-Releasex64) with Havok support
Release Notes

You are at 240.8, 145.5, 21.3 in Oritz located at ec2-54-202-167-85.us-west-2.compute.amazonaws.com
SLURL: http://maps.secondlife.com/secondlife/Oritz/241/146/21
(global coordinates 463,089.0, 306,322.0, 21.3)
Second Life Server 2021-01-08.554811
Release Notes

CPU: Intel(R) Core(TM) i5-1035G1 CPU @ 1.00GHz (1190.4 MHz)
Memory: 12052 MB
OS Version: Microsoft Windows 10 64-bit (Build 18363.1316)
Graphics Card Vendor: Intel
Graphics Card: Intel(R) UHD Graphics
Graphics Card Memory: 1024 MB

Windows Graphics Driver Version: 26.20.100.8141
OpenGL Version: 4.6.0 - Build 26.20.100.8141

RestrainedLove API: (disabled)
libcurl Version: libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.8 nghttp2/1.40.0
J2C Decoder Version: KDU v8.0.6
Audio Driver Version: FMOD Studio 2.01.05
Dullahan: 1.8.0.202007261348
  CEF: 81.3.10+gb223419+chromium-81.0.4044.138
  Chromium: 81.0.4044.138
LibVLC Version: 2.2.8
Voice Server Version: Not Connected
Settings mode: Firestorm
Viewer Skin: Firestorm (Grey)
Window size: 1920x1051 px
Font Used: Deja Vu (96 dpi)
Font Size Adjustment: 0 pt
UI Scaling: 1
Draw distance: 128 m
Bandwidth: 500 kbit/s
LOD factor: 2
Render quality: Medium-High (4/7)
Advanced Lighting Model: No
Texture memory: 768 MB (1)
VFS (cache) creation time (UTC): 2021-2-3T17:23:14
Built with MSVC version 1916
Packets Lost: 0/3,884 (0.0%)
February 05 2021 23:12:39 SLT

Edited by Clarapatra
Link to comment
Share on other sites

2 minutes ago, Xeneroso said:

I am actually having the EXACT SAME ISSUE...

I will. Another friend has tried to help me but to no avail. It's super frustrating - especially when trying to learn SL to begin with.

Link to comment
Share on other sites

1 hour ago, Clarapatra said:

 I THINK my video card is dedicated.

no it's onboard :)

In your specs isn't a lot of trouble showing at all. I'd advice not to follow the friends advice to use firestorm but try other lighter 3rd party viewers or even the LL official one. Firestorm isn't the most system friendly one.
http://wiki.secondlife.com/wiki/Third_Party_Viewer_Directory

It can help to lower the draw distance a bit, put the render quality ad medium, and avoid busy and heavy textured places

Edited by Alwin Alcott
  • Like 1
Link to comment
Share on other sites

While it's not the style of viewer that LL and most 3rd party viewers use these days, I have found that Singularity runs fine on Intel integrated graphics (on Linux, since I have not tested on Windows or Mac, ymmv...), even allowing advanced lighting and a 1GB texture setting. Do not use the main release version. I had some rendering bug with the water (again, ymmv). Personally, I prefer nightly build 8193 since it does not suffer from an issue that newer versions have with attachments and offline IMs, but you're welcome to try any of the available builds for your system.

http://www.singularityviewer.org/kb/nightly-builds

Eventually, these versions will become outdated, so don't get too attached to using them. Keep trying other viewers that get updated with the current LL standards.

  • Like 2
  • Haha 1
Link to comment
Share on other sites

9 hours ago, Alwin Alcott said:

no it's onboard :)
 

Thank you. I will try other viewers. Do you think my Video Card being onboard is an issue? And if so, should/could I change that in the future?

I'll update here after I try some other viewers.

Link to comment
Share on other sites

3 hours ago, KjartanEno said:

While it's not the style of viewer that LL and most 3rd party viewers use these days, I have found that Singularity runs fine on Intel integrated graphics (on Linux, since I have not tested on Windows or Mac, ymmv...), even allowing advanced lighting and a 1GB texture setting. Do not use the main release version. I had some rendering bug with the water (again, ymmv). Personally, I prefer nightly build 8193 since it does not suffer from an issue that newer versions have with attachments and offline IMs, but you're welcome to try any of the available builds for your system.

http://www.singularityviewer.org/kb/nightly-builds

Eventually, these versions will become outdated, so don't get too attached to using them. Keep trying other viewers that get updated with the current LL standards.

Thanks for that suggestion. I'll try it. I know nothing about the attachments and offline IMs but I'll take your word for it! Will just try it out.

Link to comment
Share on other sites

8 minutes ago, Clarapatra said:

Thank you. I will try other viewers. Do you think my Video Card being onboard is an issue? And if so, should/could I change that in the future?

I'll update here after I try some other viewers.

Yes, it can be an issue and the only real way to change that going forward is to ensure that when you next buy a Laptop, you ensure it actually has a discrete GPU instead of an APU.

Despite what some - here and elsewhere - will try and tell you, an APU is not a viable alternative to a proper GPU.

  • Like 1
Link to comment
Share on other sites

also keep in mind SL can be like a woman - it can have wild mood swings! lol Some days everything is peachy and the next day she's throwing pots and pans across the room!.... With your CPU and integrated graphics though I'd keep the Quality and Speed setting in Preference to Mid,  set the Avi count (in Phototools panel under general tab) to 10 about 5-10, make sure the Dynamic adjust level of detail is checked

the Alchemy viewer seems to run really well https://www.alchemyviewer.org/ you can try that one too

  • Like 1
Link to comment
Share on other sites

In all this I have seen no mention of antivirus whitelisting.  You antivirus and firewall can hinder and ultimately kill any software such as an SL viewer fromcommunicating via an internet connection.  In all the above cases the Firestorm wiki has suggestions and advice for both whitelisting and run crashes/not responding.

Check them out via the Fiestorm Blog.

https://wiki.firestormviewer.org/fs_run_crash

https://wiki.firestormviewer.org/antivirus_whitelisting?s[]=fs&s[]=whitelisting

 

Edited by Aishagain
  • Like 2
Link to comment
Share on other sites

1 hour ago, Aishagain said:

In all this I have seen no mention of antivirus whitelisting.  You antivirus and firewall can hinder and ultimately kill any software such as an SL viewer fromcommunicating via an internet connection.  In all the above cases the Firestorm wiki has suggestions and advice for both whitelisting and run crashes/not responding.

Check them out via the Fiestorm Blog.

https://wiki.firestormviewer.org/fs_run_crash

https://wiki.firestormviewer.org/antivirus_whitelisting?s[]=fs&s[]=whitelisting

 

The OP did mention white listing was already done.

  • Like 2
Link to comment
Share on other sites

An update....

I did some research to understand what GPUs are vs APU. I am not a gamer and have never had a reason to run a laptop with exceptional graphics. @Solar Legion is right... I will never be able to experience all the potential eye-candy SL has without investing in another computer. However, my laptop is pretty new and meets all my professional / personal needs and then some - so not being able to be on SL is not a reason to spend bones on a new computer. But at least now I know my limitations.

@RowanMinx is right. I did mention that I had whitelisted Firestorm in the OP. However, it's good that @Aishagain mentioned and linked me to Wiki as I had not gone through the full process of several restarts AND exceptioning the viewer and cache files specifically.

So, I did that earlier today. I have been on SL twice now using Firestorm. I loaded in some shops, updated my avatar, explored a huge park, and rode a hot air balloon over several regions. While it takes some time to render everything in heavier areas and I had some occasional lag, I never froze. Not once.

I may freeze up tomorrow but I'm optimistic that Avast was doing its job too well. If anything changes, I will post here. I appreciate @Alwin Alcott, @KjartanEno, and @Jackson Redstar for the viewer suggestions. I will whitelist and download those if Firestorm buckles again.

I am impressed with the generous information. I wanted to post earlier but I was at my daily limit, being a newbie and all. I have learned very quickly that a lot of SL folks are willing to offer advice and that's truly awesome. Thanks so much! -C 🦊

Edited by Clarapatra
forgot @
  • Like 9
Link to comment
Share on other sites

Sadly you even can have a high end computer and sl will not run smooth on it. That's because the majority of the so called creators upload mesh objects in here that would never exist in any game. And because we have nearly no limits while uploading something, this will not change, because uploading those unoptimized meshes is easier and most of the users still buy it, so it's quick profit with costs of good performance for everybody. 

  • Like 2
Link to comment
Share on other sites

@Clarapatra That your CPU runs at only 1Ghz puts it at half the recommended speed. System Requirements.

Since you computer uses on-board graphics all the CPU and GPU tasks are sharing the same engine. The graphics are set to dedicate 1GB to graphics. That is pretty limited.

While SL Viewers can run using the UHD graphics you have, it will not run well. I am surprised you ran well for a few days.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

On 2/8/2021 at 5:43 AM, Tonk Tomcat said:

Sadly you even can have a high end computer and sl will not run smooth on it. That's because the majority of the so called creators upload mesh objects in here that would never exist in any game. And because we have nearly no limits while uploading something, this will not change, because uploading those unoptimized meshes is easier and most of the users still buy it, so it's quick profit with costs of good performance for everybody. 

I am not familiar with meshes here or what is optimal or not. I was a creator for years at IMVU and we did have limits to how many... kbs... and MBs a product would use. We couldn't upload it if it crossed over. It was a pain a lot of the time but I think I get a very basic knowledge of what you mean.

Link to comment
Share on other sites

On 2/9/2021 at 6:27 PM, Nalates Urriah said:

@Clarapatra That your CPU runs at only 1Ghz puts it at half the recommended speed. System Requirements.

Since you computer uses on-board graphics all the CPU and GPU tasks are sharing the same engine. The graphics are set to dedicate 1GB to graphics. That is pretty limited.

While SL Viewers can run using the UHD graphics you have, it will not run well. I am surprised you ran well for a few days.

Thank you for sharing that. I made my SL account online and hit download, never seeing the reccomendations.  I assume it's on Firestorm's recommendations somewhere, too, but I would have probably skimmed it over with the assumption that I had it.  When you're not computer saavy, you get a new laptop, you have Windows 10, make a note of the RAM, and just assume you have what you need. All goes back to my computer being great for my current tasks (and then some) but maybe not SL.

I have been too busy to log on every day - but I have spent several hours online, twice since my last post - including tonight - with only the occasional issue of slight lag so fingers do stay crossed. No freezing or crashing or seizure screen since the updates to my Avast. Finally have a proper head and all. Still a fresh out of the clueless box as newbie and if I start siezing up again, I'll post here. -C 🦊

Link to comment
Share on other sites

On 2/11/2021 at 9:30 PM, Clarapatra said:

I have been too busy to log on every day - but I have spent several hours online, twice since my last post - including tonight - with only the occasional issue of slight lag so fingers do stay crossed. No freezing or crashing or seizure screen since the updates to my Avast. Finally have a proper head and all. Still a fresh out of the clueless box as newbie and if I start siezing up again, I'll post here. -C 🦊

Something that will help is to white list the SL install and cache folders in your anti-virus program. SL content is uploaded and scanned by the Lab. It is very difficult to get a virus past the scans and formatting that SL uses. So, on a practical level there is no need to virus scan the SL folders.

Windows program folder: C:\Program Files\Firestorm-Releasex64

In Firestorm look in Preferences->Network & Files->Directories You'll see where the cache and log files live.

Those folders can be white listed to improve SL's performance.

Link to comment
Share on other sites

13 hours ago, Nalates Urriah said:

Something that will help is to white list the SL install and cache folders in your anti-virus program. SL content is uploaded and scanned by the Lab. It is very difficult to get a virus past the scans and formatting that SL uses. So, on a practical level there is no need to virus scan the SL folders.

Windows program folder: C:\Program Files\Firestorm-Releasex64

In Firestorm look in Preferences->Network & Files->Directories You'll see where the cache and log files live.

Those folders can be white listed to improve SL's performance.

Thank you. I did do that as mentioned on Feb. 7th's post update. It seems to be what has helped me so far.

Link to comment
Share on other sites

  • 3 weeks later...
On 2/13/2021 at 3:10 PM, Clarapatra said:

Thank you. I did do that as mentioned on Feb. 7th's post update. It seems to be what has helped me so far.

 

On 2/13/2021 at 3:10 PM, Clarapatra said:

Thank you. I did do that as mentioned on Feb. 7th's post update. It seems to be what has helped me so far.

I am not too sure if you figured out what happened with your account. I figured out what happened with mine, someone accessed my account without my permission when I allowed her onto my account to help me dress up my avatar.. Unfortunately for her, I am serious about online harassment so I'll be filing a police report against her. I hope that it's just a glitch for you and someone hasn't compromised your account. I hope that you were able to figure out what happened with your account. 

  • Confused 1
Link to comment
Share on other sites

59 minutes ago, Xeneroso said:

someone accessed my account without my permission when I allowed her onto my account to help me dress up my avatar.. Unfortunately for her, I am serious about online harassment so I'll be filing a police report against her. I hope that it's just a glitch for you and someone hasn't compromised your account. I hope that you were able to figure out what happened with your account. 

as you gave the account in hands of others, you'r fully responsible for the things happening caused by that.

  • Like 2
Link to comment
Share on other sites

22 hours ago, Xeneroso said:

someone accessed my account without my permission when I allowed her onto my account

The bolded part totally obliterates the non-bolded part.

 

22 hours ago, Xeneroso said:

I'll be filing a police report against her.

Good luck with that.  They'll likely tell you what you should have known -- do not give other people access to your accounts.  

 

  • Like 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 193 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...