Jump to content

Grid Map repair ETA?


You are about to reply to a thread that has been inactive for 171 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

28 minutes ago, JohnLewsey said:

Oz linden posted in https://community.secondlife.com/forums/topic/464868-world-map/ "the data needed to generate the maps has been moved to AWS, but the code that does the work has not yet. Because of how the datacenter version expected to fetch that data, it was not possible for us to make it work until the code has been moved too."

And that was 20th December.  I don't think it is unreasonable to expect some progress from that point to now, or at least some information on either this forum or the Blog, is it?

I know we shared a joke with RowanMinx's post above but the joke is wearing a bit thin.

Edited by Aishagain
  • Like 3
  • Haha 1
Link to comment
Share on other sites

 

I want to search and buy more mainland but the lack of being able to see the map in full and to figure where the spots are located is really disturbing and damaging.

I got 2 bellisseria homes that i still can not figure where they are located on the map regarding to the rest.

Map tiles issue should be the 1st priority right now and looks like they are not.

 

 

 

  • Thanks 1
Link to comment
Share on other sites

15 minutes ago, foneco Zuzu said:

Map tiles issue should be the 1st priority right now and looks like they are not.

I gather it's pretty high on the priority list, though, based on a general sense I got from @Oz Linden's response when I asked about it at last week's sim user group. I'll try to ask again today, and hope to get more specifics.

Unless they're doing something weird, this should require no corresponding sim nor viewer updates, so I'd expect it to happen on its own schedule, as if by magic one day.

  • Like 3
Link to comment
Share on other sites

1 hour ago, Qie Niangao said:

I gather it's pretty high on the priority list, though, based on a general sense I got from @Oz Linden's response when I asked about it at last week's sim user group. I'll try to ask again today, and hope to get more specifics.

Unless they're doing something weird, this should require no corresponding sim nor viewer updates, so I'd expect it to happen on its own schedule, as if by magic one day.

   i guess the code is to old and nobody in the lab knows how to fix it cause there is nobody left from those times.

  • Sad 1
Link to comment
Share on other sites

12 minutes ago, foneco Zuzu said:

   i guess the code is to old and nobody in the lab knows how to fix it cause there is nobody left from those times.

Yeah, it's probably pretty old, and you may remember that every couple of years it throws a sprocket and vertical bands of the map aren't updated until somebody steps in and re-torques the manifold bolts or something to get it working again. And I don't think the far northeast corner of Zindra has ever appeared at map zoom level 3.

On the other hand, they've relatively recently updated the code that exposes the region tiles and other map contents, migrating from the (once free) Google Map API to Leaflet.

  • Like 1
Link to comment
Share on other sites

6 minutes ago, Qie Niangao said:

Yeah, it's probably pretty old, and you may remember that every couple of years it throws a sprocket and vertical bands of the map aren't updated until somebody steps in and re-torques the manifold bolts or something to get it working again. And I don't think the far northeast corner of Zindra has ever appeared at map zoom level 3.

On the other hand, they've relatively recently updated the code that exposes the region tiles and other map contents, migrating from the (once free) Google Map API to Leaflet.

We must hope and in meanwhile enjoy SL the best we can:)

 

  • Like 2
Link to comment
Share on other sites

I'm following the Jira on this issue, and yesterday there was a NEW comment on it from a Linden.  I checked, he said 'check out the Status page' !  I rushed to the status page, and it hasn't been changed since before the flood.

Fingers out Lindens!

  • Haha 3
  • Sad 1
Link to comment
Share on other sites

6 hours ago, Anna Nova said:

I'm following the Jira on this issue

Oh, which Jira? The only one I know of is https://jira.secondlife.com/browse/BUG-225252 which isn't showing any recent activity, and doesn't seem to list you among the followers, so maybe you're tracking one the Lindens have linked to their internal system.

I guess I'll confess that I did ask @Oz Linden at the user group yesterday -- twice, actually -- but he may have been otherwise engaged. (Or maybe he has me on mute?) Anyway, no response to report, sorry.

  • Sad 2
Link to comment
Share on other sites

9 hours ago, Anna Nova said:

I'm following the Jira on this issue, and yesterday there was a NEW comment on it from a Linden.  I checked, he said 'check out the Status page' !  I rushed to the status page, and it hasn't been changed since before the flood.

Yep, the Linden ability to state the blindingly obvious but I suspect also a reiteration by default of the "we know the fix but we won't be applying it any time soon" statement in that post on the GSP.  Maybe if we keep banging on about it LL will realise that it IS actually quite important to users.  I'm not holding my breath.

The selective deafness of senior Lindens regarding matters that they do not wish to discuss at user-group meetings is why I no longer bother with them.

Edited by Aishagain
  • Like 2
Link to comment
Share on other sites

Perhaps the dev team had a budget cut with the new ownership. The Linden Lab jobs page previously had some technical job postings for server-side engineers. Those are gone, but we haven't seen any new server-side Lindens. Instead, the jobs page has only a technical job for Tilia ("Here on the Ecom engineering team, we accomplish this by building a growing set of financial capabilities on top of our regulatory licenses. Some of these capabilities include processing payments and payouts, verifying user identities, detecting fraud and enforcing sanctions") and an entry level customer support position. I asked about this at Server User Group, and got a meaningless answer.

Edited by animats
  • Like 3
  • Sad 1
Link to comment
Share on other sites

7 hours ago, Qie Niangao said:

Oh, which Jira? The only one I know of is https://jira.secondlife.com/browse/BUG-225252 which isn't showing any recent activity, and doesn't seem to list you among the followers, so maybe you're tracking one the Lindens have linked to their internal system.

I guess I'll confess that I did ask @Oz Linden at the user group yesterday -- twice, actually -- but he may have been otherwise engaged. (Or maybe he has me on mute?) Anyway, no response to report, sorry.

https://jira.secondlife.com/browse/BUG-229888

I'll follow yours now too. Qie.

  • Like 1
Link to comment
Share on other sites

  • Lindens
7 hours ago, Qie Niangao said:

I guess I'll confess that I did ask @Oz Linden at the user group yesterday -- twice, actually -- but he may have been otherwise engaged. (Or maybe he has me on mute?)

I missed the question (I had a lot going on outside the meeting and was multitasking, sorry).

I do my best not to predict dates because it doesn't add anything when I'm right, and does a lot of harm when I'm wrong.

We have one of our most skilled developers devoted to getting map tile generation working again - it's one of those things that hadn't been touched in a long time and needed more work than we expected.

  • Thanks 11
Link to comment
Share on other sites

  • Lindens
3 hours ago, animats said:

Perhaps the dev team had a budget cut with the new ownership. The Linden Lab jobs page previously had some technical job postings for server-side engineers. Those are gone, but we haven't seen any new server-side Lindens.

Not so. I hate to break it to you, but you can't see most of the people who do the most of the real work. That position was filled internally, not cancelled.

  • Thanks 8
Link to comment
Share on other sites

3 hours ago, Oz Linden said:

I missed the question (I had a lot going on outside the meeting and was multitasking, sorry).

I do my best not to predict dates because it doesn't add anything when I'm right, and does a lot of harm when I'm wrong.

We have one of our most skilled developers devoted to getting map tile generation working again - it's one of those things that hadn't been touched in a long time and needed more work than we expected.

Tks Oz

  • Like 2
Link to comment
Share on other sites

Ok, so basically the underlying code is needing a complete re-write. This is a basic function of SL that residents count on. It hasn't worked right in several months. Even before that it didn't work very well so I hope the waiting results in a MUCH faster rezzing map than we've had in the past. If it needs more than one dev, please assign them. This is right up there with group chat issues and the texture cache never actually having worked well, but the latter two we are all used to being borked.

Edited by Crim Mip
  • Like 4
  • Thanks 2
Link to comment
Share on other sites

On 1/14/2021 at 12:23 AM, Mollymews said:

my mini-map started showing terrain again last night. Had been blue for quite a while. I like seeing terrain

mini maps garbage

Second Life Marketplace - SA - GPS/Transponder HUD

more detail and shows your vehicle and other players vehicles on map if they have hud allot less boring then in house viewer built in mini map

ATC Radar

it would be nice if they released a full scale world map variant for in world not just on website

  • Haha 2
Link to comment
Share on other sites

Tried to go exploring a couple of days ago, but found it just about impossible without a second person to navigate.  When I roped someone in to help, they did so, but became very frustrated with the map.  SL is supposed to be fun, so we gave it up shortly.  As I mentioned on another thread, why have large interconnected continents and waterways if it's so VERY difficult to travel?

/me sends eclairs to the lone developer who is evidently trying to rewrite the map software. 

  • Like 3
Link to comment
Share on other sites

It is almost impossible to explore at the moment, especially by sea or look for land to purchase with the map the way it is!
It is driving so many potty and putting a lot of people off from what I am hearing.... such a shame as it used to be so much fun now it is just frustrating and has been going on for such a long time! It sucks even more so with the new continents that you have no sense of direction with yet!
  • Like 2
Link to comment
Share on other sites

It's no picnic trying to make sense of the auction page, either.

Honestly, if we'd known it would take this long, some user might have crafted a (Mainland only) web service by now that fabricated a few successive zoom levels of map images from the base region texture files. The storage wouldn't be that scary, but the transmitted data volume could be pretty high.

I'm not sure, though, if the base region textures are being updated now. If not, such a service would show outdated images (which would still be better than what we have now). Anyway the lack of schedule for a fix presents a kind of "halting problem" -- it might be fixed the next time we login, or the fix might never appear, there's just no telling.

  • Like 4
Link to comment
Share on other sites

There is now this update, which would seem to imply that they

HAVE NOT BEEN EVEN WORKING ON THE MAP UNTIL THIS MONTH

Quote
Update - Now that Uplift has finished we are working to restore the map tile functionality. We still do not have an ETA, but please follow this blog for updates and thank you for your patience!
Jan 21, 11:23 PST
Identified - We have identified the issue and will be implementing a fix, but not not have an ETA for the resolution. Please note the map tile issue also affects new region owners as well as current owners. Thank you very much for your patience, and watch this blog for updates.
Nov 19, 06:49 PST

So, Lindens, thank you for the update.  Except for the fact that your update is devoid of information.

Here are some things LL COULD share that would make it easier to wait:

1. What is the nature of the problem with the map?  Previously @Oz Linden said that the problem was that some of its software hadn't been uplifted.  Was that just a wish, a lie, or what?

2.  Assuming Oz's statement was just an ill-informed wish, that would imply that some problem was eventually uncovered that prevents the map from updating in the cloud environment.  Is it possible that something about AWS makes it nearly impossible to gather data for map tiles that are synchronized enough to build a coherent map?  If something like that is the case, perhaps the UI/functional specification for the map could be changed so that it is USABLE, but not PERFECT.

3.  Can we have an order-of-magnitude estimate for the fix?

4.  Has LL looked for any partial workarounds that improve map performance in the interim before a fix?

What patience are we being thanked for?   Because at this point that's one thing I'm completely out of.

  • Like 3
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 171 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...