Jump to content

Thousands of parcels not showing in Land Search


Recommended Posts

  • Lindens
On 6/18/2021 at 10:33 AM, Count Burks said:

I go to land search, I search for Homestead Private Land. I get 356 results. 95% of these results is for anshe, a meager 5% is for other parcels of other estates while most estates are completely excluded. And this has been going on for over 6 months now. 

The money the other estates are paying is not good enough or what?

 

Hi Count,  I'm sorry you're having trouble with Search.  We've tried to replicate the problem, but so far haven't had any luck.  Unfortunately, Search isn't an issue that we can troubleshoot in the forums since we need very specific information to try to track down the problem.  If you could submit a support ticket with the following information on it and ask it to be sent to my attention (I'll let them know to be on the look out for it) then we might have better luck trying to locate the issue.  For this repro, I will need you to use the official Second Life viewer, as the Firestorm viewer results can differ.  On that support ticket, please include the full parcel name and description of at least 1 but not more than 3 test parcels that should be showing in Search but are not.  Once I have that info, I can have an engineer take a look and we can get back to you on that support ticket as soon as we've had the chance to look into it.

Thank you!

 

  • Like 4
  • Thanks 1
Link to comment
Share on other sites

20 hours ago, Keira Linden said:

Hi Count,  I'm sorry you're having trouble with Search.  We've tried to replicate the problem, but so far haven't had any luck.  Unfortunately, Search isn't an issue that we can troubleshoot in the forums since we need very specific information to try to track down the problem.  If you could submit a support ticket with the following information on it and ask it to be sent to my attention (I'll let them know to be on the look out for it) then we might have better luck trying to locate the issue.  For this repro, I will need you to use the official Second Life viewer, as the Firestorm viewer results can differ.  On that support ticket, please include the full parcel name and description of at least 1 but not more than 3 test parcels that should be showing in Search but are not.  Once I have that info, I can have an engineer take a look and we can get back to you on that support ticket as soon as we've had the chance to look into it.

Thank you!

 

I will submit another ticket about this. I also think you can exclude that Firestorm would have anything to do with this as this is completely web based.

I will put this here so others can also see:

Second Life Search

A fast review of my current parcels which are listed for sale amounts to 120 parcels at the moment. For 6 months none have been showing up. As mentioned before this is not just me I see other Estates have none of their parcels in search or only a very small amount. When I go to Land Search and search for "Dreamworld" I should see all my parcels showing up just fine and I see none. 

Another perfect example of how broken Land Search is:

Again web based search, I look for parcels between 1004 and 1026 meters (looking for standard 1024 meters). Only 299 results show up on private islands. Do you really think there are only 299 parcels of 1024 meters available in Second Life to rent on private islands? Scroll through the results and look who is offering these parcels.

Second Life Search           (results of parcels of 1024 meters) 

98% of these parcels are offered by only 2 Estates which is Anshe Chung and AME Estate. Where are the results from everyone else? There should be several thousand results instead.

 

 

This is not just with my land, here is another example of an Estate that should have at least a hundred parcels listed in search. Name of Estate Lionheart, this estate has 1 parcel showing in Land Search.

Second Life Search

 

The land search system is completely broken and has been for at least half a year. For some reason the majority of parcels in your database is simply getting ignored.

 

  • Like 2
Link to comment
Share on other sites

3 hours ago, Keira Linden said:

Thank you!  Hopefully we'll be getting back to you shortly with our findings on that ticket.

Web search in general hasn't been working.  I filed a jira months ago.  Trying to search a specific avatar name would return result for 100s of people and things but not the specific name I searched.  The person was not hidden from search either.

https://jira.secondlife.com/browse/BUG-230051

  • Like 1
Link to comment
Share on other sites

On 6/11/2021 at 4:25 AM, Qie Niangao said:

I understand that. Still, it may be that maintenance of all Search-related functionality is organizationally "Web". At least Rider claims that this one is.

The jira that @Count Burks filed back on January 9th was linked to (and closed as duplicate of) an internal jira, WENG-5684 (invisible to us) on January 29th. I simply don't know how to advance the issue further, despite recognizing it cripples the whole platform.

Maybe if we all ask the same question for the Lab leadership at their SL17B Lab Gab session, they'd bestir themselves to find out what's happening with this, and maybe even stir up some attention to fixing it. They'd much rather discuss broader subjects, so the question would need to be brief—certainly no more than ten words—in order to even be considered for asking. If this approach makes sense, who wants the drafting pen?

(Personally, I'd really like to know how we're supposed to handle issues like this that vanish behind their mystical internal jira process, never to be seen again. It's one thing if this is to delay the grand announcement of a brand new Search mechanism so revolutionary I'd be selling my Google stock, SEC beware. It's another thing if they just don't want us to see the sausage being made.)

It got ignored at the Lab Gag meetings.

I don't think it's worth pestering Wendi Linden again with this at Concierge, they can't make decisions but just take notes, and they've noted it twice already (and no change).

So maybe web users' group?

It's inworld search, however that is really the pain point.

Link to comment
Share on other sites

On 6/21/2021 at 3:44 PM, Keira Linden said:

Hi Count,  I'm sorry you're having trouble with Search.  We've tried to replicate the problem, but so far haven't had any luck.  Unfortunately, Search isn't an issue that we can troubleshoot in the forums since we need very specific information to try to track down the problem.  If you could submit a support ticket with the following information on it and ask it to be sent to my attention (I'll let them know to be on the look out for it) then we might have better luck trying to locate the issue.  For this repro, I will need you to use the official Second Life viewer, as the Firestorm viewer results can differ.  On that support ticket, please include the full parcel name and description of at least 1 but not more than 3 test parcels that should be showing in Search but are not.  Once I have that info, I can have an engineer take a look and we can get back to you on that support ticket as soon as we've had the chance to look into it.

Thank you!

 

Thanks for your response. I personally have filed a ticket that I have added to for months, have been told it was fixed, have persisted because it wasn't, have had many answers, and then the Lindens fell silent, and I was told to start over again. So eventually I will do that.

In the mean time, let me help you replicate it.

So type "Keira Linden" into search/people

More than 1000 returns, yet fortunately, you are on top in the very first return. So exact searches must work, right?

OK, now try "Dottie Linden".

Try "Space Linden".

Try "Izzy Linden". 

Starting to see a pattern?

Ok, I hope you can see the problem now!

So, does this just affect names? No.

Try "Tapestry of Time". 7,827 returns. 

Compare and contrast with:

Svarga (1 return)

Ivory Tower of Primitives (10,000 returns)

The Shelter (9,929 returns)

Edited by Prokofy Neva
  • Like 1
Link to comment
Share on other sites

12 minutes ago, Rowan Amore said:

The example I sent with my jira.  No where on that page is Sage Mellow.

Screenshot_20210124-212050.png

If you have put it in search/places by paying 30L for it to be in search/places, a search on the exact name should turn it up in first place, with not so many returns. That was the previous behaviour for years. So if I put 100 lots from Ravenglass Rentals in search/places for 30L each, then I had a list of 100. Now I have a list of thousands and not all of them show up in the first pages. 

The Lindens (and some forums regs) seem to think this is a complaint about "not showing up in search on top". But that's not the complaint at all. I don't expect that if I type "rentals" in, I will show up first or even 10 pages in. If I type in the exact name of my company "Ravenglass Rentals," however, I expect to get 100 or so returns from the search ads I paid for *because that's how it worked for years on end*.

So hopefully Izzy Linden will do a search on his name and begin to feel the problem. 

Edited by Prokofy Neva
Link to comment
Share on other sites

I noticed search throwing really weird results for a while now and was thinking maybe it's me, and actually have stopped using inworld search completely since it was not reliable at all anymore. I really hope they fix that :|

what helped sometimes is going to the places tab and then search, but the websearch tab is for the birds XD 

Link to comment
Share on other sites

15 hours ago, Rowan Amore said:

The example I sent with my jira.  No where on that page is Sage Mellow.

Screenshot_20210124-212050.png

I think understand why this is happening, it's because "sage" and "mellow" are both common terms used all over. It makes sense. Normally when  you have this problem you can put your search in quotes, so instead of Sage Mellow being searched you do "Sage Mellow" (with the quotes). But it had no effect. But looking at the results on my end, it looks like it's just searching for "sage" and "mellow" and merging the results for the two instead of finding everything that matches sage AND mellow. I don't know if that makes sense, but it's not looking for results and saying "This contains 'sage' and 'mellow', rank it higher", it's just taking everything that matches "sage" and everything that matches "mellow" it's like it's searching for Sage OR Mellow instead of Sage AND Mellow.

I'm assuming the same thing is happening with "Ravenglass Rentals", instead of searching for things with ravenglass and rentals it's searching for ravenglass and searching for rentals then merging the results, so things that just match "rentals" are thrown into the results.

I don't know what software LL is using for this, I use ElasticSearch and have experience with it and this kind of thing is usually a really simple mistake. I've been lurking here because search functioning properly has a huge effect on everyone, especially merchants who are trying to get their relevant products to people who are looking for them.

Edited by Flea Yatsenko
Link to comment
Share on other sites

18 minutes ago, Flea Yatsenko said:

I think understand why this is happening, it's because "sage" and "mellow" are both common terms used all over. It makes sense. Normally when  you have this problem you can put your search in quotes, so instead of Sage Mellow being searched you do "Sage Mellow" (with the quotes). But it had no effect. But looking at the results on my end, it looks like it's just searching for "sage" and "mellow" and merging the results for the two instead of finding everything that matches sage AND mellow. I don't know if that makes sense, but it's not looking for results and saying "This contains 'sage' and 'mellow', rank it higher", it's just taking everything that matches "sage" and everything that matches "mellow" it's like it's searching for Sage OR Mellow instead of Sage AND Mellow.

I'm assuming the same thing is happening with "Ravenglass Rentals", instead of searching for things with ravenglass and rentals it's searching for ravenglass and searching for rentals then merging the results, so things that just match "rentals" are thrown into the results.

I don't know what software LL is using for this, I use ElasticSearch and have experience with it and this kind of thing is usually a really simple mistake. I've been lurking here because search functioning properly has a huge effect on everyone, especially merchants who are trying to get their relevant products to people who are looking for them.

When you search a specific name, that name used to come up first in search followed by all those others.  This is new behavior.  It doesn't do this in firestorm legacy search but only in web search.

Link to comment
Share on other sites

2 hours ago, Rowan Amore said:

Well, to be fair, Sage Mellow is a person and  not a place.

Owner name shows up on those pages, when they are generated.  I do not know if Sage Mellow owns land or if they have a group that owns land.

I also am not SURE that LL's search still uses those pages.

Link to comment
Share on other sites

My point is this:  This search method was quite useful in years past.  It is very useless now, and I wonder if this uselessness is related to the uselessness of search tools in Second Life Viewer.

I too would like to have access to the database search UI that was removed from Second Life Viewer but I won't use a third party viewer to get it.

image.png

Link to comment
Share on other sites

  • 3 weeks later...
Posted (edited)

💥 UPDATE FOR THOSE FOLLOWING THIS TOPIC 💥

After going back-and-forth with Linden Lab support for about a week to determine what exactly isn't functioning with Land Search and the reason why my parcels and the parcels of many others aren't being displayed, the source of the issue can be described as follows:

Around the period of december 2020 - january 2021 some engineer / developer at Linden Lab made an error (that's putting it lightly) where the Land Search code was altered. 

This caused the following glitch in Land Search : Unless you submit a parcel to PLACES SEARCH and pay 30L$ per week to do so the parcel will not show up in Land Search anymore.

It is not the case that Linden Lab suddenly out of nothing decided to modify the Land Search system and began to charge to have parcels listed in Land Search.

On top of this after a parcel is submitted to places search it takes another 2 days at the moment before it even shows up in Land Search. (When you set a parcel for sale it should show up in search after a couple of minutes instead of days)

This "system glitch" now also makes it so that Places Search is currently getting spammed by thousands of land parcels that are available for sale or rent. When residents use Places Search they will often arrive at empty parcels available for rent which makes exploring Second Life less attractive and hinders finding interesting places to visit.

This bug is active for both mainland and private estate land search.

_____________________________________________________________________________________________________________________________________________________________

Linden Lab has been informed about Land Search not functioning as it should by myself and others at the beginning of the year in january. 

I will refrain from pointing fingers at certain individuals since support informed me they are now currently working on the issue and will make sure Land Search will work again like it should in the near future.

Land Search is a basic essential tool/service and should never get corrupted like this and certainly NOT remain undetected for 7 to 8 months.

 

Edited by Count Burks
  • Like 1
Link to comment
Share on other sites

13 minutes ago, Count Burks said:

💥 UPDATE FOR THOSE FOLLOWING THIS TOPIC 💥

After going back-and-forth with Linden Lab support for about a week to determine what exactly isn't functioning with Land Search and the reason why my parcels and the parcels of many others aren't being displayed, the source of the issue can be described as follows:

Around the period of december 2020 - january 2021 some engineer / developer at Linden Lab made an error (that's putting it lightly) where the Land Search code was altered. 

This caused the following glitch in Land Search : Unless you submit a parcel to PLACES SEARCH and pay 30L$ per week to do so the parcel will not show up in Land Search anymore.

It is not the case that Linden Lab suddenly out of nothing decided to modify the Land Search system and began to charge to have parcels listed in Land Search.

On top of this after a parcel is submitted to places search it takes another 2 days at the moment before it even shows up in Land Search. (When you set a parcel for sale it should show up in search after a couple of minutes instead of days)

This "system glitch" now also makes it so that Places Search is currently getting spammed by thousands of land parcels that are available for sale or rent. When residents use Places Search they will often arrive at empty parcels available for rent which makes exploring Second Life less attractive and hinders finding interesting places to visit.

This bug is active for both mainland and private estate land search.

_____________________________________________________________________________________________________________________________________________________________

Linden Lab has been informed about Land Search not functioning as it should by myself and others at the beginning of the year in january. 

I will refrain from pointing fingers at certain individuals since support informed me they are now currently working on the issue and will make sure Land Search will work again like it should in the near future.

Land Search is a basic essential tool/service and should never get corrupted like this and certainly NOT remain undetected for 7 to 8 months.

 

However, all that does not explain why People Search isn't functioning correctly either.  I've searched numerous times for a person using their exact name, they aren't hiding from search,  yet there name does not appear on the first or even the second page.  Although, the answer given to you about LAND may be true, it would be nice if they did something about the rest of search not working.

Link to comment
Share on other sites

10 hours ago, Rowan Amore said:

However, all that does not explain why People Search isn't functioning correctly either.  I've searched numerous times for a person using their exact name, they aren't hiding from search,  yet there name does not appear on the first or even the second page.  Although, the answer given to you about LAND may be true, it would be nice if they did something about the rest of search not working.

The entire web based search system has never been optimal. To solve your issue with the exact name search you can use the People search button in the Firestorm viewer. This is still based on the old search system which worked as it is supposed to work. It does exact search for a name and is much faster at displaying correct results.

Otherwise you will need to start filing support tickets with Linden Lab if you want them to look at this. 

 

Link to comment
Share on other sites

1 hour ago, Count Burks said:

The entire web based search system has never been optimal. To solve your issue with the exact name search you can use the People search button in the Firestorm viewer. This is still based on the old search system which worked as it is supposed to work. It does exact search for a name and is much faster at displaying correct results.

Otherwise you will need to start filing support tickets with Linden Lab if you want them to look at this. 

 

I've already filed 2 jiras on the name search.  I do normally use the firestorm person search when logged in.  There is no work around, however, if you are trying to use people search from the website.  It's been like that for probably close to a year now.

Link to comment
Share on other sites

10 hours ago, Count Burks said:

The entire web based search system has never been optimal. To solve your issue with the exact name search you can use the People search button in the Firestorm viewer. This is still based on the old search system which worked as it is supposed to work. It does exact search for a name and is much faster at displaying correct results.

Otherwise you will need to start filing support tickets with Linden Lab if you want them to look at this. 

 

I'm not so sure that is true. I use Firestorm, and since my first name is a single character it usually does not show up in search. I say usually because every once in a while it works.

I have purchased a couple of abandoned parcels lately, and the Linden that came to set the land for sale to me had to IM me to get me to come there, so that I  showed up in their "Near Me" list. So even the Lindens cannot find me in People Search.

Do Lindens even use Firestorm?

Link to comment
Share on other sites

3 hours ago, M Peccable said:

I'm not so sure that is true. I use Firestorm, and since my first name is a single character it usually does not show up in search. I say usually because every once in a while it works.

I have purchased a couple of abandoned parcels lately, and the Linden that came to set the land for sale to me had to IM me to get me to come there, so that I  showed up in their "Near Me" list. So even the Lindens cannot find me in People Search.

Do Lindens even use Firestorm?

Lindens are required to use the SL viewer.  

Link to comment
Share on other sites

On 7/14/2021 at 11:00 AM, Count Burks said:

This caused the following glitch in Land Search : Unless you submit a parcel to PLACES SEARCH and pay 30L$ per week to do so the parcel will not show up in Land Search anymore.

So uhh... not to be captain obvious but...

"Show Place in Search" has always been an option for L$30 a week.  If you enable the option -- your place shows up in search results.  Parcels are automatically enrolled in place pages when you tick them to show up in search.  Are you implying that parcels or places should show up in search if it's not ticked?  If so, are you then complaining that things aren't showing up in search when it's not ticked?

Please clarify.

Link to comment
Share on other sites

9 hours ago, NeoBokrug Elytis said:

So uhh... not to be captain obvious but...

"Show Place in Search" has always been an option for L$30 a week.  If you enable the option -- your place shows up in search results.  Parcels are automatically enrolled in place pages when you tick them to show up in search.  Are you implying that parcels or places should show up in search if it's not ticked?  If so, are you then complaining that things aren't showing up in search when it's not ticked?

Please clarify.

1. Land Search and Places Search are two separate things.

2. Yes to have a parcel listed in Places Search you always pay 30L$ per week.

3. Every single parcel that gets listed for sale, either mainland or Estate Land is supposed to show up directly in LAND SEARCH (this excludes places search) like it has has always been the case in the previous 18 years since LAND SEARCH was established without any charge.

This system worked fine until it got broken in december 2020. You have your Roleplay sims with some parcels you offer for rent, because of the current situation you are forced to pay 30L$ per week per parcel to have your parcels show up in search. In theory it is not even needed to list these parcels in Places Search as people who look for land use LAND SEARCH.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...