Jump to content

Help me please with sculpties!


You are about to reply to a thread that has been inactive for 4140 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

There are many reasons why you could be experiencing the problem. If you go to this website and follow the Blender trail you will get insight into how a SL sculptie will need to be made in order for it to look good inWorld.  Hope this helps with your problem :D

http://blog.machinimatrix.org/

 

Look under the Sculpties tab then Beginner Basics and that should help you with your probems :D

Link to comment
Share on other sites

Can we get a picture?

 

Crooked can be very subjective.

 

I use a sculpting app that essentially shows sculpts at 256x256, but won't put out a map larger than 128x128, which then rezzes as 32x32 in any case. I take for granted that rezzes are only ever going to have less subtle curves than the original.

Also, though, I've seen some occasional problems with jaggedness that can't be explained simply by the reduced resolution. A lot of sculpts I loaded when I was using Mac seems to get noisy for no obvious reason. I thought it was a viewer issue, but even checking the sculpts again with a different viewer on a Sony Vaio years later, they remain inexplicably jagged.

For certain, if you are putting your sculpts through Google Chrome at any stage of the process, you want to stop that right away. Need I explain why?

 

Link to comment
Share on other sites

When sculpties started the maps were uploaded with lossy jpeg2000 compression, which introduced distortions. Using maps with larger dimensions than the standard 64x64 was seen to reduce the distortion, but the sculpty code simply sampled the pixels as if it was 64x64. However, all sculpt maps, including the newer oblong sizes, can now be uploaded with lossless compression (checkbox on the upload dialog). Using larger maps now wastes resources, slows map loading and leaves the distortion. So it really is best now to stick to the 64x64 and multiples (32x128, 16x256, 8x512) with the same number of pixels. You can also use smaller maps where you don't need so many vertices. There is a table of most sizes and how many quads are used by subsampling pixels at different levels of detail here.

Link to comment
Share on other sites

 


Josh Susanto wrote:A lot of sculpts I loaded when I was using Mac seems to get noisy for no obvious reason. I thought it was a viewer issue, but even checking the sculpts again with a different viewer on a Sony Vaio years later, they remain inexplicably jagged.

I am curious to see some of your jagged sculpties. If you make one of the original models (from which you derive your sculpties) available as .obj, then i will take a look at it and tell you why it ends up jagged in SL ;-)

Link to comment
Share on other sites

>I am curious to see some of your jagged sculpties

It's a problem I'm no longer having with new sculpts.

While I was still on the Mac, I tried all kinds of advice, such as different map dimensions and using/not using lossless compression.

I never have had any luck importing or exporting anything as .obj, but if I can find some of the bad maps I haven't deleted, I can certainly provide some kind of example.

Link to comment
Share on other sites

This looks pretty much like a lossless compression issue. Or maybe for some reason you have not exported your map as a 64*64 pixel image but smaller. There are still many possible reasons for failure, but your result can certainly be improved.

You might want to publish the blend file e.g. to http://pasteall.org/blend and tell us the link. I am quite sure your problem can be solved much faster then without guessing too much ;-) ...

Link to comment
Share on other sites

In my experience, lossless compression does not always prevent these effects, and sometimes they are actually worse.

Looking at the pictures some more, it appears your spine is on the blue axis. I usually use green axis, but I don't see any reason that should matter unless your axis of symmetry in the map is horizontal rather than vertical.

You can probably rectify at least one axis (in your case, blue) by reducing the dimensions of the map perpendicular to that axis down to 1 pixel, expanding back to normal dimensions, and then reload from that the rectified layer into the original map.

Link to comment
Share on other sites

Lossy compression, as usually used in jpegs, changes the colors of some pixels to achieve greater compression and reduce download time, thus losing some of the information in the original image. The changes should be too small for the human eye to see in the image, but when the colors are used as the vertex coordinates in a sculpty, the vertices are visibly shifted.

There are other, lossless, methods of compression that don't lose any of the original data, such as that used in png images. The trade off is that they don't achieve as much compression except for images with large areas of identical pixels. So the bitmaps used for sculpt maps need to be saved in a non-lossy format (png,tga,...).

When they are uploaded from the viewer, they are always converted into jpeg2000 format. By default, that uses lossy compression, but at the lower left of the preview there is a "use lossless compression" checkbox which should be checked for sculpt maps. Then it will use lossless compression. This is available for all images with the relatively small dimensions expected for sculpt maps. It will be grayed out for larger images, which is one reason why unnecessarily large images are not a good idea.

Sculpt maps must also always have dimensions that are exact powers of two. Otherwise they will be resized with interpolation of pixel colors which will also distort the sculpty. This is the reason for using 64x64 maps when only 33x33 pixels are ecer used.

 

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4140 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...