Jump to content

UV tiles not matching what is exported


You are about to reply to a thread that has been inactive for 85 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hello, Im wracking my brain with this one. I have done nothing different from what I usually do, and Im experiencing a situation where my UV tiles to not match in SL what they do in 3ds max. Below are images of what I mean... Please help đŸ˜”

Here's 3ds max:

https://gyazo.com/d43add5c99df9ea7c1bddf51fe2985f2

heres the UV for that

https://gyazo.com/acffa33b46e8f78a106524fcafc56110

Heres the result im getting in SL. Ive never had this happen before and its REALLY annoying. 

https://gyazo.com/c9920eed5cbd783e19a0385cd6e7a514

Link to post
Share on other sites

Silly question but the texture mapping isn't set to planar for some bizarre reason is it?

What does it look like in the uploader if you toggle on the UV overlay?

If you are using FS then that is here 852b0acb0f749e8f747e131de8a2bd0d.png

The latest lab viewer has incorporated my changes along with their own and you should also have that in the SL viewer too.

Link to post
Share on other sites

I had similar things happen when i used multiple UV sets in Maya for the same object. Deleting all UV sets but the one for the export fixed those issues for me.

Other thing that sometimes can happen: Did you maybe duplicated your mesh and accidently upload 2 the same meshes, one with UV's and the other without and because they are in the same place, you get this issue?

And my last idea: Try to delete some faces and check if you don't have faces behind those faces. This could happen when you extrude faces and accidently don't pull them out enough, or you undid the extrude, but one step less and the extruded faces still sit on top very close.

Edited by Tonk Tomcat
Link to post
Share on other sites
4 hours ago, Beq Janus said:

Silly question but the texture mapping isn't set to planar for some bizarre reason is it?

What does it look like in the uploader if you toggle on the UV overlay?

If you are using FS then that is here 852b0acb0f749e8f747e131de8a2bd0d.png

The latest lab viewer has incorporated my changes along with their own and you should also have that in the SL viewer too.

Hey there, the UV guide shows the same thing when I add a texture to the mesh. Image below. 

 

 

89c7d1c3cb6ae87c17a1629123de3608.png

Link to post
Share on other sites
4 hours ago, Tonk Tomcat said:

I had similar things happen when i used multiple UV sets in Maya for the same object. Deleting all UV sets but the one for the export fixed those issues for me.

Other thing that sometimes can happen: Did you maybe duplicated your mesh and accidently upload 2 the same meshes, one with UV's and the other without and because they are in the same place, you get this issue?

And my last idea: Try to delete some faces and check if you don't have faces behind those faces. This could happen when you extrude faces and accidently don't pull them out enough, or you undid the extrude, but one step less and the extruded faces still sit on top very close.

As for your last idea, I can confirm no weird polys in the background. The mesh is singular not double - but good check. 

https://gyazo.com/eac0fa00069be3ab0ee59d10b46d8008

The UV Thing, I used Max's utility to clear the UV, then I used the applier to no avail. It is still doing it. My mind is blown. 

Edited by Lexii Lane
Link to post
Share on other sites

To avoid crazy UVs I usually have to triangulate the mesh before I export it as dae. I use the Turn to Poly modifier with Limit Polygon Size to 3, and Keep Polygons Convex checked. You can also try to add a Turn To Mesh modifier, on top of the stack, instead. I also keep the Triangulate option checked in the export settings.

And as Tonk mentioned, Reset XForms should be applied anyway.

Link to post
Share on other sites
2 hours ago, arton Rotaru said:

To avoid crazy UVs I usually have to triangulate the mesh before I export it as dae. I use the Turn to Poly modifier with Limit Polygon Size to 3, and Keep Polygons Convex checked. You can also try to add a Turn To Mesh modifier, on top of the stack, instead. I also keep the Triangulate option checked in the export settings.

And as Tonk mentioned, Reset XForms should be applied anyway.

Thank you all for your help! For record keeping, I used all the reset xforms and UV's that max had to offer. I have not tried the turn to poly modifier, or turn to mesh modifiers, but I will if this ever happens again. I just went in and remeshed the piece, and the issue is resolved. Not the best solution, but it got me moving forward! Thanks again, I will keep all of these in mind if it should happen again!

Link to post
Share on other sites

I had this issue, Max user too, anyhow, this is material naming issue, by default Max names new materials Material#123, SL does not read anything after # sign, best to rename it to Material1, Material2 etc, no spaces, no special characters...

I created a multi sub material with 8 sub materials, just a simple diffuse texture, named each by numbers i.e Face1, Face2-Face8 and saved it, so whenever I do export, I just use the same thing, it also helps when  exporting custom LOD models, plus saves some extra work down the line..

btw, no need to triangulate your mesh before export, applying X-form prior to export is always a good idea (do the same for LODs)...another thing that may cause errors when importing to SL are long thin triangles or mesh too dense, but those are just general tips, naming issue is why UVs do not show properly in SL for Max users at least...

Edited by MaxMare
Link to post
Share on other sites
3 hours ago, MaxMare said:

I had this issue, Max user too, anyhow, this is material naming issue, by default Max names new materials Material#123, SL does not read anything after # sign, best to rename it to Material1, Material2 etc, no spaces, no special characters...

I created a multi sub material with 8 sub materials, just a simple diffuse texture, named each by numbers i.e Face1, Face2-Face8 and saved it, so whenever I do export, I just use the same thing, it also helps when  exporting custom LOD models, plus saves some extra work down the line..

btw, no need to triangulate your mesh before export, applying X-form prior to export is always a good idea (do the same for LODs)...another thing that may cause errors when importing to SL are long thin triangles or mesh too dense, but those are just general tips, naming issue is why UVs do not show properly in SL for Max users at least...

Actually, the issue with material names was the space in the default name. Not the # sign. This has been fixed a couple of years ago. I know because it was me who reported it 5 years ago. (Well, actually Whirly was so kind to file the jira for me, I just gave her some test files).

What fixes broken UVs for me is indeed triangulating the mesh before exporting it. Changing the material names does nothing for me in this regard.
I would recommend triangulating meshes anyway. I certainly don't want a third party triangulator mess with a model I spent a couple of hours on to create it.
With a High to Lowpoly normal map baking workflow, it's essential to have matching triangulation between the in-game model, and the model the map has been baked to.
With the Turn To Poly modifier I can always go back to a quad version by simply deactivating the modifier.

This is with 3ds Max 2015 SP3. Your mileage may vary with other versions of Max, idk.

  • Like 1
Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 85 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...