Jump to content
  • 0

Add a credit card payment page not working properly


Question

4 answers to this question

Recommended Posts

  • 0
37 minutes ago, StariNite said:

Ok I will try that. Not sure if it's a "BILLING" issue or "TECHNICAL" issue. The page won't load all the way to the bottom, so nothing to click after you put in your information.

Billing is an issue that you can actually CALL LL about:

Billing support phone numbers
Toll-Free (US/Canada): 800.294.1067
Long-Distance: 703.286.6277
Our Billing team is available from 9am to 6pm EST(6am to 3pm PST), Monday through Friday.
 

Link to post
Share on other sites
  • 0
1 hour ago, StariNite said:

Ok I will try that. Not sure if it's a "BILLING" issue or "TECHNICAL" issue. The page won't load all the way to the bottom, so nothing to click after you put in your information.

if its a loading problem, i'd try another browser first before stepping in the support car :)  not sure it will help, but worth a try.

(and be sure it is a réal credit card... no debit or prepaid )

Edited by Alwin Alcott
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...