Jump to content
  • 0

Issue with light on some objects


Kokiron
 Share

You are about to reply to a thread that has been inactive for 397 days.

Please take a moment to consider if this thread is worth bumping.

Question

so last night I noticed that, for whatever reason, light (be it a face light or another object with the light feature toggled on) isn't showing at all on my head, ears, hair, and tail. This only happens when their textures are set to alpha blending, but setting them to anything else messes up the textures. If I edit the object with light enabled, THEN it shows properly on head/ears/hair/tail until I close the edit menu. It's something to do with the objects or SL because it literally stops working right at the seam between head and body. I'm including some images showing what it should look like (taken from edit mode) and what's actually happening. Anyone know whats up?

download.png

download (1).png

download (2).png

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

With advanced lighting on the number of light sources is not limited.

Projector lights don't work with alpha blend textures. Depending on distance, angle, colour, whatever you get things looking too bright or too dark or in teh wrong colour. Try point lights or alpha mask textures (which is probably not an option)

Need to add that I have switched off attached lights, so whatever you do - I will never see it - I will see you in the dark with shadows. So don't expect that everybody will see you enlighted. 😎

Link to comment
Share on other sites

  • 0

Is this a new issue for you, as in, did those lights work before and only just stopped working? If so, then that has happened to me before. I used to turn the Enable lights option on and off depending on where I was. One day I noticed lights weren't showing at all, even when I had the option turned on. I made sure Enable lights was turned on, then relogged and it was all fixed. This was on Firestorm.

My encounter's not exactly the same as your's since your lights are showing up on some objects. But worth a shot.

Edited by AdminGirl
Link to comment
Share on other sites

  • 0
4 hours ago, Nova Convair said:

With advanced lighting on the number of light sources is not limited.

Projector lights don't work with alpha blend textures. Depending on distance, angle, colour, whatever you get things looking too bright or too dark or in teh wrong colour. Try point lights or alpha mask textures (which is probably not an option)

Need to add that I have switched off attached lights, so whatever you do - I will never see it - I will see you in the dark with shadows. So don't expect that everybody will see you enlighted. 😎

hehe, I was only using them for screenshots, I never wear them all the time. I'll have to get point lights

Link to comment
Share on other sites

  • 0
  • Lindens

This sounds like an known issue https://jira.secondlife.com/browse/BUG-5852 "Projected light with high Ambiance setting causes textures containing transparency to render too dark."

If you set the Ambiance value to 0 on the projector lights, it should work as expected. If it does not, please consider filing a Bug in Jira so we can take a closer look.

  • Thanks 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 397 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...