Jump to content
  • 0
Josie Nova

AO Causing Script Error on Couch

Question

I have the Gracie living room sofa from Dust Bunny and my AO is from Oracul. When I sit on the couch, I get a script error pop-up that says  Could not find animation ''. It still lets me sit but some of the poses don't seem to work (cuddles for example) and I get the little script error icon hovering over the couch for a little while afterward. I contacted the creator as I thought it was an issue with the couch itself at first but ultimately figured out that it was my AO causing it. Is there any way to fix this other than getting a new AO? I really like mine and don't want to have to change it unless absolutely necessary. This is the first time I've ever had this issue and it only happens with this sofa in particular. I do realize that the easiest solution would be to just turn my AO off any time I want to sit on that couch but this really boggles my mind and I'd like to figure it out if at all possible. 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

It can't be your AO.  The anims that the couch uses are all supposed to be in the couch, not in your AO, and that message is a standard system error note that is posted by the script that is looking for a missing anim.  So, either the anims are actually missing from the couch, or they are misspelled in the couch's script, or the script was not set up properly.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
7 minutes ago, Rolig Loon said:

It can't be your AO.  The anims that the couch uses are all supposed to be in the couch, not in your AO, and that message is a standard system error note that is posted by the script that is looking for a missing anim.  So, either the anims are actually missing from the couch, or they are misspelled in the couch's script, or the script was not set up properly.

Well, when I contacted the creator, she said that they tried to recreate the error and couldn't and suggested that it could be my AO or something attached to my avatar. And when I turn my AO off, I don't get the error at all. I've never had anything like this happen before and it's so odd. 

Editing to add: I also tested this on an alt and didn't have the issue. 

Edited by Josie Nova

Share this post


Link to post
Share on other sites
  • 0

A mystery indeed, but the fact remains that the couch is responsible for triggering its own anims.  Your AO has nothing to do with it.  The worst that can happen is that high priority anims in your AO can override the ones in the couch.  When that happens, you see only the anims that your AO has succeeded in running and you get no script errors at all because they both ran properly.  The scripts don't know whose anim won the priority fight. 

That error message is pretty straightforward. It's generated when a script is trying to run an animation that it can't find.  Now, I suppose it's possible that your AO is missing one of its anims, so your couch has nothing to do with it, but then you would have problems using your AO in other places.  The bottom line is that neither script is even aware of what anims the other one is supposed to be running.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...