Jump to content
Maestro Linden

Deploy plans for the week of 2020-07-06

Recommended Posts

Second Life Server:

No main channel roll is planned for this week.

 

Second Life RC:

https://releasenotes.secondlife.com/simulator/2020-07-01T23%3A09%3A05.544419.html

Scheduled Wednesday 2020-07-08 07:00-10:30 PDT


On Region Restarts:
Regions will be restarted if they have been running for more than 10 days on Tuesday (Main Channel) and Wednesday (RCs) regardless of whether or not new code is being deployed, for the general health and well being of the Simulators. Nothing beats turning it off and then on again ... once in a while.

As always please plan events around these maintenance windows. However, if you are hosting an event on Tuesday or Wednesday when we're not deploying new code, you can restart your region ahead of time to avoid interruptions.

  • Thanks 7

Share this post


Link to post
Share on other sites

@Maestro Linden Erm...Woods of Heaven has now been running for 14 days since its last restart by LL...this is the second time recently it has gone to 2 weeks without a restart, so I must assume the 10-day regime has been ended?

FWIW it is still running pretty well with no obvious sign of a memory leak, so perhaps you (LL) have fixed something?

 

Share this post


Link to post
Share on other sites
2 hours ago, Aishagain said:

@Maestro Linden Erm...Woods of Heaven has now been running for 14 days since its last restart by LL...this is the second time recently it has gone to 2 weeks without a restart, so I must assume the 10-day regime has been ended?

FWIW it is still running pretty well with no obvious sign of a memory leak, so perhaps you (LL) have fixed something?

 

I see your 14 days and raise you 20 😆

 

Region still up 20 days later (and running fine)

  • Haha 1

Share this post


Link to post
Share on other sites
3 hours ago, Aishagain said:

@Maestro Linden Erm...Woods of Heaven has now been running for 14 days since its last restart by LL...this is the second time recently it has gone to 2 weeks without a restart, so I must assume the 10-day regime has been ended?

FWIW it is still running pretty well with no obvious sign of a memory leak, so perhaps you (LL) have fixed something?

 

Good points, Aisha and Logan.  The short answer is that regions are supposed to be restarted automatically after crossing the 10 day uptime mark, but there is currently a bug which causes that procedure to fail.  If your mainland region has high uptime and is encountering performance issues, please feel free to file a support ticket to have the region restarted.  On private estates, I recommend asking an estate manager for a restart when necessary.

  • Thanks 4

Share this post


Link to post
Share on other sites

Perhaps this bug is a gift of fortuitous discovery as my regions are also running well with extended up times.

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, Maestro Linden said:

Good points, Aisha and Logan.  The short answer is that regions are supposed to be restarted automatically after crossing the 10 day uptime mark, but there is currently a bug which causes that procedure to fail.  If your mainland region has high uptime and is encountering performance issues, please feel free to file a support ticket to have the region restarted.  On private estates, I recommend asking an estate manager for a restart when necessary.

That bug has been around for some time. Last time I read about it was in this very forum right after New Year's. I think it was @Mazidox Linden who mentioned it.
It's hard to believe that no one there hasn't taken the time to look it over...

[EDIT] I was wrong, it was @Grumpity Linden who explained it, sort of... But not exactly as a bug. By the way, did the blog post about it ever came out?

 

Edited by MBeatrix
typo correction and some info
  • Thanks 1

Share this post


Link to post
Share on other sites

Actually, the Grid Poking Bot had been fixed. Unfortunately, things happened between then and now and it was recently discovered that the bot needed another poke with a sharp stick, which has now once again been achieved.  The alerting for over-long region uptime has been adjusted to catch the current failure mode. 

I won't say that sanity has been restored, but something along those lines... 

 

  • Thanks 2
  • Haha 3

Share this post


Link to post
Share on other sites
8 hours ago, Grumpity Linden said:

Actually, the Grid Poking Bot had been fixed. Unfortunately, things happened between then and now and it was recently discovered that the bot needed another poke with a sharp stick, which has now once again been achieved.  The alerting for over-long region uptime has been adjusted to catch the current failure mode. 

I won't say that sanity has been restored, but something along those lines... 

 

So, besides the bug you have a lazy bot... Have you tried the legendary carrot on a stick?

  • Like 1

Share this post


Link to post
Share on other sites

We don't reward bots for failure! That's why it got the sharp stick poke. 

...It restarts the regions when it's time or it gets the hose again... 

  • Thanks 1
  • Haha 3

Share this post


Link to post
Share on other sites

It's also the little big things which make me happy. Thank you for fixing attachment icons in group notices. 🍓

FS Group Notice Attachments Icon.png

Share this post


Link to post
Share on other sites
14 hours ago, Willow Wilder said:

It's also the little big things which make me happy. Thank you for fixing attachment icons in group notices. 🍓

FS Group Notice Attachments Icon.png

well, you know. you file them - we fix them. sometimes anyway ;) 

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

i'm not going to rain on Grumpity's parade but in my part of the world if you break it, you pay for it, or in this case, fix it.  After all LL did break it!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...