Jump to content

(SOLVED) Genus hair disappear -only in Advanced Lightning


You are about to reply to a thread that has been inactive for 137 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Posted (edited)

So, I think I know why this happens. It is that blasted Alpha sorting issue. But why is it visible only in advanced lightning? Will all who has on advanced lightning see this?

I tried to find an alpha masking button on the Genus head, I could not find it. I tried BOM hairbase. And that looks sort of all right, but the whole decorative twisted hair is still missing. The hairbase only cover the skin, it does not fix the alpha issue. And I bought the hair because of this pretty front.

I am trying to ask in group too.

 

 

BHADcollage.jpg

Edited by Marianne Little
Link to post
Share on other sites
Posted (edited)

Okay, sorted out with group help. It is the eyebrow shaper that is the issue. I am so used to an eyebrow shaper set to 0 on all sliders. But the skin maker took another way, set the hair texture to transparent and left hair length, hair volume, all sliders is on 50 or 30 or some other number.

I assume alpha sorting issues is not visible unless advanced light is turned on. I am glad I got this corrected, so I don't walk around looking like the right image to all with advanced lightning on! 😄 I do not use advanced light when I need better FPS.

I sent the skin CSR a notecard about it, so they can change their eyebrow shapers.

Edited by Marianne Little
  • Thanks 3
Link to post
Share on other sites
4 hours ago, Marianne Little said:

But the skin maker took another way, set the hair texture to transparent and left hair length, hair volume, all sliders is on 50 or 30 or some other number.

RNGNfqgDPFm3dRKyv3QQ9pwPy4CD-eyiKQYHyHdu

That has been done by a content creator with more than a week of experience?

 

I mean... yeah, I have heard the suggestion of applying the default transparent texture to the system hairbase, because with some heads, a little edge might bleed through the back of the head. 

But the rest is just foolish of anyone who ever touched an alpha texture and should have heard of alpha blending bugs.

Link to post
Share on other sites
2 hours ago, ClariceRose said:

I have this problem a lot lately and I don't use advanced lighting. I don't understand how to fix it as I'm not techie. What do I need to do with my eyebrow shaper?

I am using Firestorm, so I maybe you won't find things the same if you use the official SL viewer. I clicked myself and "edit outfit". Then I selected "bodyparts" and the symbol that looks like a brown swim cap. I click the wrench symbol behind it. If it is no wrench symbol, it is no modify.

If you can edit it, no problem. Find "Hair style" and set volume, length and others sliders to 0.

If the eyebrow shaper is no modify, you must find another one (Brown swim cap) in your inventory and start to edit it. You do the same, set "style" all to zero, then select "eyebrows" and the last three ones, height, arc and point, control them. Hopefully you should be able to copy the eyebrow shaper you had. Since it is no modify, you can not even see the numbers.

You can make a new eyebrow shaper, but I have many that are modify, so I don't care.

  • Like 1
Link to post
Share on other sites
2 hours ago, Lillith Hapmouche said:

RNGNfqgDPFm3dRKyv3QQ9pwPy4CD-eyiKQYHyHdu

That has been done by a content creator with more than a week of experience?

 

I mean... yeah, I have heard the suggestion of applying the default transparent texture to the system hairbase, because with some heads, a little edge might bleed through the back of the head. 

But the rest is just foolish of anyone who ever touched an alpha texture and should have heard of alpha blending bugs.

I was so simple that I was feeling stupid. But really. I hope the hair creators don't get any angry complaints about "bad hair".

The skin creator's Flickr started in 2018 so not a week, no. I hope it was just one unfortunate skin.

Link to post
Share on other sites
1 hour ago, Marianne Little said:

I am using Firestorm, so I maybe you won't find things the same if you use the official SL viewer. I clicked myself and "edit outfit". Then I selected "bodyparts" and the symbol that looks like a brown swim cap. I click the wrench symbol behind it. If it is no wrench symbol, it is no modify.

If you can edit it, no problem. Find "Hair style" and set volume, length and others sliders to 0.

If the eyebrow shaper is no modify, you must find another one (Brown swim cap) in your inventory and start to edit it. You do the same, set "style" all to zero, then select "eyebrows" and the last three ones, height, arc and point, control them. Hopefully you should be able to copy the eyebrow shaper you had. Since it is no modify, you can not even see the numbers.

You can make a new eyebrow shaper, but I have many that are modify, so I don't care.

Thank you so much!!!! I use Firestorm as well.

Link to post
Share on other sites

Ok, I have a few questions.. I use Firestorm, do not use Advanced Lighting. I have been having issues with 3 hairs lately, 2 by Besom and one by Stealthic. Is it the eyebrow shaper that the problem is with or the hairs?

I did the edit with the hair style and eyebrows that you said but it is not fixing the issue. If I used a different eyebrow shaper, will that fix it or is it the hair? Is there another way to handle this issue, does anyone know?

I am wearing Izzie's babyhair hairbase and Besome Evira hair, but even with the Izzie hairbase off, it does this: 5341f2c9915bdf87b4f1dd615df0f8aa.png
https://gyazo.com/5341f2c9915bdf87b4f1dd615df0f8aa

Link to post
Share on other sites
8 minutes ago, ClariceRose said:

Ok, I have a few questions.. I use Firestorm, do not use Advanced Lighting. I have been having issues with 3 hairs lately, 2 by Besom and one by Stealthic. Is it the eyebrow shaper that the problem is with or the hairs?

I did the edit with the hair style and eyebrows that you said but it is not fixing the issue. If I used a different eyebrow shaper, will that fix it or is it the hair? Is there another way to handle this issue, does anyone know?

I am wearing Izzie's babyhair hairbase and Besome Evira hair, but even with the Izzie hairbase off, it does this: 5341f2c9915bdf87b4f1dd615df0f8aa.png
https://gyazo.com/5341f2c9915bdf87b4f1dd615df0f8aa

That looks like the hair doesn't fit your head, and it's protruding through the "baby-hairs" section.  Try adjusting the forehead angle slider and/or brow size slider.  But if you have a Genus head you might just be out of luck; a LOT of hair does not fit Genus heads at all, under any conditions.

  • Like 1
Link to post
Share on other sites
Posted (edited)
3 minutes ago, Maitimo said:

That looks like the hair doesn't fit your head, and it's protruding through the "baby-hairs" section.  Try adjusting the forehead angle slider and/or brow size slider.  But if you have a Genus head you might just be out of luck; a LOT of hair does not fit Genus heads at all, under any conditions.

Thanks for the reply, Maitimo. I am using Catwa Catya. The hair fit fine until a few days later after I bought it. I tried a fix that helped Marianne in another thread but doesn't seem to help me. It happens regardless if I use an extra hairbase or just the hair itself. Marianne said that BOM fixes this issue but I can't be BOM yet, L'etre did not convert to BOM yet for my skin.

I will try the suggestion of altering the shape/size of my head.

Edited by ClariceRose
Link to post
Share on other sites

Ok, I tweaked my head shape a little and put on the smallest size hair, it seems to help. However there is a small part in the middle of the baby hairs that separate (due to using a smaller sized hair), however, if I make my head too small, it looks weird. I will see if this helps for now, unless it makes itself a mess again lol.

https://gyazo.com/ce26869d0e5f736823e67bb3e9e2239e

Thank you, Maitimo.

Link to post
Share on other sites

It is @Skell Daggerthat is CSR for Catwa, so I bet he is coming here now when he has time to see he is mentioned.

That alpha issue there, can it be solved if you add the L'etre hairbase to the lower layer of hairbases? Then another hairbase on upper layer. Now you have double hairbases. Select the top hairbase, set it to "mask" and then do not clear it, just turn it 100% invisible. (Pull the slider)

I have an idea in my head, that separating 2 alphas (Alpha hair and alpha hairbase) with a masked layer can help. It can be worth trying until the Master himself comes with help.

 

Link to post
Share on other sites
  • 2 weeks later...

I was having this issue with my hairbase on my new Truth hair and you fixed it for me, Marianne. It turns out it was my eyebrow sharper and the settings on the head hair not being at zero. It was driving me nuts. I am glad I found your post.

  • Like 2
Link to post
Share on other sites

There's a certain make--up / tattoo brand with some I, a D, two T and a Y, on whose eyebrows I found the same effect as described here.

M-Alt #1 suddenly had weird issues with his usual no.match hairstyle and I was pretty much dumbfounded why I suddenly saw such weird alpha glitches, up to the point to almost blaming it on the new BOM head, despite not seeing any logic nor reason for it. Then it dawned upon me... and yes, transparent texture on the hairbase, but sliders set far from zero. Now fixed. 🙃

Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 137 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...