Jump to content
RoseyShayeDeRavyn Aeon

Script Warning/Error message

Recommended Posts

I have also tried to reboot the viewer several times to no avail.

This is the exact message: Script trying to trigger animations but PERMISSION_TRIGGER_ANIMATION permission not set

I have also deleted all items of this Glass of Blood Champagne and purged them but nothing helps. These messages keep coming anyway.

Another strange thing is that this is the second thread I started about it. The first just vanished mysteriously. 

It's driving me crazy! Help plz!

Share this post


Link to post
Share on other sites

That error message comes from rezzed objects that are trying to animate you but haven't properly asked for permission. If it's travelling around 'with you' as you TP, it's likely caused by an attachment.

If you can find a way to the 'Script Error Window' on your viewer, do that. Without knowing which viewer you're using, can't help you there.

 

However, I recommend you attach/detach your attachments one by one to see which one causes the error on attach. Good luck =]

Share this post


Link to post
Share on other sites

OK, go to preferences, Advanced tab, and set "Show Script errors" on, and then press the "Nearby chat" radio button, then you can do the location thing.

Share this post


Link to post
Share on other sites

When I turn it into green text, the only options I got is copy and select all. When I clicked the object itself I got the options map, block and close. I tried to block it but that didn't help either. I don't know where to locate it.

Share this post


Link to post
Share on other sites

Hi, the map option will give you the location.  There should be a line above that button that says "teleport to..." that has the location listed too.

Share this post


Link to post
Share on other sites

Is it travelling round with you, or is it confined to one particular sim (probably where your home is)?   

What you describe is frequently caused by an attachment that's been rezzed on the ground (or dropped) and which hasn't been scripted to make sure it's attached to its owner before asking for permission to animate you.    But it's only going to do that while you're on the same sim.  

If it is confined to the one sim, you're going to have to search for the offending item, I fear --  I think the script error window should give you the coordinates of the object containing the script that's throwing errors, but I'm not in world to check that.

  • Thanks 1

Share this post


Link to post
Share on other sites

OK, if you have the map location, that is where the troublesome object should be, if it really exists any more.  Build>Options>Select Only My Objects, zoom out a little, Ctrl+3, then drag the mouse over the screen to see if you can find your object there.

If you cannot find your object at that location, then you are probably daling with the ghost prim problem. Sometimes when an objet is deleted, the scripts can get stuck running on the sim. If that happened, you may need a region restart to kill it.

  • Thanks 1

Share this post


Link to post
Share on other sites

I've had it a pretty long time although I don't remember exactly for how long. Maybe 2-3 years. I originally found it in a nightclub belonging to a vampire/goth sim that does no longer exist. I haven't found the object anywhere else since then. Before I deleted it I shared a couple of copies with one of my other avatars as to not lose entirely. The properties says Cheers from Kitchen Kreations if that could be any clue. I have teleported frequently before without problems but I cannot recall that I have ever dropped the object though.

Share this post


Link to post
Share on other sites

I tried that too but couldn't find it. Is my only hope now a sim restart? Don't know when the sim is scheduled to retart next but it has happened a couple of times just in the last few days so I'll hope it will be soon. It is slightly less annoying having the messages in the chat window though. I'll try to share it back to this avatar later but I think I'll wait until after the enxt sim restart as to not risk anymore problems. The other avatar who is on Phoenix does not seem to have got any problems with it. I'll be more careful not to TP with it in the future though. But does that go with all other objects I have added to the avatar, like the sunglasses, the katana, the firey eyes and such? Should I also remove them before I TP?

Share this post


Link to post
Share on other sites

What I'm saying is that the issues you describe could very well be caused by your once having accidentally rezzed a copy of the item from your inventory, or that you accidentally dropped it rather than detaching it.   If there's a rezzed copy of the object, that belongs to you,  sitting in world, and the script doesn't allow for the object containing it being rezzed but not attached to anyone (and if it's one of the popular free "drinking animation" scripts it almost certainly doesn't) then you will get keep on getting these error messages.

That's why it's important to try to track down the location of the particular rezzed object -- so you can either take it back into your inventory or delete it. 

Share this post


Link to post
Share on other sites

TP'd far from home. Messages continued til I changed outfits. When I returned home, messages resumed.

I didn't see an object with the stated name in inventory, though have some similar ones.  I visited most of those, but the prim count is higher than described. 

Got SL viewer installed.  Got chat object.  The only info is the name of the owner, me.  The Map, I believe, locates the owner, not the object.   TP sends me to the very corner 0,0 of my island on someone else's parcel under water.  Highlighting objects does not reveal any objects nearby.  Flying up doesn't either.

I've spent hours on this.  I went into preferences and deselected showing script errors.  At least I finally have some Peace.

Found the object!  Pretty much by chance.  Took it into inventory.  Re-rezzed it.  When someone used it, it started the messages for a while, then stopped.

Thanks!

K

 

Share this post


Link to post
Share on other sites

I have the same error message.

Script trying to trigger animations but PERMISSION_TRIGGER_ANIMATION permission not set

It was from a tongue piercing I got from the shop. The owner doesn't seem to be online and I don't know how long she's been away.  I tried deleting the item from my inventory, but the error message continues. There is no option to modify this script. I followed the above instruction and found it, and deleted it, but the error is still showing up. Is this a ghost script? Do I ask my region for a restart? please help.

 

Share this post


Link to post
Share on other sites

Thanks! The object I was looking for was invisible after it had been rezzed on the ground.

...now hopefully I can solve the error while it's attached.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...