Jump to content

How to force Second Life use my RTX 2060?


You are about to reply to a thread that has been inactive for 216 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Unless your CPU has an integrated graphics chip and you managed to connect your monitor to your motherboard, your 2060 does get used.

Focusing on the Task Manager will lower the rendering, because you basically put the viewer application to sleep. Run a tool like MSI Afterburner to log performance or the tools provided in your GPU driver.

  • Like 1
Link to post
Share on other sites
2 hours ago, ElJaviLuki said:

How to force Second Life use my RTX 2060? Task Manager shows low usage. I know SL it's not a game per se, but maybe there is a option to force it to use GPU and improve performance.

 

Nalates Blog

 

Welcome to the Forum ElJaviLuki!..have a slice of warm Welcome Pie!.....Enjoy!😘 

Forum WP 512X.png

Link to post
Share on other sites
2 hours ago, ElJaviLuki said:

How to force Second Life use my RTX 2060? Task Manager shows low usage. I know SL it's not a game per se, but maybe there is a option to force it to use GPU and improve performance.

 

You do realize that when you start task manager to look at the performance of other applications most applications go into sleep or suspend mode and will show less use while they are not in the foreground..

Plus sl is more a cpu intensive application and less gpu, and there is no real way to force it to use the gpu more, its totally dependent on the viewer in use and if it was designed to use the newer hardware or not.

  • Like 2
Link to post
Share on other sites
9 hours ago, ElJaviLuki said:

How to force Second Life use my RTX 2060?

How to force anything [to] use my RTX 2060?

Why are we here on this planet?

What is the point of it all?

Anyway, the answer is 42 https://www.nvidia.com/Download/index.aspx?lang=en-us

[Update]

9 hours ago, ElJaviLuki said:

Task Manager shows low usage.

This could either be a good thing or a bad thing. Teleport to this place: http://maps.secondlife.com/secondlife/8 8/122/191/1085

If the Task Manager still shows low usage, there are two explanations:

1. You have a Windows GPU settings/driver issue.

1. Your computer is awesome.

Edited by Arduenn Schwartzman
  • Like 1
Link to post
Share on other sites
11 hours ago, Drakonadrgora Darkfold said:

You do realize that when you start task manager to look at the performance of other applications most applications go into sleep or suspend mode and will show less use while they are not in the foreground.

 

13 hours ago, Lillith Hapmouche said:

Focusing on the Task Manager will lower the rendering, because you basically put the viewer application to sleep. Run a tool like MSI Afterburner to log performance or the tools provided in your GPU driver.

Not really, if I open Task Manager in the right part of the screen and SL viewer in the other one at the same time. Anyway, based on your argument, every game (not only SL) should show low GPU usage, which is actually not true (e. g.: Far Cry 3, Fortnite, etc.)

 

11 hours ago, Drakonadrgora Darkfold said:

Plus sl is more a cpu intensive application and less gpu, and there is no real way to force it to use the gpu more, its totally dependent on the viewer in use and if it was designed to use the newer hardware or not.

Oh No way nooo :( 😐

Edited by ElJaviLuki
Link to post
Share on other sites
26 minutes ago, Lillith Hapmouche said:

... 🙄

Have Far Cry 3 or Fortnite running fullscreen. Watch the GPU usage. Tab out, minimize it. Bye, bye, GPU usage in Taskmanager. It's no valid tool to keep track of any GPU usage. 

Put it on a second monitor and you don't have to switch focus to see it. It works fine that way.

  • Like 1
  • Thanks 1
  • Haha 1
Link to post
Share on other sites
55 minutes ago, ElJaviLuki said:

if I open Task Manager in the right part of the screen and SL viewer in the other one at the same time.

If the focus (window selection) is not on the SL viewer, but on another window, say Task Manager instead, then the SL viewer deliberately drops the frame rate (and, lo, GPU use drops).

Oh my, maybe I'm on to something in this mysterious riddle?

  • Like 1
Link to post
Share on other sites
3 hours ago, Bree Giffen said:

Most gamers know that to improve performance you turn down all your graphics settings. 

So if the CPU and GPU are asleep, lowering the graphics settings to give them even less to do will reward you with more performance?

@ElJaviLuki Welcome to Second Life, where every viewer is bad at utilizing your hardware. The topic comes up pretty regularly and there just isn't much you can do about it.

Edit:

4 hours ago, Lyssa Greymoon said:

Maybe one CPU core isn't quite enough to push a GTX2060 to its limits.

I only have a GTX 1060 and none of my cores seem particularly busy... (I emphasize that this shows total usage, not just my viewer, and my viewer is in focus.)

dcf56c801a.png

Meanwhile, if I open a random game like For The King... It has distinctly simplified graphics but it's evenly spreading out the CPU load across all of my cores for that nice 100% GPU usage. The game isn't even in focus.

a592de61d5.png

Edited by Wulfie Reanimator
  • Like 3
Link to post
Share on other sites
On 5/15/2020 at 6:27 AM, ElJaviLuki said:

 

Not really, if I open Task Manager in the right part of the screen and SL viewer in the other one at the same time. Anyway, based on your argument, every game (not only SL) should show low GPU usage, which is actually not true (e. g.: Far Cry 3, Fortnite, etc.)

 

Oh No way nooo :( 😐

yes even they will show less usage when in the background not in focus compared to when they are in the foreground. almost all windows applications do this.

Edited by Drakonadrgora Darkfold
Link to post
Share on other sites
10 hours ago, Drakonadrgora Darkfold said:

yes even they will show less usage when in the background not in focus compared to when they are in the foreground. All windows applications do this.

While this is generally true for programs that are entirely minimized (assuming the program spends any significant time telling Windows to render things on the screen), simply being "out of focus" doesn't mean anything to a program unless it's explicitly programmed to slow things down, like viewers are. You can see the debug setting that plays the biggest role in my previous screenshots. Setting it to 0 will cause no slow-downs while out of focus. A minimized program can still keep going full-force, crunching numbers to draw frames, even if those frames are never seen.

There are lots of programs that can chug your CPU/GPU no matter what you try to do, besides shutting it down.

Edited by Wulfie Reanimator
  • Like 1
Link to post
Share on other sites
15 minutes ago, Wulfie Reanimator said:

While this is generally true for programs that are entirely minimized (assuming they program spends any significant time telling Windows to render things on the screen), simply being "out of focus" doesn't mean anything to a program unless it's explicitly programmed to slow things down, like viewers are. You can see the debug setting that plays the biggest role in my previous screenshots. Setting it to 0 will cause no slow-downs while out of focus. A minimized program can still keep going full-force, crunching numbers to draw frames, even if those frames are never seen.

There are lots of programs that can chug your CPU/GPU no matter what you try to do, besides shutting it down.

depends on the os as well.. some os's do not obey program settings and will ignore it and force the application to suspend or sleep to reduce cpu usage.

so really it becomes an os and application issue.

but yes some applications will run at near 100% use in the background only if they are designed to do so such as boinc, which most pretty much all of the viewers are not.

but the real problem is you cant force an application to use full cpu or gpu if it was not designed too.

this background mode is the same reason why rlv commands cannot work when viewer is in the background or minimized.

a lot of games or applications will lower its cpu and gpu usage when in the background when no input is being given. they dont have to continue to run at full force to continue to render the frames they will skip frames to catch up.

Edited by Drakonadrgora Darkfold
Link to post
Share on other sites
On 5/15/2020 at 4:15 PM, Bree Giffen said:

Most gamers know that to improve performance you turn down all your graphics settings. 

 

Most gamers know that to improve performance you buy a better video card. 

  • Like 4
Link to post
Share on other sites
58 minutes ago, Bree Giffen said:

The truth is if you bought an RTX 2060 for SL then you wasted your money. 

 

The truth is, you can bog down pretty much any video card in SL, even the high-end RTX series, if you push it hard enough. Try setting Shadow Quality >3.0, and you'll see. :)

Besides, overkill on a video card rarely truly is. Just because it can run one scene at 100fps, doesn't mean it won't slow down in others (disregarding sim lag here). Having as bit of comfortable surplus really helps for those occasions. And the less your card has to do, chances are, the less noisy it will be. Win-win, all around.

Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...

Wow, this thread is actually awful. I'm appalled at the amount of people spewing all this misinformation here and more importantly not addressing the question at all lol.

 

The answer to your question is very simple, there's no need to talk about gatekeeping gamers or whatever.

 

1. Simply right-click your desktop and select "Nvidia Control Panel"

2. Select a Task: "Manage 3d Settings"

3. You have 2 options here, you can select: Preferred graphics processor: "High-Performance Nvidia processor" and it will use that processor for ALL your programs. Hit apply and done.

or you can go to tab beside global settings called "Program settings". Then: under Select a program to customize: choose your viewer for example "Firestorm-releasex64.exe". Next  Select once again, the High-Performance Nvidia processor.  Hit Apply, then exit the program and restart the viewer you're using under administration mode by right-clicking it.

If you're successful, when you start up the viewer again it will give you a message that your card has been switched.

And done! You'll notice the differences immediately!

Hope this helps and sorry for all the people above giving you so much useless info lol.

 

 

Edited by HeartlessDisguise
spelling
  • Haha 1
Link to post
Share on other sites
4 minutes ago, HeartlessDisguise said:

Wow, this thread is actually awful. I'm appalled at the amount of people spewing all this misinformation here and more importantly not addressing the question at all lol.

 

The answer to your question is very simple, there's no need to talk about gatekeeping gamers or whatever.

 

1. Simply right-click your desktop and select "Nvidia Control Panel"

2. Select a Task: "Manage 3d Settings"

3. You have 2 options here, you can select: Preferred graphics processor: "High-Performance Nvidia processor" and it will use that processor for ALL your programs. Hit apply and done.

or you can go to tab beside global settings called "Program settings". Then: under Select a program to customize: choose your viewer for example "Firestorm-releasex64.exe". Next  Select once again, the High-Performance Nvidia processor.  Hit Apply, then exit the program and restart the viewer you're using under administration mode by right-clicking it.

If you're successful, when you start up the viewer again it will give you a message that your card has been switched.

And done! You'll notice the differences immediately!

Hope this helps and sorry for all the people above giving you so much useless info lol.

 

 

What would your definition of "useless" be? Would it be something like telling someone to use a procedure that is for a dual-video-system laptop when there's no indication that is what they're using?

Link to post
Share on other sites
1 hour ago, HeartlessDisguise said:

Hope this helps and sorry for all the people above giving you so much useless info lol.

It seems obvious from the context that OP's problem isn't that the 2060 isn't being used at all, but that it's not being fully utilized.

Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 216 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...