Jump to content
  • 0

Secondlife Marketplace logging me out every time I closer browner


SilverSin
 Share

You are about to reply to a thread that has been inactive for 1507 days.

Please take a moment to consider if this thread is worth bumping.

Question

I wasn't sure where else to post this so, if this is the wrong section I apologize. For the past like... two months I've had this problem where, every time I close my browser I am logged out of the secondlife marketplace. It's incredibly frustrating and tedious to say the least. I don't honestly know what's going on. Today I finally decided to trouble shoot it. This is what I have done so far with no difference:

  • Disabled all extensions & Add-ons
  • Disabled do not track
  • Made sure the cookie settings where not causing this <- edited in because i forgot it before
  • Turned off my anti-virus
  • Install another browser and test it

I am honestly just super confused. I don't understand why this is happened. This does not happen on any other website. I'm on Firefox atm, tried it on opera too. I'm windows 10 pro 64x, is there some weird new setting? Is there some weird account setting that's been added to secondlife? Do I have to log in via the secondlife main page to stay logged in? Like... ****?! Help please.

Edit: Seems logging onto secondlife.com worked? I still want suggestions in case this starts happening again.

Edit 2: NOPE did it again!?

Edited by SilverSin
Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0
4 hours ago, SilverSin said:

I wasn't sure where else to post this so, if this is the wrong section I apologize. For the past like... two months I've had this problem where, every time I close my browser I am logged out of the secondlife marketplace. It's incredibly frustrating and tedious to say the least. I don't honestly know what's going on. Today I finally decided to trouble shoot it. This is what I have done so far with no difference:

  • Disabled all extensions & Add-ons
  • Disabled do not track
  • Turned off my anti-virus
  • Install another browser and test it

I am honestly just super confused. I don't understand why this is happened. This does not happen on any other website. I'm on Firefox atm, tried it on opera too. I'm windows 10 pro 64x, is there some weird new setting? Is there some weird account setting that's been added to secondlife? Do I have to log in via the secondlife main page to stay logged in? Like... ****?! Help please.

Edit: Seems logging onto secondlife.com worked? I still want suggestions in case this starts happening again.

Edit 2: NOPE did it again!?

In Firefox, click Tools / Options.  Select 'Privacy & Security' on the left and scroll down to "Cookies and Site Data".  First check if the box 'Delete cookies and site data when Firefox is closed' is checked. If so, uncheck it.  If not, click 'Manage Permissions' and see if "https://marketplace.secondlife.com" somehow got added with a Status of "Block".

  • Like 1
Link to comment
Share on other sites

  • 0
7 hours ago, LittleMe Jewell said:

In Firefox, click Tools / Options.  Select 'Privacy & Security' on the left and scroll down to "Cookies and Site Data".  First check if the box 'Delete cookies and site data when Firefox is closed' is checked. If so, uncheck it.  If not, click 'Manage Permissions' and see if "https://marketplace.secondlife.com" somehow got added with a Status of "Block".

Hi there! Thank you for trying to help me. I should have stated above that I already went into the Cookies and Site Data. It is not have 'Delete cookies and site data when Firefox is closed' ticked. It was also not blocked under manage permissions. I even added it as allowed and it didn't do anything.

I have noticed that if I go to secondlife.com and log in there (I get redirected instead of having to type everything) then go to the marketplace I am logged in. It's like the two sites are communicating or something? So I turned off the built in do not track for these two web pages. If I get any results from this I'll post it.

Link to comment
Share on other sites

  • 0
6 minutes ago, Lindal Kidd said:

I always have to log in to the Marketplace, if I go there directly.

I've always thought of it as a safety feature, not a bug.

It's not, I never had this issue on my previous computer. Then again that computer was on windows 7... I just recently made the switch to 10 again, not happy about it but not much choice.

Link to comment
Share on other sites

  • 0

A couple months ago (give or take some weeks), they changed MP's cookies to expire at end of session, regardless if you leave use "remember me" checked or not. You can easily check it within your browser by finding yours. I'm not sure if it's intentional or not, it was around when gacha scam/refund thing was pretty bad so could be to help with that, hard to say, but it's what it is.

Edited by steeljane42
Link to comment
Share on other sites

  • 0
3 hours ago, steeljane42 said:

A couple months ago (give or take some weeks), they changed MP's cookies to expire at end of session, regardless if you leave use "remember me" checked or not. You can easily check it within your browser by finding yours. I'm not sure if it's intentional or not, it was around when gacha scam/refund thing was pretty bad so could be to help with that, hard to say, but it's what it is.

My login does not expire when I close the browser tab, though I think it might if I close the browser entirely -- I tend to keep both browsers open, with many tabs, pretty much all the time.  This holds true for both Firefox and Chrome.  

 

Link to comment
Share on other sites

  • 0
2 hours ago, LittleMe Jewell said:

My login does not expire when I close the browser tab, though I think it might if I close the browser entirely -- I tend to keep both browsers open, with many tabs, pretty much all the time.  This holds true for both Firefox and Chrome.  

 

"End of session" is when you close the whole browser, not the tab. Before this change MP's cookies had pretty long expiration time, a few months at least. I'm pretty sure it's not really intentional change on the end, since "remember me" check does absolutely nothing now. While it should be: with it checked - X time for cookie's life, without - end of session (which is handy for public browsers or time when you just don't want to stay logged in for any reason).

Link to comment
Share on other sites

  • 0

I tested to see if it was a tab or browser closing thing. Seems to make no difference in Chrome. Closing the browser for 1 minute then launching then opening the marketplace I need do not need to login again. 

My "user_credentials" cookie was created in 2016... 😕 and says it will expire at the end of the browser session, which I take to mean when the browser is closed. When I close the tab it remains. When I close the browser and then reopen it, the same user_credentials cookies is there.

For Chrome open Settings->Privacy and security->Site Settings->Cookies and site data->All cookies and site data->Search Cookies  enter marketplace. I have 15 cookies. One is a session cookie.

With Firefox doing the same thing I have to login each time I come to the site. Chrome and Firefox's behaviors are different.

I tested to see if the 'Remember me' checkbox would make a difference to Firefox. It doesn't. I still have to login each time I close the brower and come back to the marketplace.

 

 

Edited by Nalates Urriah
Added test
  • Like 1
Link to comment
Share on other sites

  • 0
2 hours ago, Nalates Urriah said:

I tested to see if it was a tab or browser closing thing. Seems to make no difference in Chrome. Closing the browser for 1 minute then launching then opening the marketplace I need do not need to login again. 

My "user_credentials" cookie was created in 2016... 😕 and says it will expire at the end of the browser session, which I take to mean when the browser is closed. When I close the tab it remains. When I close the browser and then reopen it, the same user_credentials cookies is there.

For Chrome open Settings->Privacy and security->Site Settings->Cookies and site data->All cookies and site data->Search Cookies  enter marketplace. I have 15 cookies. One is a session cookie.

With Firefox doing the same thing I have to login each time I come to the site. Chrome and Firefox's behaviors are different.

I tested to see if the 'Remember me' checkbox would make a difference to Firefox. It doesn't. I still have to login each time I close the brower and come back to the marketplace.

Thank you all very much... sadly cookies can't seem to be edited on firefox. Hopefully they revert this change in the future.

 

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 1507 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...