Jump to content

All bones have key frames but bones move on their own


Reiramon
 Share

You are about to reply to a thread that has been inactive for 1527 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hello, 

I made an animation where most of the bones are moved and have key frames (except for face).   

I upload it in beta grid to preview it but some bones like arms and head move on their own during the animation. 

It's like the standard standing animation (hands on hips) is fighting with my imported animation. The neck rotates too. 

When I run the animation in blender it looks OK and the bones do have inserted key frames. 

I am using 2.8 Avastar and exporting as bvh. 

Am I doing something wrong? 

Thank you! 

Edited by Reiramon
Link to comment
Share on other sites

On 4/5/2020 at 10:39 AM, RohanaRaven Zerbino said:

1. Keyframing is not enough to override default animations, rotation of the bone must be other than 0/0/0 rotation for x/y/z axes.

2. Priority of uploaded animation must be higher than priority of default animation, so try to upload with priority 4.

Thanks. 

What I found that also works is checking the bone lock option. 

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 1527 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...