Jump to content
Sign in to follow this  
Oskar Linden

Deploys for the week of 2011-05-16

Recommended Posts

UPDATED: We will not have a Wednesday morning release for the RC channels. We are postponing it until Thursday morning. I will update the dates here and update the notes soon.

We are back on track this week. I know things have been stressful and hectic and seemingly disorganized for about a month now. We now have a stable set of code deployed to the main grid to work from. It's taken a lot of work and we appreciate your patience. We have a busy week planned with upgrades coming to the main channel and all three RC's.
You may have also noticed a RC channel called "Snack". That is a small, temporary, channel we use just for a limited time. It's like a snack, get it? :-) In this case we used it as a quick live test for Kelly's mono2-performance project that has had some unfortunate rollbacks the last few times on the grid. We deployed his code to Snack and did a verification test on the 4 Snack sandbox regions. We found some bugs and got them fixed. It will now enter the regular RC process.


Second Life Server (main channel)
Main channel remains the same for now. We had issues during the deploy and rolled this channel back to the stable version.
 
2011-05-17, 5:00am: Rolling Restart - Release Notes: https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_Server/11
 

Second Life RC BlueSteel
This branch has some changes to the People API. This API was updated to handle friendship additions and removals as well as some infrastructural changes.

2011-05-19, 8:00am: Rolling Restart - Release Notes: https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_BlueSteel/11
 

Second Life RC LeTigre
This channel is the same as LeTigre last week and contains Kelly's "maint-server" changes. This is mostly bug fixes and some logging changes to help us investigate some issues. The details are in the release notes.

2011-05-19, 9:00am: Rolling Restart - Release Notes: https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_LeTigre/11
 

Second Life RC Magnum
This project is getting the "mesh-prep" branch. This contains infrastructure and framework updates to get the grid ready for mesh. It does not include any mesh features or functionality. The physics engine has been updated and the 10cm gap between colliding objects has been removed for some objects. 
The llCastRay() function has been included, but is disabled. A last minute bug was holding back the release of this project and we needed ti disable it. It will be fixed in an upcoming maint-server. Scripts with llCastRay() will compile but will not generate results and may produce errors.

2011-05-19, 10:00am: Rolling Restart - Release Notes: https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_Magnum/11
 

Snack Release Channel
This will get Kelly's updated "mono2performance" project. More info to come.

2011-05-19, 10:00am: Rolling Restart - Release Notes:https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_Snack/11
 

We will be monitoring this thread during the next week so please feel free to post issues that you feel have been introduced by the new code. Please file a JIRA for issues you find and post the JIRA link into this thread. It really helps us out. When determining if issues are relevant or not research is key. Tracking down exactly the right situation where an issue is occurring greatly speeds up the development process to get fixes in place.
I appreciate your help. Have a good week!
 
__Oskar
 
p.s. If you are interested in helping test SecondLife in beta please join the group "Second Life Beta" in-world. We also have an email list where we communicate upcoming projects and how you can help. ( https://lists.secondlife.com/cgi-bin/mailman/listinfo/server-beta ) Once a week we meet on ADITI to discuss new features, new bugs, new fixes, and other fun stuff. You are more than welcome. Information is here: https://wiki.secondlife.com/wiki/Server_Beta_User_Group

 

Share this post


Link to post
Share on other sites

are you still seeing lots of problems with region crossings? My own experience is that they are vastly improved... less rubberbanding, less pausing on the region when overloaded avatars enter, etc. still not quite as smooth as pre point to point TP, telehub days, but I don't think anyone wants a return of that (well ok, maybe the vehicle enthusiats might) =)

I know some users with 20+MiB os script load are still seeing low responsiveness from their scripted items after TP, but even that's improved over previous situations where those same avatars would often bounce or disconnect. If you're seeing something else, please report with details.

ETA:
I think it means back end support for mesh objects, code to support encroachment tools, and a switch for them to throw when they enable bigger prims.... but that's just a guess. But that's still exciting (to me anyways), because it means it's all that much closer to arrival (and means I need to update some of the logic on my freebie resizer script)

Share this post


Link to post
Share on other sites

We had some intermittent server issues with the rolling restart today and made the decision to halt the roll and set the grid back to the stable trunk version. I'll post more details as I have them.

 

__Oskar

Share this post


Link to post
Share on other sites

Hmmm. The Grid Status page says the rolling restarts are completed, but my mainland main server channel region did not restart and is still running last week's code (the region is Joffy). EDIT: Nevermind, I just read Oskar's post.

 

As far as sim crossings are concerned, they do seem better for full sim regions, but homestead mainland regions (which is the bulk of the Linden protected water sims) has problems. It seems to me that if they sit unused too long, they get swapped out to disk. When I try to enter a rarely used homestead sim, sometimes the time dialation goes to .01, and by the time the sim recovers your avatar has been separated from the vehicle you were on.

Once the region is back into the server's memory, things are usually ok for a while, but it isn't long before the same problem happens again.

I think this is happening because too many homestead regions are getting stuffed into one server, and something has changed causing them to use more memory than they used to. If anyone else has noticed this, please chime in.

Share this post


Link to post
Share on other sites

I have been seeing, what look like, random disconnects from the asset system.

Issues ranging from, objects rezzed inworld that no one can delete, return, etc. (These lost objects even survive sim restarts and bypass parcel return.) ... to very odd outfit behavior.

This morning while putting an outfit together i started getting "failed to rez" warnings while trying to wear attachments. Eventually i relogged and found that i had lost an hours worth of edits on the outfit. I was wearing all the attachments i put on, but non of the resizing or location changes stuck.

The other day, we went out for a drive in Bay City. When we were done, not One of us could pick up our vehicles. Some said they were returned via parcel return, none really were returned though.. I went back last night and found not only my vehicle was still there, but that there were 100+ copies of it, all in the exact same location. I tried everything to pick them up, eventually i slid them into the neighboring sim.. and crashed the sim Badly! (Weston)

Not sure if these observations help at all.

I would suggest, though, that if anyone does see this "failure to rez" warning while getting dressed, to relog, so as to not waste too much time.

Share this post


Link to post
Share on other sites


Alisha Matova wrote:

 

Issues ranging from, objects rezzed inworld that no one can delete, return, etc. (These lost objects even survive sim restarts and bypass parcel return.) ...

https://jira.secondlife.com/browse/SVC-6905

It's ghost prims on steroids, presumably on some revenge mission and now openly taunting us by being visible and harder to remove!

Share this post


Link to post
Share on other sites

the unreturnables is a known problem... current workarounds are the same as for original physical ghost prims, return from estate console, or region restart and then return via group/land permissions.

the outfit/inventory problems may be region related, or may be some lingering problems from the recent DNS failure of the asset cluster.

the vehicle thing... bizarre... first time I'd heard about duplications like that... o.O

Share this post


Link to post
Share on other sites

Thanks Ciaran and Void!

I am glad these are known issues and hopefully fixes are in the works =) The duplicate vehicle issue was very odd. At one point I had 100+ objects held in edit and actually saw the "you are trying to edit more than 4000 prims" warning. Yet, those 4000+ prims were on a 1024 parcel.. Which can't be possible. I have to assume that it only happened on my screen. I am now thinking, it was just an exciting version of Ghost Prims on Steroids.

Thanks again!

Share this post


Link to post
Share on other sites

Thanks for notifying us Oskar! This month has been a little crazy & it is nice to see the infos here :matte-motes-asleep-2:

Also excited to see mention of "mesh prep" that's something yay :matte-motes-inlove:

Share this post


Link to post
Share on other sites

@ Oskar

Oh Lor...."Boom" 

You are having a torrid time getting stuff out to the grid at the moment, but, I tell you,seeing this posted upfront by a Linden is seriously good.  In times gone by LL used to clam up tight when stuff wasn't working.  This openness is greatly appreciated by me at least.  I suspect Maestro recalls those times even if you don't Oskar.

/me hobbles off to buy another can of LL Bug Killer.

 

Best of luck fishing the bugs out of it, guys.

Share this post


Link to post
Share on other sites

I may have missed the information somewhere in this thread. If the the main server deploy occurred May 17th and the deploy version is 11.05.11.229644, then why are the sims I visit, one where I work and another for home, still on 11.05.05.228940? Do we have to restart the sim ourselves to propagate the deploy? I've also visited a protected sim on agni: You are at 256748.2, 258539.8, 4.9 in Theodrada located at sim9442.agni.lindenlab.com (216.82.43.145:13013)Second Life Server 11.05.05.228940

 

Forgive me for being clueless. I Have no head for tech.

NVM: I missed Oskar's additional post:

05-17-2011 08:41 AM
We had some intermittent server issues with the rolling restart today and made the decision to halt the roll and set the grid back to the stable trunk version. I'll post more details as I have them. __Oskar

Share this post


Link to post
Share on other sites

Any indication when the fix for http://jira.secondlife.com/browse/SCR-66 ("llRegionSayTo() Fails to send messages to attachments on sitting avatars") is likely to be deployed?

I'm trying to decide whether to hold off releasing some new products that use it, or put them out using llRegionSay() and send out an update later.  I'd like to send them out, but if I'm going to have to update them in in the next week or so, I'll wait.

Share this post


Link to post
Share on other sites

I'm curious which component caused the rollback of the Main channel, and if it's related to a few reports of physics items getting duplicated?

I've seen at least one user report of stuck vehicles that got duplicated multiple times on the forums, a few third hand reports inworld, and I suspect it may have been the root cause of a recent pileup of physical tram cars in the Babbage regions (which I have a spectacular picture of... it's really a sight to see, and is living proof that server performance has improved, as the regions didn't crash, and I was able to move around without much rubberbanding, so kudos on that!)

Share this post


Link to post
Share on other sites

Fewer crashes on sim-crossing with a vehicle, but far more rubber-banding. I do see a difference with different vehicles, more from script-load than such things as wearable detail, There's some connection with busy regions, but I've sometimes had huge problems when the regions involved are both empty.

Not-crashing is good. But I seem to be seeing far more mishaps which would have, a year ago, caused a crash.

Share this post


Link to post
Share on other sites

@Void Singer. It wasn't directly related to the simulator code. It was a failure on the deploy tools to bring up back end services. The back end service that pulls down the simstate form the asset server. WIthout a simstate a simhost cannot bring a region up.

 

__Oskar

Share this post


Link to post
Share on other sites

The Magnum RC Channel release this morning had far too many issues for us to allow it to continue on the grid. We are replacing it with the stable code that is in the main channel. We are doing that now.

 

__Oskar

Share this post


Link to post
Share on other sites

Quit using the main grid as a g-d beta! How about YOU test it before you inflict it on us? I've had one region down all day, can't be restarted by you during middle of rolling restart, and YAY another one follows right on the heels.

I want all my regions out of your beta channels.

Share this post


Link to post
Share on other sites

They do tend to test it, but the RC sims are specifically for this reason because so few use the beta regions on ADITI. It works usually, just lately they have been having issues with it as they are trying to introduce new things. It does bear some patience, which many don't seem t have much of. If they don't test these out we will be stuck on the same server version for months and months. I prefer these weekly restarts, we get rapid changes, but also rapid fixes

Share this post


Link to post
Share on other sites

Can you check on Le Tigre. Sims are showing last week's version number, 11.05.11.229644, rather than the expected 11.05.17.230139

Is this a dumb mistake in version numbering, or have you restarted with the broken code?

Today has not been a good day.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...