Jump to content

Need help with a AO made with Avastar


ultrafox1234
 Share

You are about to reply to a thread that has been inactive for 1548 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hello everyone,

I hope someone can help me with just a short hint. I tried to make an animation overrider with Avastar in Blender. I just want to make a holding pose, it just affects the left arm and the fingers. It shouldnt change the rest of the AO of the avatar (like feet, walking animation, etc., I just want that the avatar rases the left arm).

So i made an animation, that just affects the bones i want, it looks like that:

https://i.ibb.co/yy3Lc7W/AO1.png

And i exported it like that:

https://i.ibb.co/3Wn34YB/AO2.png

The problem is, it affects the whole AO... Like standing animations look weird, walking animations.... The legs and feet just have a strange pose...

Can somebody help me with that? To be honest, its the first time i try to make an AO.

Thank you very much for your help!

Link to comment
Share on other sites

2 hours ago, ultrafox1234 said:

https://i.ibb.co/3Wn34YB/AO2.png

First off: if start frame is 1 and end frame is 2, loop in and loop out should not be zero, those are the frames where looping should begin and end. You don't have animation at frame 0. Make these two value equal to your last frame (2) to make it constantly loop in pose. What you're setting over there is basically trying to tell the exporter "export data from 1 to 2 but loop in and out on a frame that you've not exported", it doesn't make sense, does it?

Second: Priority 6 is too much. If you want to override average AOs including the run and walk animations (which usually are priority 4), set your priority to 5 and it's gonna be fine.  Priority slots don't come for free, you're wasting one that way.

Third: The checkbox "With bone translation" should be off. That is needed when you're animating the translation of a bone AKA its position in space and was intended to support attachment points animations. All the regular bones should always be animated with rotations only and this checkbox should be off. The body is acting weird most likely because the skeleton bones positions you're using in Blender are overriding your inworld avatar's shape.

Edited by OptimoMaximo
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 1548 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...