Jump to content
ArcaneBlackwood

Problem importing custom boned avatar: deformation

Recommended Posts

Im having problems with importing my rigged and weighted. 
Everything seems fine up until I enable 'weights' preview in the upload dialog:

image.png.f8992333da213ca4cb5d53541ddb7132.png

I thought maybe it was just the default animation that was causing it, since i have modified bones and thier positions to fit my model.  I imported and played a custom animation that works within blender for my exact rig.  But still fails, looking like the picture above, malformed and disfigured beyond use.  Everything in the blender file is not scaled, all transforms are applied, and all bones and their corresponding vertex groups are labeled correctly.  Even if i use Bento Female-2017-01-09 .blend from the Avatar Workbench without modification, it fails in the same way, having an incorrect deformation in the same way.  I thought maybe it was a bug in the Firestorm Viewer, so switched to the legacy Viewer, but still, no change.

From what i have heard, its common to have issues importing from blender, but nothing I have found has been successful or even useful.  I do not have, and do not intent do purchase the Avastar plugin.  Is there any way to import this model with bones and weight information successfully?

Heres my blender file:

http://files.arcanes-spoteh.nz/uploads/11-PonySecondLife.blend

Share this post


Link to post
Share on other sites
5 hours ago, ArcaneBlackwood said:

I do not have, and do not intent do purchase the Avastar plugin.  Is there any way to import this model with bones and weight information successfully?

If you're rigging to the collision volume bones too, make sure that they have the additional scale attributes set when you open the N panel. Not the regular scale, what i'm talking about are custom properties added to the avatar workbench bones and should look like scale.x, scale.y, scale.z followed by a number. Avatar workbench comes with those already set, not sure about the avatar you can get from the SL Wiki.

Second thing, assuming that the point above is fullfilled, the avatar should face the +X direction before exporting. So if your avatar is facing -Y as per Blender's defaults it's fine to accomodate the bones into their appropriate locations, but once done, you should grab the skeleton and rotate it to face +X, then apply rotation. Then in pose mode also apply pose as rest pose (shuoldn't be necessary, but who knows).

Finally, when exporting, choose the SL rigged from the preset dropdown menu in the operator panel.

Hope this helps

Share this post


Link to post
Share on other sites
18 hours ago, OptimoMaximo said:

... the avatar should face the +X direction before exporting. ...

Finally, when exporting, choose the SL rigged from the preset dropdown menu in the operator panel.

Ive followed what you have stated here and have had much better success, the model is much less deformed, but there is still something wrong with the bones.  Viewing through Developer > Render Metadata > Joints.  Sicne Im using the Avatar workbench model, I already have the properties set.

The mesh is deformed, but it only seems to be vertical deformation.  From what I can tell via the Developer rendering options, the bones dont look linked properly, and seem to mostly be horizontal except a couple at the back.

Here is a screenshot of the model, left and center is SL, right is Blender(Goal)
image.thumb.png.c90c5ea0a7a354dc20f675f0db7f3fec.png

 

Im stupmed, it seems so close, but still not working.  Any ideas?

Share this post


Link to post
Share on other sites
Posted (edited)
32 minutes ago, ArcaneBlackwood said:

From what I can tell via the Developer rendering options, the bones dont look linked properly, and seem to mostly be horizontal except a couple at the back.

That isn't an issue, it's just the joint orientation and as long as you give it a matching set of animations, it will work right. 

32 minutes ago, ArcaneBlackwood said:

Sicne Im using the Avatar workbench model, I already have the properties set.

Alright, since I didn't know what shape you were after, i assumed you were using collision volume bones, which tends to implode and distort the mesh a lot. However I'm seeing you're after a non human shape, so here is the most likely culprit:

The default shape in SL is a shape obtained via joints scaling. So both default shapes have elongated joints, usually scaled up along their Y axis, and your vertical looking joints in the dev menu are most likely having the Y axis along the stretching direction. So, first you should check that those extra properties on the main bones are all set to 1,1,1 just in case they're set to 1.4 or something. Also, your inworld shape might be interfering, so you should set your inworld shape to female default. Let's see if these two steps help

Edited by OptimoMaximo

Share this post


Link to post
Share on other sites

Also, since I can't tell from the picture, I'm assuming that you just repositioned the bones without changing their hierarchy. Changing the hierarchy is a deal breaker

Share this post


Link to post
Share on other sites
17 hours ago, OptimoMaximo said:

That isn't an issue, it's just the joint orientation and as long as you give it a matching set of animations, it will work right. 

Alright, since I didn't know what shape you were after, i assumed you were using collision volume bones, which tends to implode and distort the mesh a lot. However I'm seeing you're after a non human shape, so here is the most likely culprit:

The default shape in SL is a shape obtained via joints scaling. So both default shapes have elongated joints, usually scaled up along their Y axis, and your vertical looking joints in the dev menu are most likely having the Y axis along the stretching direction. So, first you should check that those extra properties on the main bones are all set to 1,1,1 just in case they're set to 1.4 or something. Also, your inworld shape might be interfering, so you should set your inworld shape to female default. Let's see if these two steps help

It was a humanoid shape, default from the Avatar workbench - female angel.  I deleted bones hierarchically that I wasnt using, eg hind legs, half the wings.

On 3/29/2020 at 5:18 AM, OptimoMaximo said:

should look like scale.x, scale.y, scale.z followed by a number

Im not entirely sure where to set these values.  Im assuming it would be on each individual bone?image.png.99507ff0569838ad236d01723caa7826.png

Share this post


Link to post
Share on other sites
1 hour ago, ArcaneBlackwood said:

It was a humanoid shape, default from the Avatar workbench - female angel.  I deleted bones hierarchically that I wasnt using, eg hind legs, half the wings.

Im not entirely sure where to set these values.  Im assuming it would be on each individual bone?image.png.99507ff0569838ad236d01723caa7826.png

Yes I meant on each individual bone, but I see from your screenshot that the local y scale is properly set at 1 as for the default avatar. Only thing I can think of now is to set this pose as rest pose with ctrl A when in pose mode. Other than these, the remaining step, the inworld shape, is the last thing i think might be interfering

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...