Jump to content
kira Alena

Specific account wont load official ll viewers or black dragon

You are about to reply to a thread that has been inactive for 158 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

SO this has been happening for a while, but the official LL viewer, or black dragon has issues with a specific account. I can log on fine with my alt, but on my main account, the viewer freezes almost instantly after login, and it eventually crashes. Any help is appreciated.

Share this post


Link to post
Share on other sites
26 minutes ago, kira Alena said:

SO this has been happening for a while, but the official LL viewer, or black dragon has issues with a specific account. I can log on fine with my alt, but on my main account, the viewer freezes almost instantly after login, and it eventually crashes. Any help is appreciated.

This could be due to you having a huge inventory or a massive system notification list.

Go into: C:\Users\USERNAME\AppData\Roaming\BlackDragon\your_avatar_name

Find this file and delete it, this should clear your system notifications (top right corner). Having a large notification list can cause the Viewer to stall for extended periods of time while logging in. If that doesn't help i don't know, i had a similar issue where most of my logins failed because the 10% loading would take ages due to some outfit sync resulting in a disconnect at some point. 

image.png.d69bdc2b92f83840a6bc8803d472bbe8.png

Share this post


Link to post
Share on other sites
9 hours ago, NiranV Dean said:

This could be due to you having a huge inventory or a massive system notification list.

Go into: C:\Users\USERNAME\AppData\Roaming\BlackDragon\your_avatar_name

Find this file and delete it, this should clear your system notifications (top right corner). Having a large notification list can cause the Viewer to stall for extended periods of time while logging in. If that doesn't help i don't know, i had a similar issue where most of my logins failed because the 10% loading would take ages due to some outfit sync resulting in a disconnect at some point. 

image.png.d69bdc2b92f83840a6bc8803d472bbe8.png

I appreciate the help, but that didnt seem to work, unfortunately.

Share this post


Link to post
Share on other sites
1 hour ago, kira Alena said:

I appreciate the help, but that didnt seem to work, unfortunately.

Then i'd like to see your log file after crashing, maybe i can see something in there

You can find it here: C:\Users\USERNAME\AppData\Roaming\BlackDragon\logs

Find the latest one of these:

image.png.5b2385822dfb709c41ac90e371b97f45.png

 

Share this post


Link to post
Share on other sites

Okay. So first things first. You are not crashing, the viewer disconnects at the end. You are being timed out due to the Viewer being unable to properly connect, its literally retrying thousands of times and can't get everything it needs.

Make sure you have NOT enabled the web proxy and neither the custom port in Viewer and Browser settings. Also make sure nothing is blocking the viewer, Firewall, Windows Defender, Antivirus programs, any net management tools and so on.

Next i'd attempt to login in a few times in a row, immediately after another. As described previously you might be experiencing the same issue i had where most of my login attempts stalled due to a huge freeze and random timeout towards the end. I usually got through on the second or third attempt. Though i know of no fix for this situation sadly, it went away when i switched to Windows 10, i suspect it was simply my harddrive (i now use a SSD) being busy and slowing the loading time down so much that everything broke apart.

If that doesn't help then maybe a cache clear could help, possibly because you are experiencing a freeze or timeout due to the inventory starting to load too early (which if its big and loading in huge chunks causes drastic framedrops) which a cache clear could potentially solve as it will usually delay the inventory loading until shortly after you're seeing the world or sometimes even not at all unless you bump it manually with a search through your inventory.

Share this post


Link to post
Share on other sites
8 hours ago, NiranV Dean said:

Okay. So first things first. You are not crashing, the viewer disconnects at the end. You are being timed out due to the Viewer being unable to properly connect, its literally retrying thousands of times and can't get everything it needs.

Make sure you have NOT enabled the web proxy and neither the custom port in Viewer and Browser settings. Also make sure nothing is blocking the viewer, Firewall, Windows Defender, Antivirus programs, any net management tools and so on.

Next i'd attempt to login in a few times in a row, immediately after another. As described previously you might be experiencing the same issue i had where most of my login attempts stalled due to a huge freeze and random timeout towards the end. I usually got through on the second or third attempt. Though i know of no fix for this situation sadly, it went away when i switched to Windows 10, i suspect it was simply my harddrive (i now use a SSD) being busy and slowing the loading time down so much that everything broke apart.

If that doesn't help then maybe a cache clear could help, possibly because you are experiencing a freeze or timeout due to the inventory starting to load too early (which if its big and loading in huge chunks causes drastic framedrops) which a cache clear could potentially solve as it will usually delay the inventory loading until shortly after you're seeing the world or sometimes even not at all unless you bump it manually with a search through your inventory.

So I tried everything here... Still no fix.

Share this post


Link to post
Share on other sites

It's not happening to your alt, you say? With everything else you've tried... you've tried logging in to other start locations? (I'm grasping at straws for anything that could be different between your accounts, thinking maybe they start at different places and... I dunno, some magic network problem between you and one of them. Yeah, it doesn't make sense, does it?)

Share this post


Link to post
Share on other sites
3 minutes ago, Qie Niangao said:

yeah, my alt is totally fine ! And I can use firestorm. Firestorm freezes for 30 seconds with this account, but then its usually fine. I was reading somewhere that it could be a corrupted inventory? 

 

Share this post


Link to post
Share on other sites

Oh, it works with Firestorm! That's new information... somebody will know what to do with it. I wonder if you could get the Firestorm log file from just after it recovers from that 30 second freeze? (I'm not a viewer dev so I'm useless here, but if I were a viewer dev, I think that's what I'd ask for.) I guess it could be corrupted inventory, but evidently it's not corrupted enough to break Firestorm.

Meanwhile... if you haven't already tried this, you might login with Firestorm and temporarily switch to one of the test avatars -- Develop / Avatar / Character Tests / Test Female (or Male) -- and then try one of the problem viewers just in case it's something you're wearing (that somehow Firestorm eventually ignores or... something).

Share this post


Link to post
Share on other sites
5 hours ago, Qie Niangao said:

Oh, it works with Firestorm! That's new information... somebody will know what to do with it. I wonder if you could get the Firestorm log file from just after it recovers from that 30 second freeze? (I'm not a viewer dev so I'm useless here, but if I were a viewer dev, I think that's what I'd ask for.) I guess it could be corrupted inventory, but evidently it's not corrupted enough to break Firestorm.

Meanwhile... if you haven't already tried this, you might login with Firestorm and temporarily switch to one of the test avatars -- Develop / Avatar / Character Tests / Test Female (or Male) -- and then try one of the problem viewers just in case it's something you're wearing (that somehow Firestorm eventually ignores or... something).

No Firestorm just doesn't time out as fast. If that's the case then there is sadly nothing she can do.

Edited by NiranV Dean

Share this post


Link to post
Share on other sites
2 hours ago, NiranV Dean said:

No Firestorm just doesn't time out as fast. If that's the case then there is sadly nothing she can do.

Okay, but if Firestorm freezes for a long time and then works fine, I'd think that whatever is taking all that time eventually resolves (or else Firestorm ignores the still unresolved problem somehow). We also know that other accounts can use the Linden and Black Dragon viewer on the same hardware with the same network connection, so it's something specific to this account that's timing out on those viewers.

I'm not a viewer developer, so I don't know where to begin trying to make sense of the logfile. I wonder if it's possible to determine whether it's inventory corruption (that somehow Firestorm survives), and kira should contact the Lab for repair? We're sure she can't login to Firestorm and do some inventory maintenance on her own, maybe adding some folders to reduce the count of items in the largest folders (if that's even a thing anymore)?

I wonder if @Whirly Fizzle might recognize this Firestorm magic or have any other suggestions.

Share this post


Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 158 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...