Jump to content
Sign in to follow this  
auntiemisha

Eyebrowshaper Problem - taper back showing through

Recommended Posts

Posted (edited)

I recently went from wearing medium length hair to only hairbase tattoo+hairontopofhead

When my avatar bends her head down, there was a small bit of black "hair" sticking out the back of her head! I removed everything I could to see if it was a weird object glitch but it was still there! The problem ONLY shows up when my head is bent down. I narrowed the problem down to the "Eyebrowshaper".  Also I hat that Eyebrowshaper is "System Hair" so I sometimes refer to it as "hair" but it's not.

  •  I set the texture to transparent which helps but does not eliminate the problem.
  • Is there any slider on the Eyebrowshaper that will fix this?  I only messed around with Style -> Taper Back.

I cannot see it at all when I am in my usual pose stand, which holds the head upright.  I only see it when avatar is moving head/neck around. OR if I sit on furniture that bends the head down.

I removed hair tattoo to see the problem better, edited Eyebrowshaper -> Style -> Taper Back to 0 and then to 100 but still there is some sticking out no  matter what I set it to.

  • With just system avatar it is harder to see but still shows up.
  • With mesh head ARGH a hole appears in the head.

Any setting in Eyebrowshaper that would remove this issue?  Or am I stuck with the occasional invisible bit/line on head?

 

Here is invisible Eyebrowshaper with taper back = 0.  Pointy "invisible" bit is attached to me, not the window.

 

haribase_taperback0_invis.thumb.png.786e16741fcc3fcc0e7df78c76f5d2a0.png

Eyebrowshaper not invisible, taperback = 100

haribase_taperback100_color.thumb.png.d8bcbfc50f99dd837888554884a9d1f2.png

 

Eyebrowshaper not invisible, taperback = 0

haribase_taperback0_color.thumb.png.a4746b540ea8045f6b97d5481d382159.png

 

Here I am with my short haircut and BOM mesh head (shows hole in head!)

haribase_meshhead_hole.thumb.png.217a8881326db139c1a8cd1900c8e0ee.png

 

Here is a nicer picture because ARGH all the pictures above. I'm ready for my massage, don't mind the hole in the back of my head!justapicture.thumb.png.62eaba68e8696906ca4cad938447b087.png

 

Edited by auntiemisha

Share this post


Link to post
Share on other sites

I would have thought that setting the texture to transparent should have taken care of the issue.   I haven't had this specific problem, but here are some things that came to mind:

You mentioned setting the taperback to 0 - are the other sliders in the Style section also set to 0?

You might look to see if you have any others in your inventory - sometimes they come with shapes or with mesh heads - there are also some in the library section of inventory (Library -> Clothing -> Initial Outfits ...)   Sometimes they are just called just brows or eyebrows, so you might want to search in your inventory for 'brows' to pick up the name variations. You might want to try wearing some of the others and see if you have the same problem. 

 

Someone else will probably be along later on to add to the comments here with other suggestions or solutions. 

  • Like 1

Share this post


Link to post
Share on other sites

You can shrink it down using the system hair style sliders but you can disappear it completely by changing the texture to transparent.

Share this post


Link to post
Share on other sites

@moirakathleen

I tried the "Anna - brow" from a newer system avatar and it does NOT have the problem. BUT the eyebrow shape is not what I want, and the Anna -brow is NOT moddable.  So I have NO idea what sliders to change to fix the problem, but at least I know it IS fixable.  If only someone could tell me how.  Thanks pointing me in that direction so I know there is hope one day.

@Matty Luminos

If I change the texture to transparent, that's when I get the "hole in the head" when I wear my mesh head.

The taper back *is* at 0 (zero), I can't slide it down any more.

In conclusion:

 Unfortunately "edit appearance" puts me in a position with my head "upright", I can't see the effect of slider changes immediately.  And I don't much feel like going through all of them one-by-one to see what difference they make (would have to edit appearance, change slider, exit appearance, sit on furniture, check, then repeat all the steps for each slider).  I was hoping someone had already figured this out.

  • I note it is the "girl next door" old system avatar eyebrowshaper, which is moddable.
  • Many older avatar eyebrowshapers seem to have the same problem. 
  • The newer system avatars brows that don't have the problem, are all NO MOD so I can't see what the fix is!

I give up for now. Maybe someday I'll go through the tedium of all the steps to see what fixes it.

I'm changing it back to black color and I will just live with the "untameable hair strand" in the back of my head.  Hmm sort of like some hair on the top of my head in RL. 🙂

 

Share this post


Link to post
Share on other sites

Look for modifiable hairbases. Your best bet will be ones called 'Bald' or 'Baldie'. If you need some, I should have a few I can send if you can wait until tomorrow.

Share this post


Link to post
Share on other sites

@Roxy Couturier

I have a modifiable hairbase.   I'm hoping someone will know what slider(s) to change.  I don't want to go through randomly changing sliders at the moment, although I may one day.  I tried "taper back" from 0 to 50 to 100 because it seemed the logical slider, but it didn't solve the problem, just made a tuft of "hair" into a line of "hair" sticking out.

Share this post


Link to post
Share on other sites
2 hours ago, auntiemisha said:

I have a modifiable hairbase.   I'm hoping someone will know what slider(s) to change.  I don't want to go through randomly changing sliders at the moment, although I may one day.  I tried "taper back" from 0 to 50 to 100 because it seemed the logical slider, but it didn't solve the problem, just made a tuft of "hair" into a line of "hair" sticking out.

in the Style section of the editor set all the  slider values in Body to 0.  This will cause the system hair to crumple up inside our avatar's head

to hide the system hair completely then apply a transparent texture with Texture tool in the editor (top the editor dialog)

Inventory \ Library \ Textures \  *Default Transparent Texture

then we can use the Eyebrows section of the editor to get the eyebrow shape we want for our avatar

Save As with a new name and done

Share this post


Link to post
Share on other sites

@Mollymews I don't see the word "Body" in the Style section when editing the eyebrowshaper, what do you mean?

I tried setting ALL sliders in the Style section equal to 0 but that doesn't solve the problem.

 

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, auntiemisha said:

@moirakathleen

I tried the "Anna - brow" from a newer system avatar and it does NOT have the problem. BUT the eyebrow shape is not what I want, and the Anna -brow is NOT moddable.  So I have NO idea what sliders to change to fix the problem, but at least I know it IS fixable. 🙂

 

If it's not moddable you can't change the sliders either. You will have to trash it and use another. If you can change the sliders, you can also change the texture. The reason you have a hole in your head when it's transparent is because some of it is poking through your mesh hair, and there is an alpha conflict. 

Some of the sliders need to be at zero and some at 50. I have sent you one inworld, with all the correct settings. I didn't touch the eyebrow section, you can edit that part yourself to suit your skin. Basically everything's at zero except for Full Hair Sides, Hair Sweep, Shear Back, Taper Front, Taper Back, and Hair Tilt.  Those ones are at 50 and that makes everything as small as it will go.

 

 

Edited by Matty Luminos
  • Like 2

Share this post


Link to post
Share on other sites
4 hours ago, auntiemisha said:

@Mollymews I don't see the word "Body" in the Style section when editing the eyebrowshaper, what do you mean?

I tried setting ALL sliders in the Style section equal to 0 but that doesn't solve the problem.

 

sorry I was thinking about a TPV I use when I said Body. You are in the right section with 'Style'.  Linden Viewer pick here

image.thumb.png.509b108667469a0311fa466b4fa08be1.png

 

if you haven't already try creating a New Hair asset and working with the new asset.  It may be that the hair base asset you are currently working with has broken in some way. Which can happen sometimes with existing stuff for some dunno reason

if you haven't created a new hair asset before then on the Appearance Editor there is a gear icon menu at the bottom of the dialog.  menu: New Body Parts \ New Hair.  Click this will put a new hair base on your head replacing the current worn one.  Do the Style sliders and/or transparent texture and Eyebrows. and Save

 

  • Like 1

Share this post


Link to post
Share on other sites

I did some testing (just more and more curious about it) and found it was the following:

STYLE -> SHEAR BACK = 0 causes the problem.

If I set SHEAR BACK = 50 it looks OK, no tuft of hair when opaque, no hole in back of  head when invisible.

So setting ALL the sliders to 0, includes shearback=0 and causes the problem.

  • The Fix: I set all sliders to 0 EXCEPT for the following two: shearback =5 0 and hair tilt = 50

Yay!

  • Like 4

Share this post


Link to post
Share on other sites
19 hours ago, Matty Luminos said:

If it's not moddable you can't change the sliders either. You will have to trash it and use another. If you can change the sliders, you can also change the texture. The reason you have a hole in your head when it's transparent is because some of it is poking through your mesh hair, and there is an alpha conflict. 

Some of the sliders need to be at zero and some at 50. I have sent you one inworld, with all the correct settings. I didn't touch the eyebrow section, you can edit that part yourself to suit your skin. Basically everything's at zero except for Full Hair Sides, Hair Sweep, Shear Back, Taper Front, Taper Back, and Hair Tilt.  Those ones are at 50 and that makes everything as small as it will go.

 

 

Oh I noticed @Matty Luminos

gave me the answer after all, (Shear Back = 50 ) I had scrolled to the bottom to check for new answers and missed it.  Thanks Matty Luminos, sorry I missed your correct answer!

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)

@auntiemishaI just want to say I love it when folks who post with a problem interact with the people who post comments! This is a very friendly, helpful bunch and with feedback even more so. :)

Edited by Seicher Rae
  • Like 5

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...