Jump to content
  • 0
Sign in to follow this  
XENA5906

Second Life beta not excepting login info

Question

Hello, I am trying to log into second life beta with my current sl account. I am not being allowed in. I keeps saying that my username or password is incorrect and they are not. and idea what i should do?

 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
3 minutes ago, Lindal Kidd said:

I think you have to file a support case to get access to the beta grid for the first time.

Yes, if you are "newish". Really old avatars that have never been in WERE (at least when I tested) whitelisted and didn't have to do that step.   If you are going to upload mesh, head for a mesh sandbox when you get there :D.  Good luck. 

Share this post


Link to post
Share on other sites
  • 0

Lindal and Chic are right. If this is your first time logging into the Beta grid you will need support's help.

If you have not logged in for some time, like over a year, you may also need support's help.

Occasionally a password change fails to carry over to the beta grid. If you recently changed password, you can try your previous password. But, you will likely need to get support to help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...