Jump to content
Caleb Linden

Deploy Plans from 12-17-2019 to 1-4-2020

Recommended Posts

I don't know if this is relevant, but several Mainland regions I monitor got restarted Sunday. Seemed too many of them to all be BlueSteel if any of them were, and unfortunately I don't know what versions were loaded on them before they restarted (onto 533447). This was Sunday around 1430 - 2200 Zulu, so like 8:30 am to 3 pm Pacific. May have been totally unrelated to this, but there were too many to be purely coincidental with each other.

Share this post


Link to post
Share on other sites

The mainland region my parcel is on (which was BlueSteel and I assume still is) is still on 533558. No restart since last Wednesday (when there was 2 - The first restart seemed to trigger events twice, which may be why it got restarted again?)

Guessing "redeploy" means extending rollout of 533558 to one of the RC's on 533447

  • Thanks 1

Share this post


Link to post
Share on other sites

Looks like yesterday's roll was to a new version - my parcel's region is now on "Second Life Server 2019-12-16T20:58:49.533895". Unfortunately the release notes give "access denied", so no idea what changes it has.

Edit:
Release notes now accessible: https://releasenotes.secondlife.com/simulator/2019-12-16T20%3A58%3A49.533895.html

Edited by LoganPryor
Update on release notes

Share this post


Link to post
Share on other sites

so...we have an undocumented software version being rolled to an RC channel?  Not good just prior to the Big Holiday.  O.o

 

ETA 20th 5pm GMT: Ahh so there we are; Thankyou...more fixed internals...now, about my hernia....

Edited by Aishagain
Fatuous edit

Share this post


Link to post
Share on other sites

Just musing here....I notice my region didn't get the usual ten-day restart last Friday, and Caleb's post at the top here doesn't carry the usual paragraph about it being a good thing to switch stuff off and on again now and then.

I wonder if there's a rationale behind this or whether I'm just tinfoil hatting about it? :D

By the way Happy Holidays (it's what you Yanks say isn't it?) to all in SL and to Linden Lab Staff. :)

  • Thanks 1

Share this post


Link to post
Share on other sites

It seems we are reaping the results of LL's abandoning of the 10 day restart cycle.  My home sim will also reach 20 days without a restart on Monday 30th, and while I can restart it myself and will if it becomes needed, much of SL's Mainland is a mess right now.

I have heard of two shopping event sims, which are often heavily loaded which have ground to a halt today.  They are simply out of memory!

About a year ago LL finally admitted that the SL software has a memory leak and 10 days is about as long as a heavily loaded region can manage without a restart.  Some heavily scripted sims need restarts almost daily!  We are now approaching 3 WEEKS for most Main Server sims since their last restart.

Please WAKE UP LL!

Edited by Aishagain
Grammar and punctuation

Share this post


Link to post
Share on other sites

Just musing again and noticed the odd dates given for the OP.... 4th January is a Saturday, neither an end or a start of a week as LL usually count them.  Could THAT be significant or am I tinfoil-hatting again?

Next cycle "should" be week starting Jan 6th, I'd expect, so what have LL in store for us this time?  A round of "clean-up" restarts on Mainland?

Share this post


Link to post
Share on other sites
On 12/31/2019 at 4:28 PM, Aishagain said:

Just musing again and noticed the odd dates given for the OP.... 4th January is a Saturday, neither an end or a start of a week as LL usually count them.  Could THAT be significant or am I tinfoil-hatting again?

Next cycle "should" be week starting Jan 6th, I'd expect, so what have LL in store for us this time?  A round of "clean-up" restarts on Mainland?

7th January, and restarts began at the usual Tuesday time.

There was a Status message, but it wasn't the usual wording, and no post in this Forum. These restarts should have been predictable enough that the usual messages could appear, not new code but routine management. "We will be performing additional rolling restarts" looks odd.

Share this post


Link to post
Share on other sites

I crash after saving a script in any region that was restarted today, and don't crash in any region that hasn't restarted yet.  They are all Second Life Server 2019-12-04T20:29:26.533447

Share this post


Link to post
Share on other sites
54 minutes ago, Sayrah Parx said:

They are all Second Life Server 2019-12-04T20:29:26.533447

This amazes me because our 2 regions (Magnum) also have the same version number 2019-12-04T20: 29: 26.533447 and with us it works perfectly as a test just performed showed.

Share this post


Link to post
Share on other sites

@Miller Thor: I think the important information was:

1 hour ago, Sayrah Parx said:

I crash after saving a script in any region that was restarted today

Now, the server version number on Main Server or anywhere else has NOT changed so it is something below that level that is changed, and you will see that LL are aware of a script save issue on sims restarted today.  So the question is: what is being changed?  /me sneezes "Cloud" O.o

Share this post


Link to post
Share on other sites

I've checked two places running 533447 and although I'm not crashing it's not possible to save scripts, as per the grid status tweet a couple of hours ago. I tried a parcel on 533895 and it saved as expected, but I don't think it has had a restart today, the other two places did have restarts.

Share this post


Link to post
Share on other sites
On 1/7/2020 at 12:47 PM, Profaitchikenz Haiku said:

I've checked two places running 533447 and although I'm not crashing it's not possible to save scripts, as per the grid status tweet a couple of hours ago. I tried a parcel on 533895 and it saved as expected, but I don't think it has had a restart today, the other two places did have restarts.

Gormthoog region has the same problem still, after being restarted it still doesn't allow saving of scripts. It hasn't allowed it since an out-of-schedule region restart on Monday, when normal restart day is Wednesday. Despite the claim on the status page, the issue is NOT resolved.

Share this post


Link to post
Share on other sites
Posted (edited)

Just checked in on Gormthoog, looks like it was restarted about an hour ago (so about 6:30 am PST I guess) and seems to be saving scripts fine now. It's running about 70% of its 6600 or so scripts which is probably about normal.

[EDIT: I realize we should be over in this week's thread for stuff like this now. And that thread should be stickied instead of this one, but there's nothing I can do about that.]

Edited by Qie Niangao

Share this post


Link to post
Share on other sites
8 minutes ago, Qie Niangao said:

Just checked in on Gormthoog, looks like it was restarted about an hour ago (so about 6:30 am PST I guess) and seems to be saving scripts fine now. It's running about 70% of its 6600 or so scripts which is probably about normal.

[EDIT: I realize we should be over in this week's thread for stuff like this now. And that thread should be stickied instead of this one, but there's nothing I can do about that.]

Yes, I got on with Live Chat support this morning, and told them what was going on. They moved it to a different server channel during that restart this morning as a fix for whatever was wrong with it, and that fixed the issues. But I have no idea what channel it was on before or is on now,  the new numbering convention is confusing to me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...