Jump to content
  • 0

Scripts randomly getting turned off?


You are about to reply to a thread that has been inactive for 292 days.

Please take a moment to consider if this thread is worth bumping.

Question

Has anyone else had scripts in items randomly getting themselves deactivated? It's happened very occasionally for a little while, and for the most part it it's just a minor annoyance because the script can just be turned back on, but recently the phenomenon ruined an old and irreplaceable HUD because of its no-mod condition (obviously it's dumb to not have a backup, but it worked flawlessly for years). Is this a known issue, is there a reason behind it, and is there a way to force the scripts in a no-mod item to turn back on?

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
4 hours ago, Beasil Roundfield said:

Has anyone else had scripts in items randomly getting themselves deactivated? It's happened very occasionally for a little while, and for the most part it it's just a minor annoyance because the script can just be turned back on, but recently the phenomenon ruined an old and irreplaceable HUD because of its no-mod condition (obviously it's dumb to not have a backup, but it worked flawlessly for years). Is this a known issue, is there a reason behind it, and is there a way to force the scripts in a no-mod item to turn back on?

In fact this came up in yesterday's Server User Group (was news to me) and I understood the issue to have prevented the RC simulator version from "graduating" to the main server channel this week.

Quote

[2019/12/03 12:03]  Simon Linden: Let's see ... for news, we originally had planned to update the main channel regions with the version that's on the RC channels, but held off as we are looking into issues about scripts not running.
[2019/12/03 12:03]  Oz Linden: (some scripts, not all)
[2019/12/03 12:04]  Oz Linden: ("all" would have been a rollback)
[2019/12/03 12:04]  Simon Linden: It appears to be an old issue that's always been there but is worth investigating ... we're trying to get an update together for tomorrow morning
[2019/12/03 12:04]  Simon Linden: yes - it was a very small percentage but that's enough to be painful when there are millions running

A bit later the subject was raised again:

Quote

[2019/12/03 12:17]  Torric Rodas: Rider, we were speaking about scripts inexplicably setting themselves to not running, and I got a reply from Evie Linden saying it was a know issue? When we spoke it wasn't "known", can I take it that it has been accepted as a problem now?
[2019/12/03 12:17]  Torric Rodas: *known
[2019/12/03 12:18]  Simon Linden: That's exactly the one I was talking about earlier, Torric - yes it's known and getting attention
[2019/12/03 12:18]  Torric Rodas: oh great thanks. Sorry I missed the very tip of the meeting.
[2019/12/03 12:18]  Rider Linden: I had just sat down at my desk when you messaged me... so it was not yet known to me (I hadn't even cracked my email yet). We've since identified the issue and have a fix for what was going on.

Unfortunately, once a no-mod object's scripts get b0rked, there's no recovery short of replacing the object. No redelivery possible from this creator?

[EDIT TO ADD: Oh, wait, Inara Pey's wonderful blog mentions that this may be BUG-227864 which has the interesting suggestion that affected scripts start running again when the region restarts. So maybe, if you have a friend with an Estate sim that can be restarted on command, you could rez the HUD somewhere on the sim, get it restarted, and see if it's magically cured. Seems improbable, but maybe worth a try anyway, and sure would be cool to find out if it worked.]

Edited by Qie Niangao
Link to post
Share on other sites
  • 0
3 minutes ago, Qie Niangao said:

Unfortunately, once a no-mod object's scripts get b0rked, there's no recovery short of replacing the object. No redelivery possible from this creator?

Sadly no. It's a pretty ancient toy and I think that the creator is long-gone. Anyway, I'll need to remember to back up anything for which I don't have one, or the original package. Eventually finding an alternative for this thing from another creator is..not impossible, I guess, but I've never seen a thing like it. Thanks for the info.

Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 292 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...