Jump to content
  • 0
theHuskyNicko

Black Dragon - Mesh Head Glitch

Question

4 answers to this question

Recommended Posts

  • 0

I suggest you contact NiranV, the author of Black Dragon. Show Niran the problem. If it is a bug, it will get fixed. If it is a setting, you'll find out what to change.

@NiranV Dean help...

Edited by Nalates Urriah
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Looks like alpha fighting.
If you remove the hair does it stop?
Just to clarify - does this problem only happen on Black Dragon viewer?  Do you see the same problem on the latest release of the LL viewer or Firestorm?

Share this post


Link to post
Share on other sites
  • 0

As Whirly suggested this is indeed an alpha fighting (z fighting) issue.

Your friend's head is alpha and so is hair and his eyes.

Unlike other Viewers Black Dragon does not make use of the pre-materials auto masking hack and instead shows you items as they are.

There are several ways to fix this depending on how much control you have over said avatar and how much time you want to invest in fixing this issue.

The Actual Fix:

You replace all textures with ones that do not use alpha nor contain an alpha channel on export/save. You can do so by explicetly removing the alpha channel from a texture, in GIMP you'd go into Layers - Transparency - Remove Transparency Layer/Channel, then export the texture again and upload it, you can check whether you successfully removed the alpha channel by using the Local Texture feature and putting the texture onto a cube, if the cube shows the "Alpha Mode" dropdown in the Texture tab in the Tools window you did something wrong, "Alpha Mode" MUST be greyed, make sure you only select one face when doing so as selecting the entire object or multiple faces can grey out the dropdown depending on which face is counted as the first or last. No idea how to do this in Photoshop.

Correct:

image.png.18bef305b665a3aa71b25796067e5d55.png

Wrong:

image.png.ffad00934999e57463bee5a02271f7a4.png

The Bandaid Fix:

Select all faces/prims you want to "fix" and open the Tools window, select the Texture tab and choose "None" in the Alpha Mode dropdown if you dont need any alpha or select "Masking" if you alpha for things like eyebrows, don't forget to set a Cutoff if you choose "Masking" otherwise it will be just like "None". Doing this will tell the Viewer to handle the texture as a simple 1bit alpha thus practically making it a solid object, preventing these alpha sorting issues and improving performance too.

From this:

image.png.37d3920ef6a9d03f561b6e7f74f0e43d.pngimage.png.24cd4f00bc3a6a45a67547a68b939e74.png

To this:

image.png.ea0e85c4aeadcd1bd6dfbd75862f9c8d.pngimage.png.46e788748138d2d5ef6606bd877298b6.png

The Pink-Glasses Workaround:

Put on pink glasses again, ignore that the world is burning and re-enable Automatic Alpha Masks (Deferred). From now on you'll be jumping around happily in a huge flowerbed.

 

---

Explanation:

As you may have noticed in the pictures above, changing an object from "Blending" to "Masking" can have a big impact visually, both negatively as well as positively. In the case of my ears, they are made to use "Masking" mode hence, why they look no different using either mode, the difference between them are the many different visual bugs, starting with the pixelated shadows (can be seen on the picture at the tip), incorrect lighting, different material visuals, alpha flickering (z fighting, you are experiencing), not properly working post processing effects such as SSAO, Volumetric Lighting and as you already noticed Depth of Field completely ignoring the "depth" of said objects, higher performance footprint, in case of rigged attachments they cut out alpha objects behind them (seen on the pictures above, often happens to rigged hair on human avatars) and much more. In short alphas are bad and you want to not use them as much as possible and instead use "Masking" if you absolutely must use alpha, there are exceptions where "Blending" is necessary such as glass panes ofcourse.

To Clarify:

This issue happens on all Viewers if you toggle the auto masking hack off, however even though the hack does "hide" some of these cases, it is not perfect and utterly fails on harsher cases, a texture that is completely solid but contains an alpha channel is a surefire case to get catched by this hack, if you delete out a few pixels from the main channel, making it contain real alpha, this case would probably fall through as well and show you the same ugly issues. Also note that the hack does NOT fix all the issues nor does it a good job at hiding certain issues like pixelated shadows, pixelated shadows (especially on rigged attachments) will still appear even with the hack on ultimately requiring you to fix it manually. The hack is basically useless it just gives you as user the false impression that everything is fine when it is not.

Edited by NiranV Dean
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...