Jump to content
Sign in to follow this  
Rumancekk

I changed my hover height and now I can't sit on anything

Recommended Posts

I can but I go through the furniture. It wasn't like that before I adjusted my hover height. I only adjusted it because my feet were going through the floor on one spot but I didn't have much trouble when I sat on things. Now everywhere I sit, I sink into the furniture, even though I put it back to where I had it... And when I try to fix it, other parts of my body are way to high. Is there any way I can fix this? I did sink in a LITTLE before but now it's ridiculous

This is before and after I changed my hover height. It should be obvious which one is broken. romanscondlife_030.thumb.png.10d0de2d075824a8bbb3f1eefd612c6f.png

romanscondlife_031.thumb.png.ab3b475ac26d3f2a910754f54ee2e134.png

 

Share this post


Link to post
Share on other sites

Well if you change your hover height for whatever reason this is the natural effect. Most all furniture let's you both ADJUST your sitting position AND save that preset for the specific avatar. So if you need to adjust your hover height dramatically (and I have had to a  lot recently so I understand) then the best method would be to adjust your seating position and SAVE that setting. You will need to do that for each piece of furniture and each animation within that furniture. 

Share this post


Link to post
Share on other sites
2 hours ago, Chic Aeon said:

Well if you change your hover height for whatever reason this is the natural effect. Most all furniture let's you both ADJUST your sitting position AND save that preset for the specific avatar. So if you need to adjust your hover height dramatically (and I have had to a  lot recently so I understand) then the best method would be to adjust your seating position and SAVE that setting. You will need to do that for each piece of furniture and each animation within that furniture. 

so is there no way to get it back to the way i had it before? i don't understand why it worked just fine until i changed my hover height. i set it back to what it is was, so i don't know why it's still doing that.

Share this post


Link to post
Share on other sites

I leave the hover slider visible on screen.

Also on some furniture, you have to switch off your AO to sit properly.

Finally......I sometimes use multiple viewers for my alts, and although you might look ok to yourself, others may still see you under the furniture.

Share this post


Link to post
Share on other sites

Avatar height, system shoes, shape hover (the hover in the Edit Shape->Body->Hover), and avatar hover (the right-click hover) all have an effect on how you sit. And there is the furniture's sit position settings too. You can get things looking correct in any ONE instance by adjust any of them. To get things to GENERALLY work in ALL instances requires some finesse. 

So, to get back to where you were, you'll have to put your "hover height", whichever one, back to the previous setting before you started having the problem. Once you have done that look at the other settings and especially look at whatever you wore that caused you to need to change your hover height.

Assume that however you previously changed your hover height wasn't the best way. The drastic amount you need to adjust has me thinking you adjusted the shape hover. I keep that value at 50, the neutral no adjustment default. This is a very coarse adjustment and is meant to adjust hover across all outfits. It is not generally the best hover to adjust.

If the problem is related to a specific outfit, you can make a system shoe or set shape hover saved as a shape for that outfit. Otherwise, stick with the right-click Avatar Hover.

 

Share this post


Link to post
Share on other sites
4 hours ago, Nalates Urriah said:

Avatar height, system shoes, shape hover (the hover in the Edit Shape->Body->Hover), and avatar hover (the right-click hover) all have an effect on how you sit. And there is the furniture's sit position settings too. You can get things looking correct in any ONE instance by adjust any of them. To get things to GENERALLY work in ALL instances requires some finesse. 

So, to get back to where you were, you'll have to put your "hover height", whichever one, back to the previous setting before you started having the problem. Once you have done that look at the other settings and especially look at whatever you wore that caused you to need to change your hover height.

Assume that however you previously changed your hover height wasn't the best way. The drastic amount you need to adjust has me thinking you adjusted the shape hover. I keep that value at 50, the neutral no adjustment default. This is a very coarse adjustment and is meant to adjust hover across all outfits. It is not generally the best hover to adjust.

If the problem is related to a specific outfit, you can make a system shoe or set shape hover saved as a shape for that outfit. Otherwise, stick with the right-click Avatar Hover.

 

Is there a way I can reset the hover height? The one I messed with was not in the shape/edit appearance menu, it was the 'right click appearance adjust hover height' one. I wasn't wearing anything different. What happened was that I was made to stand on a spot that had me up against the wall, and my shoes were sinking into the ground because my character is 7'10 and is wearing high heels. They told me 'adjust the hover height' to fix it, so I did, and when I was released from that square I tried putting it back to where I THINK it was, but I might be off slightly, so I have no idea what one it was before unfortunately.

 

I didn't' change the outfit at al before and after these pics 😞

Share this post


Link to post
Share on other sites

I keep my shape edit hover slider set at 50. The other hover slider (the right-click-your-avatar one) should be as close to zero as you can get it - for flat feet. Since you're wearing heels just edit it accordingly so your soles are touching the ground. Rather than right-clicking your avatar you can fine tune quickly using the Firestorm Quick Prefs menu. I currently have mine set to .050 because I'm wearing shoes with a slight heel to them. I fiddle with that hover height setting all the time, since I change shoes a lot.

hover_height.png.eca14f6a048cea17790c24fedf1454bd.png

  • Thanks 1

Share this post


Link to post
Share on other sites

Here's my little dirty trick :D:

hheight.png.5dbc3c375a9a52bb34036767faa2f82b.png

I download the Belleza demo body (well, I actually have the "real deal" - but I suspect that my alt just got the demo, typically her...), and get these four items.

With the "right-click-on-avatar"-hoverheight set so my bare flat feet touches the ground (around 0), I add the one corresponding with the height of the heels/shoe I wear, and saves that in the outfit. Voila, hoverheight basically corresponds with my shoes everytime I change outfits...

outfit.png.7cc9a97d43ec854f29e80476fd841162.png

(I sometimes find that a hoverheight that is perfect in one sim, might be a bit off in another, but that is easily adjusted via the right-click or QuickPrefs. Seems like some floors or skyboxes at some altitudes migh have something to say?)

Share this post


Link to post
Share on other sites
3 hours ago, Rumancekk said:

Is there a way I can reset the hover height?

Skell gave the answer I would give. BelindaN does what I do. I tend to leave the right-click-hover on screen. It is handy for quick and frequent adjustments.

Share this post


Link to post
Share on other sites
20 hours ago, Rumancekk said:

so is there no way to get it back to the way i had it before? i don't understand why it worked just fine until i changed my hover height. i set it back to what it is was, so i don't know why it's still doing that.

Sorry  no clue what is happening there. I change mine all the time as I have some odd boots that I really like and wear often that are OLD and don't conform well to "hover height". I change back with no problem.   

 

If you use Firestorm the hover height is easy to change the the Quick Preferences panel. And somehow my LOD got changed to 3 so happy I pasted that in here :D  Well I missed this was already posted.  

 

image.png.ce523d5917947497604b4392f8d32131.png

Edited by Chic Aeon
adding info

Share this post


Link to post
Share on other sites
15 hours ago, Nalates Urriah said:

Skell gave the answer I would give. BelindaN does what I do. I tend to leave the right-click-hover on screen. It is handy for quick and frequent adjustments.

Yes, I also leave it on the screen all the time.

Share this post


Link to post
Share on other sites

I use Firestorm's Quick Preferences to adjust my hover height almost on the fly.

When I put on a new pair of shoes, I adjust it for walking.

When I sit on something that buries me, or floats me above the cushions, I adjust it again.

Share this post


Link to post
Share on other sites
On 11/11/2019 at 8:25 PM, Rumancekk said:

Is there a way I can reset the hover height? The one I messed with was not in the shape/edit appearance menu, it was the 'right click appearance adjust hover height' one.

Reset this one to default by changing it to zero. This also assumes that the hover height in your shape/edit appearance is set to the default which is 50.

Once you've got both of those set at these defaults, go back to your furniture and sit on it again. Now, when you click the furniture, there should be an "Adjust" option in the menu. Use this to adjust your avatar's height (usually the Z axis) back up to where it should be to make your avatar sit in the correct position.

My guess is that you've previously altered the adjust height in the furniture whilst your hover height was set at something other than zero.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...