Jump to content

music off and crash logging out

You are about to reply to a thread that has been inactive for 1143 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts


I have some problems in these days: i cannot ear music and when i log out, the viewer crashes anytime (even if i reinstalled Firestorm 3 times deleting all old files), so i must close the app with task manager because the viewer is stuck not responding. So it crashes but stays on full screen not responding.

There was bad problems to render any avatar, too. But i fixed it installing original graphic drivers for my video card (NVidia GeForce GTX 1050 Ti) from the installation CD, avoiding any update by Windows (the new generic driver is very bad) and the new NVidia driver downloaded from official web site (because it is not working and the SO crashes, as always). Result: the fps increases (about 60 fps against 15 fps previous).

Usually i use Firestorm and i tried ANYTHING to fix this bug, also reinstalling Firestorm 3 times. So i tried to use LL viewer but the problem got worse. Then i installed Singularity and the problem was the same of Firestorm.

After this first test i understood that the problem is not of SL viewer. I think the the issue is the last update of Win 10. Indeed the graphic drivers was corrupted, at the least for SL. So seems that also the audio drivers are corrupted for streaming radio, but in SL only! Indeed i can ear any streaming radio on web browser. This is really weird.

I tried to connect on SL with my notebook WiFi and there are not problems (except for the fact that it is slow). So i exclude that the router may block traffic vs SL, also because its firewall is disabled. However i reset the router. My PC is connected to router via Ethernet. Could the lan port blocked... for streaming? Mmmm i doubt because it's absurd.

I allowed SL to Windows firewall and to antivirus, allowing Firestorm.exe and also the files slplugin.exe and dullahan_host.exe. Also i opened all ports for SL:

Port    Protocol    Used For
53    UDP and TCP    DNS lookup
80    TCP    Second Life web resources
443    TCP    Second Life web resources/client authentication
3478    UDP    Voice/STUN traffic
3479    UDP    Voice/STUN traffic
5060    UDP    Voice/SIP traffic
5062    UDP    Voice/SIP traffic
12000-29999    UDP    Voice/RTP traffic/Core protocol communication ** (see note below)
12043    UDP and TCP    Capabilities/map services/simulator communication
12046    TCP    Texture downloading
21002    TCP    Voice signaling

7060 TCP Audio Streaming

But i still cannot ear the music on SL.

Obviously i set anything on preferences (streaming music and/or media are enabled in Preferences > Sound & Media > Sounds)...

Last step is the HD format and reinstall all... But if i must make all this job for a stupid issue on SL i'm going mad.

Some suggestion? Thank you.

Edited by Miumiu Yiyuan
Link to comment
Share on other sites

Ok Thank you. Then you need just system info.


Firestorm 6.3.2 (58052) Sep 27 2019 22:41:52 (64bit) (Firestorm-Releasex64) with Havok support

CPU: Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz (2672.73 MHz)
Memory: 12280 MB
OS Version: Microsoft Windows 10 64-bit (Build 18362.418)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 1050 Ti/PCIe/SSE2

Windows Graphics Driver Version:  (the old driver after my downgrade that works better)

OpenGL Version: 4.6.0 NVIDIA 391.3


RestrainedLove API: RLV v3.2.1 / RLVa v2.2.0.58052   (the issue there is also with RLVa disabled)
libcurl Version: libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.8 nghttp2/1.25.0
J2C Decoder Version: KDU v7.10.7
Audio Driver Version: FMOD Studio 2.00.03
LibVLC Version: 2.2.8
Voice Server Version: Vivox 4.9.0002.30313

Some graphic settings (the issue is same also with minimum setting):

Settings mode: Firestorm
Viewer Skin: Firestorm (Grey)
Window size: 1920x1057 px
Font Used: Deja Vu (96 dpi)
Font Size Adjustment: 0 pt
UI Scaling: 1
Draw distance: 408 m
Bandwidth: 2950 kbit/s
LOD factor: 2.625
Render quality: High-ultra (6/7)
Advanced Lighting Model: Yes
Texture memory: 2048 MB (1)
VFS (cache) creation time (UTC): 2019-10-18T10:48:43 
Generated with MSVC version 1800
Lost packets: 0/7.915 (0,0%)
18. oct 2019 07:54:11 SLT


That's all. So i think. 

Edited by Miumiu Yiyuan
Link to comment
Share on other sites


Noticed a detail on Firestorm web site:

Firestorm with BoM!   (What? "With BoM!" ???)

<< The Bakes on Mesh release from Firestorm has been long awaited; apologies for that. This should be considered by all in SL a MAJOR UPDATE, and it is important that all our SL users upgrade to it. This update contains a lot of rendering-related changes from Linden Lab, without which you WILL be running into avatars that look badly broken to you. Even if you don’t intend to use or purchase anything with BoM, you will still need to be able to see BoM items in your viewer. Please take the update. I can assure you we have put this through a rigorous QA process; it’s a great build! >>

So i had a doubt. Even if the version number is same of that one installed... there is this a warning. Then i downloaded again the viewer and cancelled the old installer. I uninstalled Firestorm deleting again all old files. I installed the new Firestorm and logged. I can ear the music now... but i have serious problem with avatars rendering and the viewer is unstable with crashes. If there are no problems with rendering then i cannot ear the music.

Another fail...

Edited by Miumiu Yiyuan
Link to comment
Share on other sites


I have come to the conclusion that the problems are due to something that blocks and slows down the data traffic to the ports used by SL, regardless of the viewer used.

This is because the correct rendering of mesh avatars is very slow. Sometimes it happens that I only render my avatar. Other times it happens that I render all the avatars except mine. As I have already said, sometimes it happens that I render all the avatars but I don't hear the music and vice versa. Only rarely, with the fourth installation of Firestorm, I managed to render the avatars and hear the music, but after three re-log. While with a second avatar I was connected to SL in the same sim using my notebook and my avatar logged in from the PC looked normal looking at it from the notebook. However there are not problems to render the world, except sometime after a teleport. So i must re-log in order to fix. Also if I stop the music it may happen that I cannot switch it back on, or if I teleport in another sim then music turns off, even if there is audio media on in the new sim/parcel. Of course nothing is yet really fixed.

Link to comment
Share on other sites

i have a very similar computer, and I live quite a distance from the USA so my ping time is always quite high

an issue I had with sound when it wasn't working will was to update the driver for my sound card. Then it worked

it does seem tho that your main issue is somewhere on the internet between your router and the servers

SL uses a tonne of DNS requests. A thing we can do is to increase the number of DNS servers our computer can connect to at any one time. Typically our computer uses the DNS server given to us by our ISP - acquire DNS automatically.  Usually we get two: a primary DNS server and an alternative DNS both provided by our ISP.  When our ISP DNS servers come under heavy load then we get time-outed. SL and other programs affected then send another request to the DNS server

by increasing the number of DNS services available to us then when a DNS server makes us wait, our computer then switches the next request to an alternative DNS server. The more alternative DNS servers, the sooner a response when the primary DNS server is stalling

a howto add DNS servers on Windows is here: https://support.opendns.com/hc/en-us/articles/228007207-Windows-10-Configuration

since I added 2 Google and 2 OpenDNS to my 2 ISP DNS servers most of my SL connection issues went away

Link to comment
Share on other sites

Thank you for your reply.

I tried to set the OpenDNS following the instructions in your link. But nothing is changed. I restart the PC and the router, too.

There is a detail to not forgive: the viewer stucks anytime at log out (quitting it with Ctrl+Q or any way). The app do not responding and I must force the quit. I think that this is important, because some functionality of SL are blocked. When we log out the client communicates with server but if the communication is interrupted then the client do not responds freezing.

I suspect a malware in my PC but my antivirus do not find any. I use also other program like "Spybot Search and Destroy" but nothing is detected except cookies.

Edited by Miumiu Yiyuan
Link to comment
Share on other sites

I disabled the voice because I do not use it. But nothing is changed. Perhaps rendering is faster... but i'm not sure. Probably because the objects are in cache.


I tried also other DNS:

TCP/IPv4 > 8:8:8:8 and 8:8:4:4 

And the rendering was too slow.

So I return on previous IPv4 and added IPv6:

TCP/IPv4 > 208:67:222:222  and  208:67:220:220

TCP/IPv6 > 2001:4860:4860::8888  and  2001:4860:4860::8844

Then in command prompt:


Restart PC and router.

Result: rendering faster but still not hearing music.

The OpenDNS web site does not recognize my dns as OpenDNS perhaps because I set IPv6 that have a priority.

Ah... the viewer continues to not respond at log out. But this is not concerning to DNS.

Edited by Miumiu Yiyuan
Link to comment
Share on other sites

Try this. 

1. Click on speaker in Windows taskbar

2. Click on the up-arrow in what comes up from step 1.

3. Examine your options within "Select Audio Device" from step 2. 

4. If you have more than one audio device in step 3, try them all.


I'm not saying that this is your problem or a fix, but it might be.  It has helped me before.  I have a lot of audio devices.

Link to comment
Share on other sites

assuming that we have tried logging in to and out of a variety of regions other than our Home location, and this is happening on every region, and

as you are able to login and run the viewer on your laptop thru the same router/network connect then is the most likely to be an issue with the computer. Either drivers or hardware

after we have tried everything ourselves and is still wonky then we are pretty much left with taking the computer to a PC lab and have a technician look at it


Link to comment
Share on other sites


Ooook... Here we are! The problem seems fixed finally.

Need to install Silverlight because stupid Windows10 excluded it with last update and seems that Microsoft no longer supports it. Also latest version of Chrome.

But it could not be enough as well as in my case...

So need to make another setting.

In Chrome v.45 or later, no solutions are available for this problem. To access a Silverlight page, we must use a browser that supports Silverlight content.

To resolve this issue in Chrome v. 42 to 44. proceed as follows:

  1. In the address bar, type chrome://flags/#enable-npapi.
  2. In the Enable Mac NPAPI, (or Touch Events API) Windows toolbox, click Activate.
  3. Exit and restart Chrome.
  4. Restart PC.

Yes, both settings fix Second Life issue.

Also TCP DNS setting (always better do that if your connection is not with NAT by ISP). Mine is with NAT so this is the reason why DNS changes are useless.

Thank you Microsoft for make us crazy.

Edited by Miumiu Yiyuan
  • Like 1
  • Thanks 1
Link to comment
Share on other sites

  • 5 months later...

Thank you VERY much for all the technical details in this thread. I was having similar problems (screen completely freezing shortly after entering populated/high avatar density sims and trying to cam around to see things). I tried all the usual fixes (drastically lowering graphics settings, moving my cache to a less crowded drive partition, etc.)   This happened on Firestorm and the main SL viewer: there was no difference in performance between the two. Like Miumiu, I suspect the connection. My problem is occurring during the coronavirus pandemic--I saw lots of articles online about how Second Life use is increasing at this time due to all of us being bored out of our skulls. 🙂

What worked for me is the "disable voice"setting  in Preferences > Sounds. This thread is great, it helped me understand why this might be happening.  Thumbs up to you all! 🙂

Link to comment
Share on other sites

Adding more troubleshooting info: I also installed silverlight, using a version of Internet Explorer I keep around for that sole purpose. Things did seem better. But when trying to add a comment about this, the second horrible symptom of these second life freezes occurred: My entire PC and all applications I was trying to use, like my web browser to type this comment, also froze. Alt-tab, ctrl-alt-del to bring up task mgr, none of these "get out of the frozen app" tricks worked. I've hard booted about 12 times today.

So disabling voice didn't solve my problem although it let me function a bit longer in a crowded sim. But why does this frozen connection in Second Life extend to every other application open on my PC, forcing a power down?

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 1143 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...