Jump to content

Recommended Posts

Hello, so im having this continues issue when exporting mesh out of marvelous designer and into blender, my mesh seems to break at areas where my  seam lines are (where the garments were sewed in MD)  

6d4674da0b896de0a7cbf6491cb1c26c.thumb.png.88412c7b1e8d386f2e71e80735241b8c.png

here's a screen capture of my mesh when I imported it into blender, I have asked for help in inworld creator groups but none seemed to know what the issue is exactly, id appreciate any help, thanks in advance. 

Edited by cameelya
attaching a direct pic

Share this post


Link to post
Share on other sites

yes it doesnt exactly brake, but the mesh acts weird at the seamlines as you can see in the pic ive attached above

Share this post


Link to post
Share on other sites

From looking at it in edit mode it looks like you have some kind of modifier on the green edges. I think that’s what you have a problem with right?

Im not quite sure what the green color means. In my settings sharp edges are a cyan color. So it looks like it’s some sort of shading issue you have going on there. Possibly two meshes on top of each other. 

What are your export settings from MD looking like? Can you post that?

Actually, I looked at it in object mode and edit mode a couple more times.

It’s definitely a shading issue. Select the whole object and recalculate the normals. Give that a shot.

Edited by janetosilio
Added something.
  • Thanks 1

Share this post


Link to post
Share on other sites

i just tried flipping normal and this is what I got

ww.thumb.png.91512a8fa5ce58ad2ef5a67a5a1dd49b.png

 

 

 

 

 

 

 

 

 

when I played with some details in MD like particle distance the effect changed of those gray parts where the seam line is but never solved so my guess is that the issue is from MD, here are the settings of my export from MD  

pmd.thumb.png.940e5e1d872e3c156280a4f6233143d1.png

and when I export I often get this message

wmmd.png.462b3294974d97d39d86764496096951.png

but I tried looking into it more but nothing was much of a help 

Edited by cameelya

Share this post


Link to post
Share on other sites

Possibly shading issue is caused by rotated vertex normals?

First image is of a section of your mesh:

1.png.af0b39c4f5dc446d80b0bed511737854.png

 

Next image looks similar ....... The ugly shading in this image was caused by rotating some of the "split normals" .

2.png.328c5bfc07443ed4965670562f41a764.png

 

Check to see if you have auto smooth enabled:

4.thumb.png.33108fedc86a4aded9c564af1efafbe8.png

 

If so, enable Display Split Normals.

The direction of these split normals will be indicated by single pink lines. Zoom in close to a part of your mesh with the possible bad shading and check the direction of the pink lines emanating from the vertices. If they look weirdly rotated compared to their neighbors then that could be the cause of the problem.

In the image below I have marked some of the rotated split normals with red lines. The lines marked in blue are indicating examples of good, unedited split normals.

3a.thumb.png.cce644295d9a5437f264599cfd849266.png

 

If this is how your mesh is looking you could try unchecking the Auto Smooth option and see how that effects the shading.

 

2 hours ago, janetosilio said:

Im not quite sure what the green color means.

I had to look it up, the green lines indicate  edges that have been marked as Free Style edges.  Edge > Mark Freestyle Edge. I don't know what that means :)

 

Edited by Aquila Kytori
  • Thanks 1

Share this post


Link to post
Share on other sites

oh thank you, but any idea how to fix this on blender tho 

nvm I found it and it worked!!! 

thank you so much guys ive been struggling with this for sometime and no one knew what the issue was

you've actually made my day!

Edited by cameelya

Share this post


Link to post
Share on other sites
11 minutes ago, cameelya said:

nvm I found it and it worked!!!

For future reference, (It may help other people), can you confirm that when you dis activated  the Auto Smooth  option that fixed the issue or was it something else that you found?

Edited by Aquila Kytori
  • Like 1

Share this post


Link to post
Share on other sites

yes it got fixed when I unchecked the "Auto Smooth", but I wasn't sure where to find that button at first, so here's a shot to show where I found it in blender 2.79

ssbf.thumb.png.035225032c1c25bb530dfaa79f7686fe.png

Edited by cameelya
  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks.

It never occurred to me that you were using 2.79   :)

Next time try to insert your images directly into your post. That way others will find it easier to solve similar issues :)

Share this post


Link to post
Share on other sites
On 9/16/2019 at 4:24 PM, Aquila Kytori said:

Thanks.

It never occurred to me that you were using 2.79   :)

Next time try to insert your images directly into your post. That way others will find it easier to solve similar issues :)

Well, should be safe to assume most will still be on 2.79 as it's been the main version of blender for the last few years, and with the rather drastic change of UI 2.8 has, some will probably still prefer working in 2.79 till they get better acquainted with 2.8.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...