Jump to content

Recommended Posts

For the past month now, I have had a huge problem. I will import a house which is 33 land impact. The second I try and resize it, or put a door script in it, or link a prim too it, it jumps to 110 land impact. The house itself is only 35 prims. This has happened on the past 3 houses I have imported. I have never had this issue in the past. I am using the same tools to create the houses, add physics, the same door script... the same everything. Yet the past few houses have done this. The triangle count is low, the hulls are low. I don't understand what is causing this, and what I can do to fix this. Any ideas?

Share this post


Link to post
Share on other sites

I'm guessing it's the physics model that is the problem - your analysed physics is 116 as opposed to the base hull of 23. It's likely that your land impact is soaring when you switch your build from "convex hull" to "prim". I know I've read a page or discussion that explains it better than I can...I'll see if I can find it.

 

This is one of the discussions I was thinking about...hopefully it can help, or if not, that a better mesh maker than I can suggest something.

Good luck!

Edited by Peony Sweetwater
Found it!

Share this post


Link to post
Share on other sites

Turning it to prim seems to be fine, only the base parts are prim. The rest is set to "none". I don't use the convex hull. Its when I resize or add a script or add a prim. I have tried using SL, Firestorm, and Alchemy browsers.... all the same. Your post you linked helped. Thank you!

Share this post


Link to post
Share on other sites
4 hours ago, Jenny Ashland said:

For the past month now, I have had a huge problem. I will import a house which is 33 land impact. The second I try and resize it, or put a door script in it, or link a prim too it, it jumps to 110 land impact. The house itself is only 35 prims. This has happened on the past 3 houses I have imported. I have never had this issue in the past. I am using the same tools to create the houses, add physics, the same door script... the same everything. Yet the past few houses have done this. The triangle count is low, the hulls are low. I don't understand what is causing this, and what I can do to fix this. Any ideas?

Peony is correct.  It is your physics model which in NO WAY should be 116 as your upload chart says it will be.    And your house physics shouldn't be set to "none" unless your are a venue like Hair Fair. I mean walls should be walls  LOL.

 

Maybe this will help some.    Woot. I am number one on Google  LOL. This is Blender 2.79 and below but if you are using 2.8 the IDEA is the same.

 

https://www.youtube.com/watch?v=g6SJjFc4P_k

 

Share this post


Link to post
Share on other sites

The house itself is more or less phantom... Using none lets you keep it phantom and linked... The walls, floors, ceilings and such I save duplicated, and use those as the physics, which are prim. After reading the other thread I am going to try a different import then this. Instead of saving it separate I am just going to use the whole bloody house as physics. At least then I will get a more accurate land impact when I import. Thank you guys so much for your answers. 

Share this post


Link to post
Share on other sites

That is a terrible idea, using same mesh for physic and definitely not what was suggested....Physic model should be much much simpler, basically determining outer boundaries of mesh shape as well as collidable surfaces 

Share this post


Link to post
Share on other sites

I found out the problem. I recently changed my architectural program to the metric system, rather then imperial, which caused the houses to be a lot larger when bringing them in. After some tweaking I fixed the problem

The architectural program I use to make the houses, puts a sheathing on the house, kinda like a shell. I use this for the Physics. I took it out of the house and put it beside it, in the pics. It is very simplistic. in world I set it to invisible, so all you see is the house set at none.

 

27adcfc900fed6dae0e861c7ddb7a586.png

d58451e8a015b3357bddb45f49ca86d4.png

Share this post


Link to post
Share on other sites

Glad you worked out what was going wrong.

Out of interest, what are the benefits to making the physics a separate object rather than using the simplified model as the mesh’s physics?

 

Share this post


Link to post
Share on other sites

I can pick the pieces individually, but that usually winds up being more prims, and more physics. The shell, is just a simple basic mesh that is one piece. I can't use the whole structure, because some stuff is to complex, like the light in the drawing. It makes it stupid primy. Stuff like molding or friezes around the house don't need to be prim, so they have to be set to none (phantom), or else you get stuck in the house. 

13aeb42422775c3406e928704279678e.png

Share this post


Link to post
Share on other sites
5 hours ago, Peony Swee*****er said:

Glad you worked out what was going wrong.

Out of interest, what are the benefits to making the physics a separate object rather than using the simplified model as the mesh’s physics?

 

The simplified model is almost always inadequate and trash. I kinda wish they would just remove that feature from the uploader as it never produces good results.

Share this post


Link to post
Share on other sites

I have come to the conclusion that there is definitely something wrong with mesh uploading in SL. There is no reason in the world this structure should be 43 land impact. Its not a huge structure, it has no curves, the physics are very basic... So where is 43 land impact coming from?!?! I get the same thing in the SL viewer... Something is not right....

764f70ec22e3cb519a902ee4043624be.png

ee0b421a68376f1aa4bb35567f28036b.png

Edited by Jenny Ashland
add pic

Share this post


Link to post
Share on other sites
13 hours ago, Jenny Ashland said:

So where is 43 land impact coming from?!?!

Unlink the object, and check each part for it's download weight. Then you see which ones the most expensive are. Since you upload a group of individual objects all at once, and just use the automatic LOD generator of the viewer for all of them (at once), I can imagine that some pieces are heavier on their low/lowest LOD than they should/could be.

Making all custom LODs for all pieces (that's what I always do), or uploading each part individually with appropriate triangle settings should make a difference.

Edited by arton Rotaru

Share this post


Link to post
Share on other sites
On 9/11/2019 at 2:16 PM, Jenny Ashland said:

It really is... you wind up with doors holes you can't walk through, and stuck in corners. Doesn't matter what you set it on. I have tried all the ways...

I almost wish LL would just remove this feature and just force you to supply your own collision mesh.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...