Jump to content
Prokofy Neva

SL Version Checker?

Recommended Posts

I see this all the time now as an error -- but I never heard of it and I swear it wasn't there before. It's even an exe file.

Why is it even needed? What, LL's servers can't themselves tell what version is logging on without having to put files on your computer to do this?

Share this post


Link to post
Share on other sites

It was introduced a couple versions ago. When you launch SL it launches the version-checker, if your version is current then it launches the SL app proper. Otherwise it initiates a download of any new version then launches the SL app proper. If you are still using an old Alias or Shortcut that launches the SL app proper you may be getting an error or continuously getting update notifications.

Use any Alias (Mac) or Shortcut (Windows) that the installer creates for you from now on and you'll be all set.

  • Like 2

Share this post


Link to post
Share on other sites
On 8/11/2019 at 1:09 AM, Prokofy Neva said:

Why is it even needed? What, LL's servers can't themselves tell what version is logging on without having to put files on your computer to do this?

It allows downloads for optional upgrades to happen in the background so that you don't get prompted about the upgrade until the file is ready to be installed.

More importantly, it is a 32bit application so that it can check whether or not your system is compatible with the 64bit viewer (a test that's not as simple as whether or not it can run 64bit apps, since some video systems are not supported in the 64bit Windows). By doing that test, it can ensure that no matter which build of the viewer you start with you end up installing one that should work on your system.

  • Like 5

Share this post


Link to post
Share on other sites

@WhirlyFizzle I have had dozens of error messages saying "Fatal Error! SL Version Checker" - something like that. I'll try to capture it when it happens again.

@Oz So if I unchecked getting automatic downloads and only want them on demand, why is it still doing this in the background

I totally get it that you need to distinguish between 32bit and 64bit. But after all, we did this before, for years, by looking at what our system was and choosing the correct SL download. And as far as know, it didn't work otherwise.

And if SL is offering me a download when I log-on mandatorily (again, I thought I had unchecked "automatic" but maybe it fell out after so many re-installs), wouldn't it already know whether I had 32bit or 64bit?

I mention this merely because it's one more layer of stuff in the struggles to get logged on. So I wanted to find out more about it so I could shut it off possibly. The reason I don't opt to have the candidate viewers or optional downloads as I used to enthusiastically because my log-on is so fragile now, it takes dozens of times to get logged on. Apparently the diagnosis for this now is inventory files (which Lindens now re-sort for you) but that's not a total explanation.

  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, Prokofy Neva said:

wouldn't it already know whether I had 32bit or 64bit?

Even if the program wrote a little text file saying 32/64, LL would then add some code to the viewer to check for that file and its contents.

Even if they did that, a system can change drastically from one login to the next, like if the user swaps their graphics card, or the viewer is installed on an external drive and plugged into a different machine.

It's an extra point of failure just to make it "remember." It's easier, simpler, and safer to just make a new check each time.

In your specific case it might not be needed, but code is rarely tailored for individuals.

  • Like 2

Share this post


Link to post
Share on other sites
On 8/13/2019 at 11:48 PM, Prokofy Neva said:

I totally get it that you need to distinguish between 32bit and 64bit. But after all, we did this before, for years, by looking at what our system was and choosing the correct SL download. And as far as know, it didn't work otherwise.

"years" is a wee bit of an exaggeration given the 64bit version has only been an option since January of 2018. Any choice being made over the "years" would have been platform. 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...