Jump to content

Recommended Posts

11 minutes ago, Diawa Bellic said:

NOT THE TP CRASH BUG AGAIN?

that would be more than annoying - anyone else expiriencing this?

Share this post


Link to post
Share on other sites

Since two or three days. You try to tp, get a message like "your destination cannot be found" and then you're unable to tp anywhere until you relog. After relog you have been resetted to the place you logged in at the beginning of your session, not the place where you already disconnected. Crossing sim borders works smoothly.
-experienced with firestorm  and win10, newest version -

Share this post


Link to post
Share on other sites

Less ubiquitous than at its height, but I've been having it more frequently in the last few days. Cannot teleport to destination, then TP is locked, then disconnect, or log out manually before that.

On relog Last Location is a few TPs prior to the disconnect, and while my outfit is the same as when I disconnected, any recently edited scripts in my attachments and any data they had saved in object descriptions have reverted.

Share this post


Link to post
Share on other sites

Yes, I have experienced this TP crash again over the past week or so. Also happening with physical region crossings. All reminiscent of a month or so ago when it was happening with every TP or crossing. It got better for a while but lately it has become annoying the few times it has happened.

Share this post


Link to post
Share on other sites

We are very interested in hearing about TP problems, but it will be far far more useful if you report all of the following:

  • When it happened; this doesn't have to be exact - within a few minutes is plenty accurate. Tell us what time zone you're using (SLT is easiest for us)
  • Where were you when you tried to TP?
  • Where were you trying to go?  (region names is all we normally need for start and end locations)
  • If you ended up somewhere else, where was it?
  • Were you disconnected or did you crash?  If the viewer window disappears with no message, you crashed; if not, you were disconnected.
  • What viewer were you using? (copy the information from Help > About Second Life)

It's easiest for us if you report those in jira, but contrary to what some people think we do watch the forums.

This issue is a very very high priority for us right now, so we really will use reports we get, but none of the above is enough for us to learn anything from. If what you want to do is just vent your frustration by all means go ahead, but if you'd like to contribute to solving the problem we need the information above.

  • Like 4

Share this post


Link to post
Share on other sites
Posted (edited)

Will do, @Oz Linden. Is stuff like location at relog to last location, state of scripts and script-saved data useful or relevant? For instance, there's stuff like time and region I could have my HUD scripts save to an object description and report on relog, highlighting any differences.

Maybe you guys could publish a script  (maybe a variation of that TP tour thing one of you did recently) that we could add to a HUD, that made a note of anything useful you'd like to know.

Also, what words or phrases do you prefer to see when users are venting?

Edited by KT Kingsley
  • Haha 1

Share this post


Link to post
Share on other sites
25 minutes ago, KT Kingsley said:

Is stuff like location at relog to last location, state of scripts and script-saved data useful or relevant?

Bad effects on scripts may be relevant (or may be bugs in the scripts... hard to say), so it's fine to include it.

Subsequent login attempts, regardless of where they are, are not part of the base problem we're most interested in right now.

Share this post


Link to post
Share on other sites
1 minute ago, Oz Linden said:

Bad effects on scripts may be relevant (or may be bugs in the scripts... hard to say), so it's fine to include it.

Subsequent login attempts, regardless of where they are, are not part of the base problem we're most interested in right now.

In my case the bad effects on scripts have been that those I've edited (whilst worn, and not subsequently detached and reattached) shortly (in terms of the number of TPs rather than time) before the TP failure have reverted to their pre-failure code. As has data written to the object description field. It's one of a number of scripts I use constantly (as part of my always and everywhere HUD) without issues, and on relog after a TP failure the data recovered from that object description refers to a situation a while before the failure rather than that at the time of failure.

Share this post


Link to post
Share on other sites
Posted (edited)

Well bummer - looks like it's back - not as frequent as before though.

  • When it happened; just now  around 2:25 am
  • Where were you when you tried to TP? good idea - I wish I knew exactely
  • Where were you trying to go?  Serena Pisces
  • If you ended up somewhere else, where was it? got disconnected from SL
  • Were you disconnected or did you crash?  see above
  • What viewer were you using?

Firestorm 6.0.2 (56680) Feb  8 2019 23:11:19 (64bit) (Firestorm-Releasex64) with OpenSimulator support
Release Notes

You are at 86.6, 129.2, 21.2 in Serena Pisces located at sim10162.agni.lindenlab.com (216.82.49.28:13022)
SLURL: http://maps.secondlife.com/secondlife/Serena Pisces/87/129/21
(global coordinates 309335.0, 292993.0, 21.2)
Second Life RC Magnum 19.06.14.528215
Release Notes

CPU: AMD FX(tm)-8350 Eight-Core Processor (1422.16 MHz)
Memory: 32066 MB
OS Version: Linux 4.15.0-54-generic #58-Ubuntu SMP Mon Jun 24 10:55:24 UTC 2019 x86_64
Graphics Card Vendor: X.Org
Graphics Card: Radeon RX 570 Series (POLARIS10, DRM 3.26.0 AMD 18.30 , 4.15.0-54-generic, LLVM 6.0.1)

OpenGL Version: 3.1 Mesa 18.1.0-rc4

RestrainedLove API: (disabled)
libcurl Version: libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.8 nghttp2/1.25.0
J2C Decoder Version: KDU v7.10.6
Audio Driver Version: FMOD Studio 1.10.10
Dullahan: 1.1.1080 / CEF: 3.3325.1750.gaabe4c4 / Chromium: 65.0.3325.146
LibVLC Version: 2.2.3
Voice Server Version: Vivox 3.2.0002.10426

Settings mode: Firestorm
Viewer Skin: AnsaStorm (Bright Blue)
Window size: 1358x687 px
Font Used: Deja Vu (96 dpi)
Font Size Adjustment: 0 pt
UI Scaling: 1
Draw distance: 32 m
Bandwidth: 750 kbit/s
LOD factor: 1.5
Render quality: Low (1/7)
Advanced Lighting Model: No
Texture memory: 768 MB (1)
VFS (cache) creation time (UTC): 2018-1-30T10:47:42 
Built with GCC version 40902
Packets Lost: 19/2732 (0.7%)
July 12 2019 02:29:25 SLT

Edited by Fionalein

Share this post


Link to post
Share on other sites

I did notice some issues TP-ing between two certain sims in the past week always around 3:30 pm slt 

  • Where were you when you tried to TP? Anati 
  • Where were you trying to go?  Jieut
  • If you ended up somewhere else, where was it? Map location showed neighboring parcel in sim not mine but when i next logged in i started where i'd tried to TP to
  • Were you disconnected or did you crash?  Disconnected
  • What viewer were you using? Firestorm 6.0.2 (56680) Feb  9 2019 16:38:49 (32bit) (Firestorm-Release) with OpenSimulator support

Share this post


Link to post
Share on other sites
On 7/12/2019 at 2:48 AM, KT Kingsley said:

In my case the bad effects on scripts have been that those I've edited (whilst worn, and not subsequently detached and reattached) shortly (in terms of the number of TPs rather than time) before the TP failure have reverted to their pre-failure code. As has data written to the object description field. It's one of a number of scripts I use constantly (as part of my always and everywhere HUD) without issues, and on relog after a TP failure the data recovered from that object description refers to a situation a while before the failure rather than that at the time of failure.

has been my experience that this has always been the case and not necessarily something new.  The state of edited attachments has always been murky when we don't detach or log out safely  after doing an edit while wearing the attachment.  Prim property edits as well as script edits. Happens sometimes (but not always) when change our prim/mesh hair texture while worn for example.  Don't detach and reattach. Teleport. Crash. Relog. Hair texture is the previous

i dunno exactly as not privy to the server code. Just from observation it seems to be some kinda cache flushing issue.  It seems that our edits are cached pending some permanent storage update flush process. Detaching seems to flush (save) the cache to permanent storage.  When we don't detach and the cache hasn't yet been flushed, then on crash and relog then the cache entry is no longer available and the object is restored from permanent 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
15 hours ago, Mollymews said:

i dunno exactly as not privy to the server code. Just from observation it seems to be some kinda cache flushing issue.  It seems that our edits are cached pending some permanent storage update flush process. Detaching seems to flush (save) the cache to permanent storage.  When we don't detach and the cache hasn't yet been flushed, then on crash and relog then the cache entry is no longer available and the object is restored from permanent 

it's a feature - think of it as "last ditch undo"

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Nikira Naimarc said:

I was logged off too by teleport this day. I wrote a JIRA.

Niki

Ditto - Just did a TP from HILTED region, trying to TP back home, and the client totally closed.  No error or crash message, though there is a dump directory containing a dump file and a few log files in the Firestorm appdata location.

 

Note that that is the first TP issue I've had since the major issue quite a while back.

Edited by LittleMe Jewell

Share this post


Link to post
Share on other sites
Posted (edited)
  • When it happened; just now around 4:15pm
  • Where were you when you tried to TP? mishmish
  • Where were you trying to go? limbo
  • If you ended up somewhere else, where was it? got disconnected from SL with a black screen could have been anywhere
  • Were you disconnected or did you crash?  see above
  • What viewer were you using? Firestorm 6.0.2 (56680) Feb  8 2019 23:11:19 (64bit) (Firestorm-Releasex64) with OpenSimulator support

PS: As a funny side effect the list of friends I can see online was cropped in that incident and has not recovered since - maybe only in so far related as that phenomenon might get caused by the disconnects in a chain reaction.

Edited by Fionalein

Share this post


Link to post
Share on other sites
Posted (edited)

Hello:

The same thing has been happening to me for the last two or three days as well, after a long period with no issues (when the previous TP bug was fixed). It's happened several times, from/to different regions, and always leading to a disconnect after the tp fails. Here's the info about the last one:

  • When it happened; this doesn't have to be exact - Saturday, July 13, 8:40 pm, SLT
  • Where were you when you tried to TP? - Tempura
  • Where were you trying to go?  - Mirromere
  • If you ended up somewhere else, where was it?: - n/a
  •  Were you disconnected or did you crash?  If the viewer window disappears with no message, you crashed; if not, you were disconnected. - I was disconnected
  • What viewer were you using? (copy the information from Help > About Second Life) - Firestorm 5.1.7 (55786) Jul 13 2018 20:00:04 (64bit) (Firestorm-Releasex64) with Havok support
Edited by LoryInfinity52

Share this post


Link to post
Share on other sites
16 hours ago, LittleMe Jewell said:

Ditto - Just did a TP from HILTED region, trying to TP back home, and the client totally closed.  No error or crash message, though there is a dump directory containing a dump file and a few log files in the Firestorm appdata location.

 

Note that that is the first TP issue I've had since the major issue quite a while back.

If you can zip up that dump folder from the crashed session & send to me at whirly.fizzle at phoenixviewer dot com I can tell you why you crashed.

  • Thanks 2

Share this post


Link to post
Share on other sites
19 hours ago, LittleMe Jewell said:

Ditto - Just did a TP from HILTED region, trying to TP back home, and the client totally closed.  No error or crash message, though there is a dump directory containing a dump file and a few log files in the Firestorm appdata location.

 

Note that that is the first TP issue I've had since the major issue quite a while back.

Got the dump thanks.
Yours was a crash when entering the new region, rather then a disconnect.

This crash should (I hope) be fixed in the next FS release with this fix we pulled in from LL: https://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/6b753a247e1b

This Octree crash has nothing to do with any server changes made by LL.

STACK

Operating system: Windows NT
                  10.0.17134 
CPU: amd64
     family 6 model 158 stepping 10
     12 CPUs

Crash reason:  EXCEPTION_STACK_OVERFLOW
Crash address: 0x7ffc745322ca
Process uptime: not available

Thread 0 (crashed)
 0  msvcr120.dll + 0x22ca
 1  msvcp120.dll + 0x3cdc5
 2  msvcp120.dll + 0x3cf80
 3  Firestorm-Releasex64.exe!LLMutex::trylock() [llmutex.cpp : 121 + 0xa]
 4  Firestorm-Releasex64.exe!LLError::Log::out() [llerror.cpp : 1241 + 0x1a]
 5  Firestorm-Releasex64.exe!LLOctreeNode<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 439 + 0xad]
 6  Firestorm-Releasex64.exe!LLOctreeRoot<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 860 + 0xc]
 7  Firestorm-Releasex64.exe!LLOctreeNode<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 449 + 0xc]
 8  Firestorm-Releasex64.exe!LLOctreeRoot<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 860 + 0xc]
 9  Firestorm-Releasex64.exe!LLOctreeNode<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 449 + 0xc]
10  Firestorm-Releasex64.exe!LLOctreeRoot<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 860 + 0xc]
11  Firestorm-Releasex64.exe!LLOctreeNode<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 449 + 0xc]
12  Firestorm-Releasex64.exe!LLOctreeRoot<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 860 + 0xc]
13  Firestorm-Releasex64.exe!LLOctreeNode<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 449 + 0xc]
14  Firestorm-Releasex64.exe!LLOctreeRoot<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 860 + 0xc]
15  Firestorm-Releasex64.exe!LLOctreeNode<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 449 + 0xc]
16  Firestorm-Releasex64.exe!LLOctreeRoot<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 860 + 0xc]
17  Firestorm-Releasex64.exe!LLOctreeNode<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 449 + 0xc]
18  Firestorm-Releasex64.exe!LLOctreeRoot<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 860 + 0xc]

   <SNIP Hundreds of line of the same octree barf>

786  Firestorm-Releasex64.exe!LLOctreeNode<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 449 + 0xc]
787  Firestorm-Releasex64.exe!LLOctreeNode<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 449 + 0xc]
788  Firestorm-Releasex64.exe!LLOctreeRoot<LLViewerOctreeEntry>::insert(LLViewerOctreeEntry *) [lloctree.h : 860 + 0xc]
789  Firestorm-Releasex64.exe!LLSpatialPartition::put(LLDrawable *,int) [llspatialpartition.cpp : 1005 + 0xe]
790  Firestorm-Releasex64.exe!LLSpatialPartition::move(LLDrawable *,LLSpatialGroup *,int) [llspatialpartition.cpp : 1077 + 0xe]
791  Firestorm-Releasex64.exe!LLDrawable::movePartition() [lldrawable.cpp : 783 + 0x1b]
792  Firestorm-Releasex64.exe!LLVOAvatar::idleUpdateMisc(bool) [llvoavatar.cpp : 2936 + 0x6]
793  Firestorm-Releasex64.exe!LLVOAvatar::idleUpdate(LLAgent &,double const &) [llvoavatar.cpp : 2674 + 0xd]
794  Firestorm-Releasex64.exe!LLViewerObjectList::update(LLAgent &) [llviewerobjectlist.cpp : 1063 + 0x10]
795  Firestorm-Releasex64.exe!LLAppViewer::idle() [llappviewer.cpp : 5688 + 0x13]
796  Firestorm-Releasex64.exe!LLAppViewer::doFrame() [llappviewer.cpp : 1694 + 0x8]
797  Firestorm-Releasex64.exe!LLAppViewer::frame() [llappviewer.cpp : 1563 + 0x5]
798  Firestorm-Releasex64.exe!WinMain [llappviewerwin32.cpp : 396 + 0x9]
799  Firestorm-Releasex64.exe!__tmainCRTStartup [crtexe.c : 618 + 0x15]
800  kernel32.dll + 0x14034
801  ntdll.dll + 0x73691
802  KERNELBASE.dll + 0xebc30

 

  • Thanks 1

Share this post


Link to post
Share on other sites
7 hours ago, Whirly Fizzle said:

Got the dump thanks.
Yours was a crash when entering the new region, rather then a disconnect.

This crash should (I hope) be fixed in the next FS release with this fix we pulled in from LL: https://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/6b753a247e1b

This Octree crash has nothing to do with any server changes made by LL.

 

Thank you  

  • Like 2

Share this post


Link to post
Share on other sites

Hey everyone,

We've gotten some very helpful reports so far; in order to further narrow down the problem's exact cause it would be really helpful if someone who files a future bug report in Jira regarding this issue could include their viewer logs for the session where they got disconnected on teleport.

  • Thanks 2

Share this post


Link to post
Share on other sites

Hello,

the day before yesterday I had the teleport problem again after weeks the first time.

Yesterday I did more than 50 teleports in a row (sometimes numerous teleports in a minute, it depends how many scans are to do)  for Bloodlines scan achievement without any problem.

Today I logged in first time @Bloodlines East and did some teleports for Bloodlines scan achievement again (see attachment) and at House of V @Chained Desires http://maps.secondlife.com/secondlife//117/161/68 I got an error message that I can't teleport to the next destination JAMAICA XXX  My Favorite Beach @Tribalia, http://maps.secondlife.com/secondlife/Tribalia/203/241/21 .

I tried to teleport 2 times again. One to Jamaica Beach at @Tribalia and one to Mama Allpa Mainstore @Mama Allpa  http://maps.secondlife.com/secondlife/Mama%20Allpa/149/18/3502.

Then I were logged out.

The next login I were logged in @Bloodlines East again at the same point I logged in first time today. 

 

Operating system:
Linux Mint 19.1

Viewer, driver and hardware informations:
Firestorm 6.2.4 (57588) Jul 11 2019 22:29:54 (64bit) (Firestorm-releasex64)
You are at 152.1, 15.5, 3502.0 in Mama Allpa located at sim10666.agni.lindenlab.com (216.82.53.28:13010)

SLURL: http://maps.secondlife.com/secondlife/Mama%20Allpa/152/16/3502
(global coordinates 213656.0, 248336.0, 3502.0)
Second Life Server 19.06.14.528215

CPU: Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz (4300.78 MHz)
Memory: 32107 MB
OS Version: Linux 5.0.0-20-generic #21~18.04.1-Ubuntu SMP Thu Jun 27 04:04:37 UTC 2019 x86_64
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce RTX 2070/PCIe/SSE2

OpenGL Version: 4.6.0 NVIDIA 430.26

RestrainedLove API: RLV v3.2.1 / RLVa v2.2.0.57588
libcurl Version: libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.8 nghttp2/1.25.0
J2C Decoder Version: KDU v7.10.7
Audio Driver Version: FMOD Studio 2.00.01
Dullahan: 1.1.1320 / CEF: 3.3626.1895.g7001d56 / Chromium: 72.0.3626.121
LibVLC Version: 2.2.3
Voice Server Version: Not Connected
Settings mode: Firestorm
Viewer Skin: Firestorm (High Contrast)
Window size: 3840x2105 px
Font Used: Deja Vu (96 dpi)
Font Size Adjustment: 0 pt
UI Scaling: 2
Draw distance: 120 m
Bandwidth: 1000 kbit/s
LOD factor: 3.5
Render quality: Ultra (7/7)
Advanced Lighting Model: Yes
Texture memory: 2048 MB (1)
VFS (cache) creation time (UTC): 2019-7-19T10:22:36
Built with GCC version 40902
Packets Lost: 190/199527 (0.1%)
July 19 2019 04:17:24 SLT

 

 

Teleport History Ehawee2016 2019-07-19 12-54-14.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...