Jump to content
Pixels Sideways

Option/Alt key to zoom not working on Mac

You are about to reply to a thread that has been inactive for 103 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hiya.

After the last update  Second Life Release 6.2.0.526104 (64bit)  when I try to zoom in using my mouse and the Option Alt key, the camera zooms rapidly far out and spins and will not zoom in at all as it always has done.

Is this a bug in the the viewer or something I may have inadvertently done to change the key command?  

It is making camming in SL - especially for content creation - difficult at best.

I've never experienced this issue in all my years in SL on PC's or the MacBook.

Thank you!

 

Edited to add the SL Viewer update is the EEP version:

http://wiki.secondlife.com/wiki/Release_Notes/Second_Life_Release/6.2.0.526104

 

 

Edited by Pixels Sideways
added info

Share this post


Link to post
Share on other sites

Do you have a Retina Display Mac? If not, then try turning off the HDD checkbox in settings (High Definition Display). 

Well, even if you do have a Retina Display Mac, try turning it off anyway. LOL

  • Like 1

Share this post


Link to post
Share on other sites

Oh, no - settings preferences in the Viewer - if you do not have Retina Display Mac- then you need to turn this OFF (Graphics Settings: Advanced):

Screen Shot 2019-04-16 at 6.07.13 PM

This is a new feature that takes advantage of the Retina Display on the newer Mac (and it makes SL look AMAZINGLY GORGEOUS) - LOL BUT, for non-Retina Display Mac it causes that alt-click-glitch you describe. So turning this off *should* fix that.

Edited by Alyona Su
  • Like 2

Share this post


Link to post
Share on other sites

ahhhhh...  🙂

I unchecked the HDPI box as you noted, restarted and unfortunately that did not fix the problem.  

Any other thoughts on what might be causing this?

 

 

 

 

Share this post


Link to post
Share on other sites

I can only suggest you try an alternate trackpad or mouse if you have one, other than that you may be to contact support because the issue is definitely at your end (most likely some setting in the viewer) as I know a lot of Mac users and only one, maybe two other people who complained of the same thing. A Linden replied suggesting what I suggested to oy and it apparently fixed their issue.

Maybe take a close look at all settings, especially anything that has to do with mouse/trackpad and clicking, scrolling, etc.

  • Like 1

Share this post


Link to post
Share on other sites
On 4/16/2019 at 8:22 PM, Alyona Su said:

Do you have a Retina Display Mac? If not, then try turning off the HDD checkbox in settings (High Definition Display). 

Well, even if you do have a Retina Display Mac, try turning it off anyway. LOL

Is this possible in Firestorm? Or only in the LL viewer?

 

Share this post


Link to post
Share on other sites
15 hours ago, livb89 said:

Is this possible in Firestorm? Or only in the LL viewer?

 

This is an LL Viewer feature (and it looks amazingly gorgeous when turned on - Windows can't even come close, much less touch it) - I imagine Firestorm, Catznip (if they ever finally release a macOS version,) Kokua and the rest will implement the technology when they are able or, at least, they'd be smart to do so.

  • Like 1

Share this post


Link to post
Share on other sites
15 hours ago, livb89 said:

Is this possible in Firestorm? Or only in the LL viewer?

 

It will be in the next Firestorm release.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Alyona Su said:

This is an LL Viewer feature (and it looks amazingly gorgeous when turned on - Windows can't even come close, much less touch it) - I imagine Firestorm, Catznip (if they ever finally release a macOS version,) Kokua and the rest will implement the technology when they are able or, at least, they'd be smart to do so.

Oh OK. The reason I asked is because it looks as though Firestorm on my retina Macbook Pro is already using the full display resolution. I mean... if I take a screenshot with Firestorm full screen it is 3360 × 2100 and the text looks pretty sharp. Maybe I am wrong.

I was actually looking see if I could turning the Hi DPI setting *off* in order to see if I could get a better frame rate. While SL looks great on my retina display I struggle to get about 10 FPS in some places, where my partner who has a 1920x1080 72 dpi display on a PC gets more like 20 FPS at the same place. There are other factors... mine is a laptop so not the best graphics card. But I was just experimenting with performance generally.

(And yes i know about changing other graphics settings like draw distance, max complexity, and shadows, reflections and so on - I already have presets)

Share this post


Link to post
Share on other sites
48 minutes ago, livb89 said:

Oh OK. The reason I asked is because it looks as though Firestorm on my retina Macbook Pro is already using the full display resolution. I mean... if I take a screenshot with Firestorm full screen it is 3360 × 2100 and the text looks pretty sharp. Maybe I am wrong.

I was actually looking see if I could turning the Hi DPI setting *off* in order to see if I could get a better frame rate. While SL looks great on my retina display I struggle to get about 10 FPS in some places, where my partner who has a 1920x1080 72 dpi display on a PC gets more like 20 FPS at the same place. There are other factors... mine is a laptop so not the best graphics card. But I was just experimenting with performance generally.

(And yes i know about changing other graphics settings like draw distance, max complexity, and shadows, reflections and so on - I already have presets)

Firestorm does not show at retina display resolutions (I can see an actual difference between FS and LL on MacBook Pro) - as for frames per second - start with LL viewer. FS is a pig-in-a-poke the way I see it - it's performance is definitely lower than LL viewer in every experience I have had. If you NEED RLVa function, try Kokua viewer first.

SETTINGS: Turn your settings DOWN. It amazes me how many people whine about lag and low FPS and the rest, and they have their setting cranked up too high. You have a choice of priorities, but you cannot have both: Performance or Eye-candy features.

I have a mid-2018 MacBook Pro (4-core), and SL runs fantastic on it. Especially in the LL viewer and even FS runs better on that than my PC (GAWD I wish Catznip would come out with the macOS version because it outperforms *EVERY* other TPV, especially FS). Also remember, if you turn HiDPI on - it effectively triples your resolution without resizing your viewer (this is why it looks so freaking amazing).

MY settings are (basically)

  • Bandwidth: 1000-1200
  • Cache 2048 (fast Internet is faster than reading cache)
  • Draw Distance 256 (Preset called "Main" with Advanced Lighting ON)
  • Draw Distance 256 (Preset called "ALT" with Advanced Lighting OFF - instant double frame-rate)
  • (and a preset to 128 and near zero settings and Advanced Lighting OFF for crowds and events)
  • Set water reflections to Static Objects (no need for more unless snapshotting)
  • Set Shadows to Sun and Moon only (or NONE; Projectors do what Advanced Lighting does: kills FPS)
  • Non-Avatar Imposters 8 (Set this way down!)
  • LOD 2.0 (Seriously - set it to 2.0, LL default is like 1.25 or something, either way: it 2 or less)
  • If using Firestorm (I'm Sorry) turn off unnecessary features like Look At targets, etc.
Also, keep in mind that many private sims are OVER-MESHED, the designers using 75% to 90% mesh in their sim designs should all be shot. (Rhetorical statement). These are lag-cesspools and will kill performance on any viewer and hardware unless you have a $4,000 machine. Yes, for real.
The true trick is to recognize when it is not your machine, but how the region/parcel/venue is built, what your settings are, and what features do you have enabled. It's all about balance needed feature and setting with satisfactory performance, and this requires a little less of both.
Edited by Alyona Su
  • Like 1

Share this post


Link to post
Share on other sites
13 hours ago, Alyona Su said:

MY settings are (basically)

Thanks, yes I have four presets for different purposes such as: parties, shopping, exploring, photography and so on, each with different draw distances, some with advanced lighting off and so on.

I will give the LL viewer another go. I don't need RLV :)

Share this post


Link to post
Share on other sites
5 hours ago, livb89 said:

Thanks, yes I have four presets for different purposes such as: parties, shopping, exploring, photography and so on, each with different draw distances, some with advanced lighting off and so on.

I will give the LL viewer another go. I don't need RLV :)

Presets are awesome for this reason alone! :) I actually *really like* the LL viewer, though I need RLVa for my CTS Wardrobe (Inventory outfit management system) - though when I'm in the mod to just go as I am (no changing outfits willy-nilly) I always fire up the LL viewer. Though the performance difference between LL and FS are definitely more noticeable on Windows, the HiDPI feature (Retina Display) on LL viewer on the Mac is fo damned gorgeous OMG. :)

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I'm facing this issue when using SL viewer on a Surface Pro 6 with Windows 10.

The resolution on the Surface is 2736 x 1824 with 267 PPI.

Why is this feature only available on MacOS?

Is there a workaround to fix this without changing Windows monitor settings?

Should I file a bug report?

Second Life Release 6.3.8.538264 (64bit)

UPDATE

There are at least 2 bug reports regarding this issue but only for MacOS:

  1. [Mac] Camera spins and pulls back when using alt+zoom with mouse

  2. Alt zoom zooms way out when attempt to zoom in on Mac build running with external monitor

At the first issue, kyle.lindenKyle Linden  suggests a temporary fix to this issue in this comment:

Quote

Hi!

To anyone dealing with this issue we have a work around. I'm hesitant to share it though because this change will persist through regular updates and it's easy to forget you've done it.
Only full uninstall and reinstall would reset this particular setting. (Or you can delete/rename your /user_settings/ folder)

Please write this down on a sticky note somewhere near your computer so you don't forget, how, or that you have, made this change. Note: that using this work around will result in some other subtle changes like your mouse cursor hopping back to the center of the screen after each alt+left click and being limited to 180 degrees panning in mouse-look.

Caveats done, here is a quick fix:
Open the menu Advanced > Show Debug settings, then type in DisableMouseWarp and then set the value to True.

That's it, the spinning alt+zoom issue should be fixed on either primary or secondary monitor.

Please keep watching future release notes and when you see this issue marked as fixed you should be good to set DisableMouseWarp back to False.

Additionally, please let me know if this does not resolve the issue.

Thanks!

Open the menu Advanced > Show Debug settings, then type in DisableMouseWarp and then set the value to True.

This worked for me.

It looks like I can't add comments to any of these issues. If anyone cares and has access, please go and comment that this issue affects Windows 10 as well on high PPI monitors.

Edited by Chris Thesium

Share this post


Link to post
Share on other sites
23 hours ago, Chris Thesium said:

Should I file a bug report?

Yes.

23 hours ago, Chris Thesium said:

It looks like I can't add comments to any of these issues. If anyone cares and has access, please go and comment that this issue affects Windows 10 as well on high PPI monitors.

The fix for macOS has already been released, so that would be pointless. 

Share this post


Link to post
Share on other sites
14 hours ago, Willow Wilder said:

Yes.

The fix for macOS has already been released, so that would be pointless. 

Thanks for the response.

I thought there is an other status other than ACCEPTED to indicate that a bug is resolved.. well something like RESOLVED.

I am a bit lazy to go through the bug report process. That fixed my problem so it's OK now.

If anyone has that problem they can fix it by applying the proposed solution.

Share this post


Link to post
Share on other sites
18 hours ago, Chris Thesium said:

I thought there is an other status other than ACCEPTED to indicate that a bug is resolved.. well something like RESOLVED.

Not on the LL bug tracker. If a BUG is accepted, LL then uses an internal tracking system which regular Jira visitors don't have access to. Tracking those is its own fun and games. 😉 

You are probably thinking of the Firestorm bug tracker. 

Share this post


Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 103 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...