Jump to content

Problems to Rig (I DON'T KNOW HOW TO FIX IT)


You are about to reply to a thread that has been inactive for 735 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hello, i'm Nicholas and i'm learning how to make clothes for SL, i have a big problem and i don't know how to fix, i make everything right for make a fitted pants, and in blender i saw everything ok, when i make the upload for SL the pant not fit well, i really need help.

i tryed first make to belleza jake mesh body, and i thought that maybe could be the dev kit, but i tryed with others bodys and the same happen, so is not a problem in dev kits i think.

I know that in sl image is missing some parts of pants but the problem is that not fit well.

Screenshot_3.png

Screenshot_4.png

Link to post
Share on other sites
37 minutes ago, NichollasEvans said:

I know that in sl image is missing some parts of pants but the problem is that not fit well.

Leaving aside the missing surface in SL, which is most likely a problem with too many materials...

 

In Blender you can't have a custom bind pose (i don't know if 2.8 will bring news about this, in the future), you must rig it in TPose. If you think about it, what you get in SL is exactly what you rigged: imagine the pants like you modeled, just rigged to the normal TPose straight legs... once you import it and wear those pants, the offset would carry over and you get that result you're showing from SL.

To use a custom bind pose, you should use Avastar add on, but i don't know whether this feature is still there nor if it works as it should.

  • Like 2
Link to post
Share on other sites

Firstly, If you haven't already, then invest in Avastar, it'll save you a ton of headaches going down the road.

Secondly, as mentioned by Optimo. SL expects mesh to be in a T-Pose for uploading. Avastar compensates for this with the Bind pose option, but that's not an option you can freely use as you think. The Belleza Dev Kit is provided in a A-pose, (arms downwards, legs together) and should be kept that way, same for other kits, if their legs are together, keep it that way, if arms are in T then keep it that way. Changing the pose of Dev Kits can have an adverse affect on fitting inworld, much like the result you shown there where they don't fit.

The Avastar documentation for Bind poses warns against altering the pose when using Dev Kits https://avastar.guru/workflows/bind-pose/

You don't need to spread the legs for binding/rigging pants. If you suffer from sticky thighs just make the pants thighs thinner on the inside, bind them, then edit back into shape and then refresh the binding, or fix quickly using vertex selection and limit select to quickly remove weights from opposite bones.

 

  • Like 1
Link to post
Share on other sites

Hey hunni,

The belleza dev kit have some instructions  to use the bind pose option so i was trying with it.

i read the avastar doc about bind pose, and i saw that the recomended is not use bind pose with devkit of other creators. so i tried not use it, but the same bug in legs happened ☹️

and yes, i use the avastar

Link to post
Share on other sites
2 hours ago, NichollasEvans said:

The belleza dev kit have some instructions  to use the bind pose option so i was trying with it.

The Belleza original models were made in Maya, which fully supports bind poses. However the creator might not know that Blender, natively, doesn't.

21 hours ago, HunniHope said:

You don't need to spread the legs for binding/rigging pants. If you suffer from sticky thighs just make the pants thighs thinner on the inside, bind them, then edit back into shape and then refresh the binding, or fix quickly using vertex selection and limit select to quickly remove weights from opposite bones.

The problem that the OP is facing is that their pants were modeled with spread legs, so the issue may persist. 

  • Like 2
Link to post
Share on other sites
3 hours ago, OptimoMaximo said:

Os modelos originais da Belleza foram feitos em Maya, que suporta totalmente poses de vinculação. No entanto, o criador pode não saber que o Blender, nativamente, não sabe.

O problema que o OP está enfrentando é que suas calças foram modeladas com pernas estendidas, então o problema  pode persistir. 

i thought the same in the begin, but i didn't change the model for make the pants, i used the dev kit like it is for make the pant in marvelous and after i used the same kit for rig

i didn't change the avatar pose because i not wanted headaches but i was surprised with this bug

Edited by NichollasEvans
Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 735 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...