Jump to content

Recommended Posts

Posted (edited)

Hello, I am having the following issue since the last few hours.

I make a tattoo in Photoshop, save it with 60% opacity as PNG, then upload it to SL and open the texture, transparency looks ok.

Then I set it as the texture of a prim cube... the tattoo image appears 100% solid.

But if I save the same tattoo with a 49% opacity as PNG and apply it... the transparency appears to be fine.

Repeat the process, but with 50% opacity... solid tattoo once again. 😤

Further tests:

33% opacity = Working fine

66% opacity = working fine

70% opacity = Solid tattoo

75% opacity = Solid tattoo with some extra black pixels on the borders

And I find this even more confusing because up until yesterday I was making tattoos with 50%, 55%, 60% 80% 85% opacity in Photoshop, and all of them looked and are still looking fine when applied to the prim cube or my skin. 😧

Thanks in advance for any advice in this matter!

 

Edited by Alasttor

Share this post


Link to post
Share on other sites

Did you have a viewer update right before the problem started?
Which viewer are you using?  Top menu bar, help -> About Second Life (About Viewer Name on a TPV).
First line gives the exact viewer version.

Can you post the 66% & the 70% opacity textures here so we can test?

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, Whirly Fizzle! I am using this version, I updated to it many days ago.

Firestorm 6.0.2.56680 (Firestorm-Releasex64 64bit)

This is how I see a tattoo texture saved with 49% opacity in Photoshop. The transparency shows up fine: The texture is being applied on all sides of a prim, as a local texture.

d7e85176b46f116333c13cd5398a3bf1.jpg

Then I repeat the same process, but saving the same image with 55% opacity in Photoshop. Once applied on the same prim, the tattoo looks completely solid, as if I have saved it with 100% opacity in the editor.

63dbca3838397ecde8672ba943e25945.jpg

I have attached both images in case you want to try them on your side. It would be nice to know if it's a problem from my side only. ☹️

Many thanks again

 

Edit: I also installed the Offficial SL Viewer yesterday to try if it was a problem with my Firestorm, but the problem persisted.

Edit 2: I add a third picture showing that when viewing the 55% image in my inventory, it looks ok, it's opacity as normally expected. But when the texture is applied, it just looks solid.

460116f03b4477efca765a8ad20efac4.png

49op.png

55op.png

Edited by Alasttor
  • Thanks 1

Share this post


Link to post
Share on other sites

I guess Automatic Alpha Masking is kicking in. To avoid that I usually set 1% transparency in the in-world build floater.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
Quote
2 hours ago, arton Rotaru said:

I guess Automatic Alpha Masking is kicking in. To avoid that I usually set 1% transparency in the in-world build floater.

 

So is there any way to set 1% transparency on a local texture? 

I usually make a prim cube with a script that tells me the local texture UUID and load my tattoos designs on it, get the UUID, and use it on my tattoos appliers for testing how the tattoo fits.

But with this opacity issue I am getting quite frustrated. ☹️

Edited by Alasttor

Share this post


Link to post
Share on other sites
13 hours ago, Alasttor said:

So is there any way to set 1% transparency on a local texture?

The transparency option in the bulid floater is independent of the texture. You need to be able to set that on the object in question. It must be modifyable to you, or would have a build in scripted feature to set transparency per face. 

To check if Automatic Alpha Masks is kicking in, you can disable that in the viewer. Under the Develop menu > Rendering. This is a local viewer setting indeed. It has no effect to other peoples viewers, which may have it enabled still. 

Share this post


Link to post
Share on other sites
Posted (edited)

Well, I disabled the Automatic Alpha Masks and now the dolphins texture's opacity looks ok in my viewer.

But as you said, it's a local setting, and it's not a default one, at least  in Firestorm or in the Official Viewer.

So I guess that means my tattoo will still have no transparency for most people out there 🙁

 

Edited by Alasttor

Share this post


Link to post
Share on other sites
6 hours ago, Alasttor said:

So I guess that means my tattoo will still have no transparency for most people out there 🙁

Yes. Like I said, the usual "fix" for this is to set the transparency to one percent. This will force it to alpha blending no matter what. But if you don't have the abillity, or control over the object in question to set that, I'm afraid you are out of luck.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...