Jump to content
MBeatrix

What's up with sim crossings?

Recommended Posts

2 hours ago, Qie Niangao said:

I just wish they'd tell us what they actually did.

If they're trying to fix a race condition by tweaking timing constants, it's doomed.

Yes, Qie, I believe that's what they have been doing. But I do understand that properly changing the method would have serious implications, not to mention the time it would take.

Nevertheless, I'm amazed that after so many years they admit they don't know why sometimes it gets so bad. I can only guess that they never gave it the importance it has for many, many users.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, Qie Niangao said:

I just wish they'd tell us what they actually did.

If they're trying to fix a race condition by tweaking timing constants, it's doomed.

 

2 hours ago, MBeatrix said:

Yes, Qie, I believe that's what they have been doing. But I do understand that properly changing the method would have serious implications, not to mention the time it would take.

Nevertheless, I'm amazed that after so many years they admit they don't know why sometimes it gets so bad. I can only guess that they never gave it the importance it has for many, many users.

All this has an much too familiar ring to it.  I've been around SL in my alter ego since early 2008 and I was aware of it from about 2006.  When Philip Rosedale and his team developed SL out of the LindenWorld project, it was then understood that the chassis on which SL was built was a complicated and pasted-together one, but those who had pasted it together were still around to "bang on things".   In the years following Philip's departure SL passed through a phase of utter incompetence, during which time much knowledge and understanding of the nuts and bolts of SL was lost as experienced developers were "let go".  I will not comment on that time, it is too ridiculous to describe adequately.

When sanity began to return to Linden Lab, the new developers were only able to patch and Band-Aid issues and new features as they were introduced, to the point now where fixing one leak causes the programme to spring another.  I do not see any sign of this retrospective bodging growing into a real understanding of our virtual world.

The case of TPs and region-to-region crossings is a case in point.  They are considered by many to be much the same, but the truth is that they have little in common above some basic processes.  Region crossings require parameters such as vector, velocity and azimuth to be transferred from simulator-to-simulator and sometimes server-to-server.  TPs do not require that data.

One final comment.  The reason why we are not flooded with "me too" comments on such threads as this is that most users are too numbed by the lack of contact with the Lindens in past years to bother with complaining for a matter such as this.  Many were also rebuffed by a few who believe that we should simply be grateful for what we have and not make trouble. It is only those of us that can "be bothered" that post our thoughts suppositions and occasional frustrations here.  It does NOT mean that it isn't really happening!

Edited by Aishagain
  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites
19 minutes ago, MBeatrix said:

Nevertheless, I'm amazed that after so many years they admit they don't know why sometimes it gets so bad. I can only guess that they never gave it the importance it has for many, many users.

As I've pointed out to some of the Lindens, their technical debt is past due. Not fixing old problems creates technical debt. Problems caused by not fixing old problems increase the technical debt.

Share this post


Link to post
Share on other sites

Seems something changed. And oh,  not my computer nor connection.

 

Since 2 days I simply can't reproduce a disconnect, nor an unsit, even went through sim CROSSES flawlessly ! :)))

*fingers crossed*

  • Like 1

Share this post


Link to post
Share on other sites

We're going to find out on Saturday how well things are working. Drivers of SL is doing a drive/fly/boat run from the south end of Jeoghot to the north end of Sansara.

Share this post


Link to post
Share on other sites
4 hours ago, animats said:

We're going to find out on Saturday how well things are working. Drivers of SL is doing a drive/fly/boat run from the south end of Jeoghot to the north end of Sansara.

That reminds me .... do we have any data on the extent to which the number of vehicles attempting a particular sim border crossing at the same time has an impact?   Either for disconnect or for agent detach problems?

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/10/2019 at 9:17 AM, animats said:

We're going to find out on Saturday how well things are working. Drivers of SL is doing a drive/fly/boat run from the south end of Jeoghot to the north end of Sansara.

The log out problem seems to have gone, but replaced this weekend by a different problem where people appear 100m away from the boat after the sim crossing and no control over the vehicle. It is a familiar sim crossing problem to any traveller, but what is different this weekend is the frequency. I run a sailing group and we ran a route around blake sea and around Nautilus city and I think all of us had this problem 6 or more times across the couple of hours we sailed. The immediate solution seems to be to teleport away and teleport back and you reconnect with your boat and can continue. We have always had these maybe once or twice an hour but it has got silly now. I don't know if the sims are in bad shape and need restarts or what is going on but we seem to have swapped one problem for another.

Edited by Aethelwine
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

I've given up on guessing. Trying to diagnose a timing problem with weak tools is hopeless. Both for users and LL.

I got through the Drivers of SL on Saturday with zero region crossing problems. I was amazed. I seem to have been the first to finish, and others were reporting much worse experiences. It probably helped that I got out in front at the start and thus was going through empty sims for the long water crossing from southern Jeoghot to Bellesaria.  If anything goes wrong on that segment, it's a long way to a rez zone. The game HUD will notice if you teleport.

Edited by animats

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Aethelwine said:

The log out problem seems to have gone, but replaced this weekend by a different problem where people appear 100m away from the boat after the sim crossing and no control over the vehicle. It is a familiar sim crossing problem to any traveller, but what is different this weekend is the frequency. I run a sailing group and we ran a route around blake sea and around Nautilus city and I think all of us had this problem 6 or more times across the couple of hours we sailed. The immediate solution seems to be to teleport away and teleport back and you reconnect with your boat and can continue. We have always had these maybe once or twice an hour but it has got silly now. I don't know if the sims are in bad shape and need restarts or what is going on but we seem to have swapped one problem for another.

I realized that to me, it's a matter of distance between your cam and avie.

If I cam my boat from far > I have the bug you describe 2/3 borders.

If I let my cam close to the boat / avatar (or even better in mouselook) > flawless.

Edited by Jo Clip

Share this post


Link to post
Share on other sites
Posted (edited)
5 minutes ago, Jo Clip said:

I realized that to me, it's a matter of distance between your cam and avie.

If I cam my boat from far > I have the bug you describe 2/3 borders.

If I let my cam close to the boat / avatar > flawless.

I keep my view fairly close.

I have just done LCC cruise up in NW Sansara and I only had a couple of problems as described before in the hour or so of sailing. So perhaps it is just that the sims around the blake are tired and need a restart. Perhaps the Bellisara houseboats have generated more interest in sailing creating more traffic on the waterways degrading their performance quicker. I am not sure how often the sims get restarted but it would be nice if they did them more regularly.

Edited by Aethelwine

Share this post


Link to post
Share on other sites
On 5/2/2019 at 10:43 AM, Jo Clip said:

Note : on the pic on minimap, some region is showing red. Happens almost everytime I crash now. That was not happening before the 'fix'.

Note 2 : I have now that bug where you can't see the opposite sim at a given cross. Dunno if I say it well please excuse my poor english.

sl-tp-crash-2019-05-02-2.png

The red region thing has been around for a long time. It is not a thing of the region rossing failures and disconnect syndrome of this year. It is however worse than previously. So, the disconnects issues may be aggravating the symptom.

On 5/6/2019 at 9:57 AM, Qie Niangao said:

I just wish they'd tell us what they actually did.

If they're trying to fix a race condition by tweaking timing constants, it's doomed.

They did, last Friday... at least in regard to the outage. For the disconnects specifically they rolled back the OS upgrades. They added logging to find the problem. They have some things to work on based on the newly logged data. Fixes are going into server updates. Over the last 2 weeks those changes seem to have made a big difference.

Often the server fixes are only ever explained at the UG meetings. The Tuesday noon meeting with Simon, Oz, and Rider Linden is likely your best bet for getting answers.

  • Thanks 2

Share this post


Link to post
Share on other sites
17 minutes ago, Nalates Urriah said:

They did, last Friday... at least in regard to the outage. For the disconnects specifically they rolled back the OS upgrades. They added logging to find the problem. They have some things to work on based on the newly logged data. Fixes are going into server updates. Over the last 2 weeks those changes seem to have made a big difference.

Often the server fixes are only ever explained at the UG meetings. The Tuesday noon meeting with Simon, Oz, and Rider Linden is likely your best bet for getting answers.

I try to make it to every Tuesday server user group -- for one thing, it's the only user group meeting that I can usually kinda fit into my RL schedule -- but I may have missed a few along the way. Apparently I missed (or misunderstood) when they announced they had to roll back the OS upgrades; I'd so hoped that would not turn out to be the actual cause of the problem. Anyway, I certainly agree that the disconnects have stopped completely (for me).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...