Jump to content
Zumeji

I can't make the transparencies not become invisible when overlapping

Recommended Posts

Hi!

I have some doubts about the textures with transparencies. Mi ontention is to create hair with tufts drawns on a texture, but as they have transparencies, when superimposing some over others, the most common occurs: that they become opaque or become invisible.

I have been researching on the web and trying to study the hair that I bought in the market (how they manage to make textures with transparencies overlap without interrupting each ohter), but I can't find those results.

Some say that it is due to the viewer, others that it is to use PNG format instead to tga format. It can't be the first because I have many hairs with strands that do not become invisible when overlapping and I don't think it is the format since I use .tga.

This is driving me crazy.

Whoever has the patience and kindness to explain me, thank you very much.

Share this post


Link to post
Share on other sites

I'm definitely no expert, but from my limited experience(using pngs at least), switching to alpha masking and playing with the 'mask cutoff' value might fix that for ya.  You may have to use select face for the option to come up if there are alpha and non-alpha textures on the same object, but that may be best for what you're going for anyway since the mask cutoff might have different optimal values per section.

  • Like 1

Share this post


Link to post
Share on other sites

I appreciate your response. That was my last option, but I think it's not the best, the edges of the images look very bad with the masking, they are not the soft lines that draw the ends of a hair, but I have no choice :)

Share this post


Link to post
Share on other sites

The previous answer is correct, the only fix is to make one of the textures Masked instead of blended. Raising the Mask Cutoff number often helps. Sometimes one of the textures will handle it better than the other; in particular, often masking the one that's supposed to be behind, is the best way. 

And no, it makes no difference whether you use .png or .tga, or what viewer you use.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...