Jump to content

Recommended Posts

So I am trying to learn how to create emissive masks. I've gotten everything just about done: I chose a test texture, created a mask in Photoshop (all parts show up as red that I do not want to glow in-world, and the vice versa for white), and saved as a targa (.tga) file. I have tested it in-world and... no emission, I can't even use the menu to change it, the dropdown is grayed out. What am I doing wrong? Can I get some advice? I am not new to texturing but I am new to this type of texturing. I have a feeling I am quite close to having this figured out, but I do not understand why it's not working in-world.

Share this post


Link to post
Share on other sites
Posted (edited)

Transparent or black pixels will not glow - any color will glow in that color.

You add this mask to your texture as the transparency layer and save it as 32bit TGA.

In SL you set the alpha mask to emissive and of course you activate glow for that surface.

Edited by Nova Convair
  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, Pirschjaeger Fassbinder said:

In order to see emissive masks, you need the "Advanced Lighting Model" setting enabled in the graphics setting.

Obviously XP

Share this post


Link to post
Share on other sites
Just now, Pirschjaeger Fassbinder said:

I'm (and others are) trying to be helpful here and sometimes we have to ask the seemingly obvious questions in order to troubleshoot your problem. 

Okay, fair enough. But my problem is in saving the texture and then getting it to work in-world. I've got an alpha channel set up on my test texture but when I save it as .tga it simply doesn't work in-world. 

Share this post


Link to post
Share on other sites
40 minutes ago, rtd144 said:

Thanks for replying but you're telling me things I already know. lol

Seriously? You come here for help then insult people for not reading your mind?

Share this post


Link to post
Share on other sites
10 minutes ago, Pirschjaeger Fassbinder said:

I'm (and others are) trying to be helpful here and sometimes we have to ask the seemingly obvious questions in order to troubleshoot your problem. 

And the reason is the OP expected everyone to play 20 questions to find out the relevant info. 

 

Share this post


Link to post
Share on other sites
6 minutes ago, Pamela Galli said:

Seriously? You come here for help then insult people for not reading your mind?

I figured by saying I was not new to making textures that it was obvious I'm not making extremely nooby mistakes. Calm down.

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, Ivanova Shostakovich said:

   Are you sure your graphics editor is saving it as a 32 bit file? Photoshop asks when I save as tga if I want 32 bit or 24 bit.

 

I will go back in and look at that, I figured it was saving as 32 bit by default.

Share this post


Link to post
Share on other sites
15 minutes ago, Ivanova Shostakovich said:

   Are you sure your graphics editor is saving it as a 32 bit file? Photoshop asks when I save as tga if I want 32 bit or 24 bit.

 

Well, I saved it as 32 bit, but same result, not working in-world. 😧

Share this post


Link to post
Share on other sites

   Well, if it's a 32 bit file, and your alpha channel has white for everything you want to glow and black for what you do not, and you've enabled ALM, and you've set the object diffuse texture alpha mode to emissive, I don't know what else could be wrong.

Share this post


Link to post
Share on other sites
4 minutes ago, Ivanova Shostakovich said:

   Well, if it's a 32 bit file, and your alpha channel has white for everything you want to glow and black for what you do not, and you've enabled ALM, and you've set the object diffuse texture alpha mode to emissive, I don't know what else could be wrong.

The build menu isn't even letting me select the option to do emissive masking. The dropdown is still grayed out. I'm so confused, what in the world have I possibly done wrong..? @-@ 

Share this post


Link to post
Share on other sites
3 minutes ago, rtd144 said:

The build menu isn't even letting me select the option to do emissive masking. The dropdown is still grayed out. I'm so confused, what in the world have I possibly done wrong..? @-@ 

   If the alpha mode drop down box is grayed out, then your texture is in fact not 32 bit and it has no alpha channel.

Share this post


Link to post
Share on other sites
7 hours ago, rtd144 said:

I am new to this type of texturing. 

 

Share this post


Link to post
Share on other sites
1 minute ago, Ivanova Shostakovich said:

   If the alpha mode drop down box is grayed out, then your texture is in fact not 32 bit and it has no alpha channel.

Hmmmm I'm going to make one from scratch and see if it works. I swear I did everything right though.

Share this post


Link to post
Share on other sites

What version of Photoshop are you using? I use an incredibly ancient version but this is what I do...

  • Make sure the mode is "RGB" if I'm dealing with just a grey texture
  • Start with a background layer (appears as "Background" in italics in the layers tab) of your texture
  • Duplicate that layer as a regular layer
  • Go to the channels tab and create a new channel
  • Select that channel in the tab
  • Paste my alpha channel image
  • Make sure my alpha channel and the combined color image are visible in the channel tab
  • Save as .tga with the save option "Alpha Channels" enabled 
  • In the next pop-up window, make sure 32 bits/pixel is selected under "Resolution"

Worse comes to worst, I could look at a .PSD of your setup or give you an example .PSD of mine.

  • Like 1

Share this post


Link to post
Share on other sites
On 3/10/2019 at 1:24 PM, Pirschjaeger Fassbinder said:

What version of Photoshop are you using? I use an incredibly ancient version but this is what I do...

  • Make sure the mode is "RGB" if I'm dealing with just a grey texture
  • Start with a background layer (appears as "Background" in italics in the layers tab) of your texture
  • Duplicate that layer as a regular layer
  • Go to the channels tab and create a new channel
  • Select that channel in the tab
  • Paste my alpha channel image
  • Make sure my alpha channel and the combined color image are visible in the channel tab
  • Save as .tga with the save option "Alpha Channels" enabled 
  • In the next pop-up window, make sure 32 bits/pixel is selected under "Resolution"

Worse comes to worst, I could look at a .PSD of your setup or give you an example .PSD of mine.

I shall open photoshop and try this right away! Thank you!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...