Jump to content
animats

Mesh upload of linkset with explict low-LOD model

Recommended Posts

I'm uploading a linkset with 3 components from Blender. I have one model for the high level of detail, and a second, much simpler model which I use both for all lower levels of detail and the physics model. This works if I merge the linkset into one mesh. But I need multiple texture animations, and you only get one of those per prim, so I need to split off some objects.

I get the upload error "Material of model is not a subset of reference model", even though the material list for the two DAE files is the same. Does that have to match per-object, or per linkset?

The simpler model only has one object, not three. Is it required that the lower level of detail models have the same number of objects? If so, how do you match them up? Alphabetically? Can you have empty objects to complete the match, or do they have to have triangles?

Firestorm 6.0.2.

Share this post


Link to post
Share on other sites

Trying to see what's going wrong. To get a look at the low-LOD model, I tried uploading the .dae file both into SL and Blender.

bogusmsgfirestorm.thumb.png.d3f4fd9f3e9699a55427976276ab1fa9.png

The .dae file will upload into Blender, but Firestorm/SL says "Missing required level of detail".

That message is bogus when only one file is being uploaded and the others are "Generate". Clearly it's not an empty .DAE file; Blender can read it.

This bogus message was discussed back in 2012. This looked promising:

By default, when you re-upload a file with the same filename, the uploader will use an  ".slm" file, stored on your machine, to fill in many of the details, including the low-LOD meshes. If you have increased the number of separate meshes in the main file, then there will be no equivalent of the additional meshes in the .slm file and you will receive that error. In a single case, you can work around this by finding and deleting the .slm file (it has the same name and location as the main file, but with .slm instead of .dae).

Since I have increased the number of separate meshes in some files with the same name recently, that might be it. But I am not finding a ".slm" file in the directory with my .dae file. Did that misfeature go away sometime after 2012, or are there hidden files somewhere I need to delete, or what?

 

Share this post


Link to post
Share on other sites

This may help you on the physics: https://www.youtube.com/watch?v=789HEWcYyp0   Not sure if I talked about the LODs but hopefully I did. 

 

For the LODs you have to follow a similar naming of the files.    I believe it is _LOD2, _LOD3   etc.   I don't do this all that often so someone that does can help you more.  I have a post somewhere on Google Plus but I can't find it. Features a trio of gift boxes.  

 

Share this post


Link to post
Share on other sites

Maybe I don't understand all the scope of your issue but there's a thing drawing my attention : your lowest model is 3 triangles and your object owns 6 materials. Your lowest model should own at least 6 triangles with one different material each triangle. Same for the other levels : you must check they all have the six materials named after the original mesh's.

I always create the lowest models from a duplication (SHIFT D) of the original mesh because sometimes the uploading window generate engine won't do the job well.

Also, if I use the Decimate modifier, I always check the operation didn't eat a material, by selecting each material.

To resume :

  • Material of model is not a subset of reference model : the sub models don't own the same number and/or the same names for the materials.
  • Missing required level of detail : the materials don't repeat on the sub model because not enough triangles. Or some faces haven't been assigned a material.
Edited by Pierre Ceriano

Share this post


Link to post
Share on other sites
1 hour ago, Pierre Ceriano said:

Maybe I don't understand all the scope of your issue but there's a thing drawing my attention : your lowest model is 3 triangles and your object owns 6 materials. Your lowest model should own at least 6 triangles with one different material each triangle. Same for the other levels : you must check they all have the six materials named after the original mesh's.

That's not it.

allsamelod.thumb.png.a9e86df65c75c6f88fb0cca761f817bf.png

This fails, too.

It acts like an upload of an empty file. But Blender can import that file, materials and all.

I also thought that the problem might be that I was uploading an object named ..._PHYS.  No, that's not it. Changed the object name, upload failed the same way.

Maybe this will make more sense tomorrow.

I watched Chic Aeon's video. It's unclear. It talks about "saving the file" for upload. Do you mean exporting it as Collada? The video doesn't show exporting, or discuss export options. Nor does it involve multiple level of detail models; they're all generated by the uploader's built in decimator.

There's a workflow in there where all the objects are joined together into a single mesh, the textures are baked into one image, and then the objects are cut apart again by hand into individual objects. This works for the example of a few gravestones which are some distance apart. It's hell for any linked model where the parts are close together. Do you actually have to do that to get a linkset to upload, or can each object in the linkset have separate textures?

And yes, I've read this discussion of uploading a linkset.

Perhaps this will be clearer tomorrow.

Share this post


Link to post
Share on other sites

I never upload multiple meshes in one go so I can't help you with the naming conventions for LoD and phyisics models.

But apart from that:

When you upload multiple meshes together, they are treated as separate objects in every way. The only difference from uploading them one by one is that it saves you the job positioning and linking them in-world.

All faces need to be present in all LoD models of a mesh.

 

  • Like 1

Share this post


Link to post
Share on other sites

Materials list has to match per object, and the names need to be unique and not have spaces (unless you are using the preprocess DAE setting). In my experience, the objects in the DAEs have to be in the same order in order to load without explicit named LOD matching 

materials are dumped into a map as they are loaded and then referenced, if you have multiple materials of the same name the map picks up a different permutation of materials and says "hang on these aren't the same". 

The single high lod model (called physics and low lod)  I don't understand what you are showing. The high LOD model has failed to parse there it would seem but without knowing more I can't say what's going on at all. What is the object naming? as arton suggests, remove anything that might be confused from the mesh name, note it is the name of the mesh, not the object. if it believes that you are attempting to use named LOD matching it may fail. The parsing is finicky at best.

Share this post


Link to post
Share on other sites

I've just uploaded a house that consists of 16 separate objects as a linkset with LOD's and Physic models and can confirm it works as it is supposed to.

Here's what I've found you need to do to get it to work right. It might be useful for others that are struggling to upload a linkset with lod's and physics.

 

1) Make sure you have LOD's and Physics models for EVERY object in the linkset, no exception!

2) Decide on the type of physics you are going to use. When uploading the whole set at once you can only use one type of physiscs.

3) Name your materials with no spaces and number them at the beginning to make sure they remain in the correct order (e.g. 01Material, 02Material, etc...).

4) Add _LOD2, _LOD1, _LOD0 and _PHYS to your level of details and physics models names. Use _LOD2 for your highest and _LOD0 for your lowest level of detail models.

5) Export each LOD set as a separate DAE.

 

  • Like 3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...