Jump to content

Recommended Posts

I bought a texture changing HUD and i got it to work on objects that aren't linked together, but when i link them the texture changes everything not that one thing i just want to change. i don't know why it is doing that and what i am doing wrong. the script i'm using is ::jAS:: Texture Change HUD Script

i'm not used to working with scripts so sorry if this seems like a silly problem

 

https://gyazo.com/116aeead3caadcb847a3812e1f84262b << unlinked

https://gyazo.com/c2f6f4c8559f2eb6f4c495831a61c4d5 << Linked

Share this post


Link to post
Share on other sites

That's not too surprising. Unless you know exactly how the script was written, you take a big chance by dropping it into a random object. If you want to change the texture on a specific prim in a linkset, you'll have to use a script with llSetLinkTexture (or the llSetLinkPrimitiveParams equivalent) to target a specific face on that specific prim.  If the script has not identified the link correctly, you'll get unpredictable results.  If the script you are using wasn't designed to work in a linkset at all, then it will have used llSetTexture (or the llSetLinkPrimitiveParams equivalent) to change the texture of the prim that it's in.  If you drop that script into a linkset, again, you may get unpredictable results.  The bottom line is that you need to write a texture changing script that is matched to your particular application.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...