Jump to content

Question

After several months away from SL, I logged in last night (after updating my SL and Firestorm viewers to the current release versions). The problem appears to be limited to the SL viewer.

  • Prim hover (floating) text, i.e. created by llSetText(), is not appearing when I'm using the SL viewer (it wasn't appearing when I initially logged into the Firestorm viewer, but restoring old Firestorm settings fixed it for Firestorm).
  • Bizarrely, this type of floating text can be seen on attached HUDs, but the HUD prims can't be seen-yet the HUD seems to function properly.
  • The problem is independent of avatar (I saw it on the two avatars I tried).
  • I tried uninstalling and doing a totally clean install of the SL viewer; the problem still exists.

Is there some obscure setting I'm missing? I've looked through pretty much everything I could think of (it's annoying enough to find settings that used to be on the main menus now buried in the Debug Settings menu).

SL viewer: Second Life Release 6.0.1.522263 (64bit)
Firestorm viewer: Firestorm 5.1.7 (55786) Jul 13 2018 22:34:51 (64bit) (Firestorm-Releasex64) with OpenSimulator support
Windows 7 64 bit

First image in SL viewer, second in Firestorm

 

Secondlife viewer-floating text missing.jpg

Firestorm viewer-floating text seen.jpg

Edited by Scott Woollahra

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I didn't find a setting in the SL viewer that would turn this on and off, but while testing, I did notice that the visibility range for hovertext is 10m.  Did you try moving closer?

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Lindal Kidd said:

I did notice that the visibility range for hovertext is 10m. 

The range depends on the size of the prim, so it's not a fixed 10m.  If you put hover text on your house, you'll see it from 50 or 60 m away.

Share this post


Link to post
Share on other sites
  • 0

I've discovered what the problem is: when the Advanced Lighting Model in Graphics preferences is enabled, the floating text disappears. I've confirmed this for both Firestorm and the SL Viewer. I believe this is a relatively new phenomenon, as in the past I've often had Advanced Lighting active to enable shadows, and never noticed this.

I don't know what a solution might be, and wonder if it is a bug or feature, possibly related to my older computer/graphics card, or some new obscure settings buried somewhere in the byzantine viewer interfaces.

Edited by Scott Woollahra

Share this post


Link to post
Share on other sites
  • 0

Yeah if this only happens when ALM is enabled, I suspect it's a graphics card/driver issue.

In the top menu bar of the viewer, go to Help -> About Second Life (or About Firestorm).
Click the "Copy to clipboard" button & paste all your system information here.

Share this post


Link to post
Share on other sites
  • 0

Here, my system info (Firestorm updated this morning to current version). I know my graphics card/driver is old, but it's still able to run ALM. The issue has only manifested in one of the recent viewer updates.

---------------------------------------

Firestorm 6.0.2 (56680) Feb  9 2019 10:23:10 (64bit) (Firestorm-Releasex64) with OpenSimulator support
Release Notes

You are at 232.0, 4.2, 152.3 in Hughes Rise located at sim10481.agni.lindenlab.com (216.82.51.187:13010)
SLURL: http://maps.secondlife.com/secondlife/Hughes Rise/232/4/152
(global coordinates 261,352.0, 231,684.0, 152.3)
Second Life Server 19.01.25.523656
Release Notes

CPU: Intel(R) Core(TM) i5 CPU       M 450  @ 2.40GHz (2394.03 MHz)
Memory: 7861 MB
OS Version: Microsoft Windows 7 SP1 64-bit (Build 7601)
Graphics Card Vendor: ATI Technologies Inc.
Graphics Card: ATI Mobility Radeon HD 5650             

Windows Graphics Driver Version: 8.771.1.0
OpenGL Version: 4.0.10188 Compatibility Profile Context

RestrainedLove API: (disabled)
libcurl Version: libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.8 nghttp2/1.25.0
J2C Decoder Version: KDU v7.10.6
Audio Driver Version: FMOD Studio 1.10.10
Dullahan: 1.1.1080 / CEF: 3.3325.1750.gaabe4c4 / Chromium: 65.0.3325.146
LibVLC Version: 2.2.8
Voice Server Version: Vivox 4.9.0002.30313

Settings mode: Firestorm
Viewer Skin: StarLight (Silver Blue)
Window size: 1280x972 px
Font Used: Deja Vu (96 dpi)
Font Size Adjustment: 0 pt
UI Scaling: 1
Draw distance: 128 m
Bandwidth: 1200 kbit/s
LOD factor: 2
Render quality: Medium-High (4/7)
Advanced Lighting Model: Yes
Texture memory: 512 MB (1)
VFS (cache) creation time (UTC): 2019-2-19T10:39:41 
Built with MSVC version 1800
Packets Lost: 52/74,424 (0.1%)
February 19 2019 03:12:43 SLT

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...