Jump to content
decurcele

Custom joint offset are getting dislocated in world

Recommended Posts

software usedBlender 2.79b, Avastar 2.5.1 and firestorm viewer.

Hello, i'm having an issue with a mesh limb for a custom avatar i made that uses custom joint offset (pic1, pic2),

pic1.thumb.jpg.db6f787adeca9ca88d59a1f71def52bd.jpgpic2.thumb.jpg.ed12b56a4e9b676e85a6b9c47a28c738.jpg

i upload it with "include skin weight" and "include joint position" .

the arm it self works until i wear some mesh that is rigged with a different joint offset, this will dislocate completely the limb and i have to relog to fix it.

pic4.thumb.jpg.4474a47e2168679115d6aab89489a7c5.jpg

Also the fingers are all pointing in the wrong direction whenever i wear something or not.

pic6.thumb.jpg.0f35e1d97ca39c5beda436e458b2d76f.jpg

I'm not sure what i'm doing wrong, this is the first time i'm using different joint offsets.

link for the blend file, NOTE this is the dumbed down version of the mesh : https://drive.google.com/file/d/1q2YfVvDktjmRMC_X7997eUpFQoJr5Kd_/view?usp=sharing

Any help is appreciated

Share this post


Link to post
Share on other sites
38 minutes ago, decurcele said:

the arm it self works until i wear some mesh that is rigged with a different joint offset, this will dislocate completely the limb and i have to relog to fix it.

This is most likely due to the starting shape you rigged from in addition to the other thing you're wearing on top. You should always begin the joints repositioning starting from the Neutral shape, not the default shape

39 minutes ago, decurcele said:

Also the fingers are all pointing in the wrong direction whenever i wear something or not.

This is an issue with joints orientations. It's not visible in Blender right away, but when you go into Edit mode on your skeleton, in the side panel (that toggles with N) you can find a "Bone Roll" value. Always make sure that, after the bone position is correct, this value is set to zero.

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, decurcele said:

But they are saved for me 

Then it's most likely the shape issue, at least for the dislocation of the forearm. I'm pretty positive that you've been using the Default female, rather than the Neutral (check in the shape presets). When doing joint positioning, you should start from the Neutral shape.

  • Like 1

Share this post


Link to post
Share on other sites
9 minutes ago, OptimoMaximo said:

Then it's most likely the shape issue, at least for the dislocation of the forearm. I'm pretty positive that you've been using the Default female, rather than the Neutral (check in the shape presets). When doing joint positioning, you should start from the Neutral shape.

I got this options instead, should i see the "Neutral" preset in here?

2.jpg.33b73cb3f1be211ae749e4017abe804f.jpg

Share this post


Link to post
Share on other sites
4 minutes ago, OptimoMaximo said:

The two Tpose icons on the left, hover your mouse over each one and you should read Neutral on one of them

Ah yes i was using that already then 

Share this post


Link to post
Share on other sites
19 hours ago, Kyrah Abattoir said:

If you use other items that have custom join offset i believe the last worn item "wins"

It doesn't matter if it is first or last, the dislocation on the mesh arm persist even if i remove the item that caused that(i have to click "underform avatar" with everything removed to fix the dislocation) , then again whats going on with the fingers? i checked bone roll and it's  all on zero, i must doing something wrong for sure but i don't know what.

Share this post


Link to post
Share on other sites

Ok so i think i figured it out, i have updated Avastar to 2.5-8 and checked "use bind pose" and "export with joints"

1560718204_bandicam2019-01-2017-05-29-991.jpg.5828e70d0dc9f5ec59035996fd64ddaf.jpg

This fixed the fingers, as for the dislocation it seem to be a sl issue so the "underform avatar" option fixes that when you change avatars that use custom joint offsets. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...