Jump to content
Sign in to follow this  
Cielo Aulder

Please help with RLV command

Recommended Posts

I'm trying to do an object that attached to the avatar will prevent them from teleporting.

I'm using llOwnerSay("@tplure=n"), which works on avatars (or viewers) with RLV active. Problem is, those with RLV not active get that "@tplure=n" on local chat and i will like to avoid that and instead send them a message letting them know they have RLV deactivated. I'm pretty sure that has to be possible but i can't figure out how.

I've seen some code using llSay(-1812221819, ......  This can avoid the local chat message, but i can't get that to work.
I'm not sure how the whole sentence on this one would be. I've tried:
llSay(-1812221819,(string)llGetOwner()+"@tplure=n");
llSay(-1812221819,(string)llGetOwner()+",@tplure=n");
llSay(-1812221819,"@tplure=n");

but no luck.

Hope you can help me. Thanks!

Edited by Cielo Aulder

Share this post


Link to post
Share on other sites

What you describe -- sending messages using channel -1812221819 -- is used to send messages to someone's RLV relay, which listens on that channel and then, if the message is correctly formed and passes whatever security filters the relay's wearer has set, parses it into a RLV command which it passes on in the form of llOwnerSay();

Relays, as you probably know, are used so that objects (cages and traps, for example) can send RLV commands to avatars other than their owner.

So when you're sending a message to a relay, the general rule is to start by pinging the avatar in whose relay you're interested with the @version command, which tells the relay -- if it's turned on and set to respond to your object -- to report which version of RLV its wearer is using.

That's not going to work here, since the owner is the target.   I think the best you can do is have the object set a timer for a few seconds and ping the wearer, using llOwnerSay("@version=someChannel) where someChannel is a high positive integer ion which the item is listening, and then, if it hears a reply on that channel, remove the timer and issue the RLV restriction.    If the timer fires, then you know that the wearer probably isn't using RLV, so turn off the timer and tell the wearer to activate RLV and to try again.

You need to remember that if you want automatically to try to reapply the restriction when the avatar relogs, the attachment's on_rez event is going to fire a good 30 to 60 seconds before the avatar's viewer is able to reply, so allow plenty of time there.   

If the av isn't using RLV, she will see the @version=9999 message, but  there's nothing you can do about that.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you very much Innula, incredibly well explained, as all your posts i've read on this forum. You've helped me millions of times without knowing it  😉

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...