Jump to content

Avatar sometimes does not fully render after TP


Valerie9861
 Share

You are about to reply to a thread that has been inactive for 1021 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

22 minutes ago, Valerie9861 said:

 This has been happening a lot lately...usually just hair but sometimes other things. If I choose avatar health and refresh attachments it fixes...also...I see the hair but others do not.

The bit that I've bolded is the crucial point here. The fact that others don't see these items after you teleport (but you still do see them) means the items have detached during the teleport but your viewer hasn't caught up with that fact. Sometimes refreshing attachments will help diagnose this: (e.g. if your mesh head's HUD stops working, refresh attachments might make it vanish, showing you that it wasn't working simply because it had already detached but your viewer was still rendering it. No wonder clicking it didn't do anything!)

The main reason behind body parts and other attachments coming off during teleport is that you have too many things attached to a single point on your avatar's skeleton. Next time you notice it happening, make a note of what's missing. Relog (log out of SL and then back in again) and you'll see for yourself what's missing. Next, re-add those items, and then go into the 'worn' tab of your inventory. Next to each item you're wearing you'll see which attachment point it's using.

If your hair came off, as well as a pair of boots and a mesh skirt, and they're all attached to your left hand, look at what else is attached to your left hand. Maybe your mesh body is, too. The more that you have attached to a single point, the more risk there is of something detaching during a teleport. The centre point of the body as well as the hands are the positions that many creators use, but if an item is rigged (that is, it moves with your body) then it can be attached anywhere. To check if something is rigged, try to edit and move it. If it won't move, then it's rigged.

Hair coming off, and it's attached to your hand? Remove it and re-attach it using the skull point. Boots coming off and they're attach to your hand? Remove them and re-attach to the left (or right) foot. Mesh body coming off and it's attached to your hand? Remove it and re-attach to your avatar's centre point. Attachments will always remember the last point they were added to, so by working your way through the 'culprit' items like that you'll slowly reduce the chance of losing half your avatar during teleports again.

Edited by Skell Dagger
  • Like 1
  • Thanks 3
Link to comment
Share on other sites

Hello,

I have nearly the same problem and the attachments that are affected are not all attached a single point. 

Don't know if all the others can't see me with all attached every time because they don't normally know what stuff belongs to my outfit.

But I can't see several attachments after a teleport. 

Sometimes "refresh attachments" works, but not everytime. Now I do a rebake (ctrl+alt+l) after nearly each teleport because I can't see several attachments after teleport. 

And I try to detach all huds I don't need that moment every time. 

But the last time for me it is not normal need making so many rebakes.

Kindly regards

Ehawee

Link to comment
Share on other sites

I have a few hairs and a couple of pairs of ankle boots that sometimes disappear from view when I teleport.  However, if I simply scroll my view out and back, they show up.  I've always figured that those particular items were badly made in some way.  Doing a 'refresh attachments' doesn't change my view - only scrolling my view back and forth -- and only with a few items that I own.

Edited by LittleMe Jewell
Link to comment
Share on other sites

Yes, problems with some hairs I know too. Often I deleted of a copy from that hairs the scripts. But that didn't help too.

I have that problem with hats, caps, with parts of armor and sometimes with weapons or belts too. Oh - and with eyes. Looks really good with no eyes. o.0

Cam out and in again, sometimes cam around me works. Or right click on some attachments that are invisible. 

But sometimes it doesn't work.

Sometimes I need detach it and attach it again and sometimes it does not work too. 

*sighs

Edited by Ehawee2016
Link to comment
Share on other sites

3 hours ago, LittleMe Jewell said:

I have a few hairs and a couple of pairs of ankle boots that sometimes disappear from view when I teleport.  However, if I simply scroll my view out and back, they show up.  I've always figured that those particular items were badly made in some way.  Doing a 'refresh attachments' doesn't change my view - only scrolling my view back and forth -- and only with a few items that I own.

I've had a similar issue with a pair of glasses, and with one of my favorite hairs.  I hadn't tried the scrolling out and back in trick - I always right-clicked where they should be and then they would show up - easy to do with hair, not so easy with glasses.  If I decide to try wearing them again I'll try the scrolling out and back in. 

Link to comment
Share on other sites

1 hour ago, moirakathleen said:

I've had a similar issue with a pair of glasses, and with one of my favorite hairs.  I hadn't tried the scrolling out and back in trick - I always right-clicked where they should be and then they would show up - easy to do with hair, not so easy with glasses.  If I decide to try wearing them again I'll try the scrolling out and back in. 

The clicking sometimes works for me and sometimes doesn't.  Overall, it is a bit frustrating.  I can't quite figure out if it has something to do with the way the items are made or what.  The hairs and boots that this happens with are older objects, prim items, so who knows.  Even though I don't wear those items a lot, I do like them and wear them enough to put up with the issue -- though I have often wondered if others see the items or not.   One of these days I'm going to log in an alt and place here somewhere and then TP there to see how she views me.

Link to comment
Share on other sites

Yesterday I asked a friend if she can see me like before the tp. She said my outift looks complete but I can't see several parts from it. 

I did a rebake and could see them again.

And on an other outfit I just wear disappear 5 parts +/- after a tp and I need a rebake or I cam out and in again. 

For me it is not normal.

Ok, I did 15 about teleports now to several sims and only after 2 tp my avatar was complete. 

Edited by Ehawee2016
Link to comment
Share on other sites

20 teleports and after 4 tp of them my avatar looks complete.

The four sims are:

Colloseum club: http://maps.secondlife.com/secondlife/Exquisite/75/74/21

Big Daddy's Club: http://maps.secondlife.com/secondlife/BIG DADDYS WORLD/66/136/25

The Temple of the Collar: http://maps.secondlife.com/secondlife/Arcadia/104/209/21

and

The Gor Hub: http://maps.secondlife.com/secondlife/Marina Bay/225/208/3905

 

At the Gor Hub sim happened that:

[05:18] [Sim tried to kill attachment: TSC Battle Mage Priestess L Hand [BENTO] (tp)]
[05:18] [Sim tried to kill attachment: TSC Battle Mage Staff (Back) (tp)] <<< parts of it become invisible after tp
[05:18] [Sim tried to kill attachment: .LeLutka.Simone.Teeth 1.1 (tp)]
[05:18] [Sim tried to kill attachment: TSC Battle Mage Priestess Chest (tp)]
[05:18] [Sim tried to kill attachment: TSC Battle Mage Priestess R Hand [BENTO] (tp)]
[05:18] [Sim tried to kill attachment: PFC~Gjallarhorn - belt (stretchable) (tp)] <<< often invisible after tp
[05:18] [Sim tried to kill attachment: TSC Battle Mage Staff (Hand) (tp)]
[05:18] [Sim tried to kill attachment: Az... Psychocat Purple Eyes (L) v2.0 (tp)] <<< was one or two times invisible after tp
[05:18] [Sim tried to kill attachment: TSC Battle Mage Priestess Belt (tp)] <<< sometimes becomes invisible after tp
[05:18] [Sim tried to kill attachment: TSC Battle Mage Priestess Panties (tp)]
[05:18] [Sim tried to kill attachment: TSC Battle Mage Priestess L Shoulder (tp)] <<< often invisible after tp
[05:18] [Sim tried to kill attachment: [CX] Creeper Ring - Gold ( Maitreya ) R (tp)]
[05:18] [Sim tried to kill attachment: TSC Battle Mage Priestess Skirt (tp)]
[05:18] [Sim tried to kill attachment: TSC Battle Mage Priestess Hood (tp)]
[05:18] [Sim tried to kill attachment: TSC Battle Mage Priestess L Gauntlet (tp)]
[05:18] [Sim tried to kill attachment: Az... Psychocat Purple Eyes (R) v2.0 (tp)] <<< was one or two times invisible after tp
[05:18] [Sim tried to kill attachment: TSC Battle Mage Priestess Boots (Skirt) (tp)]
[05:18] [Sim tried to kill attachment: TSC Battle Mage Priestess R Gauntlet (tp)]
[05:18] [Sim tried to kill attachment: PFC~Gjallarhorn - hand (tp)]
[05:18] [Sim tried to kill attachment: .LeLutka.Head.Simone 3.3 (tp)]
[05:18] [Sim tried to kill attachment: HUD [Thirst::Bloodlines] 4.5 (tp)]
[05:18] [Sim tried to kill attachment: Soft Body Illuminator (for material clothing, add) (tp)]
[05:18] [Sim tried to kill attachment: TSC Battle Mage Priestess Chest Chain (tp)]
[05:18] [Sim tried to kill attachment: TSC Battle Mage Priestess Horn (Halo) (tp)] <<< often invisible after tp
[05:18] [Sim tried to kill attachment: Maitreya Mesh Body - Lara V4.1 (tp)]

[05:18] [Second Life: Teleport completed from Arcadia (69,190,21)]

But my avatar looks complete after arrival. 

 

Not in the list but often inviesible too:

TSC Battle Mage Priestess R Shoulder


On one sim I did no rebake and tp to one of the 4 sims and tadaaa I were complete again.

Edited by Ehawee2016
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 1021 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...